Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Nope! Is TB3. I suspect the cable. Maybe too long...........
That's very possible. Passive Thunderbolt 3 cables are only about 0.5m long. To support full 40 Gbps speed over longer cables, a repeater chip is built into each end of the cable, which increases the cable's price. So we must specifically purchase a cable that supports 40 Gbps.
 
Just installed Big Sur on a Crucial BX500 SSD, no problem! No mini system freeze like with my Samsung Evo 970 Plus
IMG_1271.JPG
 
@fpazcas

Could you try shutting down, unplug power cable (or switch off power supply), wait 2 minutes and reboot ?

Your Asus board is probably not compatible (TB_HEADER) with Gigabyte GC-Titan-Ridge. Have you tried before patched version flashing ? Which behaviour had you with the original firmware on Windows ?

this can be possible?
 
@dgsga Does TB3 work after sleep & wake? If so, which GPU are you using? Considering this MB but the problem I had with the Z390 ITX was that with the flashed TB firmware, I lost access to TB3 after sleep wake. Tried it with RX 580, Vega 64 & 5700XT - same result.
I can confirm that it is status quo with Z390 itx MB - I have found no way to reconnect the TB device after sleep (tried a lot of combinations). So for now I have given up on sleep :).
I'm interested to see if anyone has managed to solve sleep with TB in an ITX form.

P.S - I use a flashed TB firmware with a SSDT.
 
What options are available under Thunderbolt Boot Support? If you only see Enabled and Disabled, have you tried both settings?

View attachment 494944

On Asus X99 we should use Thunderbolt header (THB_C) and we should not connect the middle and top pins.

Do you have any other Thunderbolt devices with which to test hot plug?

I have tried both options but with no luck
 
Slightly off topic, but since I upgraded my bios I've been unable to have the POST/FastBoot screen or the BIOS display at a higher resolution - it's back to the horrible stretched low resolution mess.

I remember a while ago it went to a much higher res after I'd disabled CSM support (I'm running a 5700xt), but this is still disabled.

I can't see anything obvious in the BIOS settings, nor can I find much info on this around the web. Anyone have any tips? My custom splash image looks like hot garbage.

EDIT: I've just tried Windows 8/10 WHQL mode instead of Other OS and I now have full resolution again.
-> Does this cause any side effects? The system seems to be booting fine.
 
Last edited:
Hello @CaseySJ ,
I have a flashed Thunderbolt and "Working" Z390 Designare i9 9900K , Vega 64.

Have 2 Universal Audio Devices. An Apollo Twin Audio interface and UAD 2 Satellite.

Works hotplug, works everything, but you cant connect both devices at the same time.
If you connect both, only one is detected. Happens the same in cascade mode or using the two Mobo ports.

Both appears in thunderbolt control panel in preferences, but not in universal audio control panel (only 1).

Any idea why could it be?
I Have tried all SMBIOS, different Bios versions, etc... Nothing changes....

I attach here all the files:

Thanks you so much!
 

Attachments

  • iMac de Pedro.ioreg
    28.8 MB · Views: 60
  • Send me iMac-de-Pedro.zip
    3.5 MB · Views: 54
  • 1.png
    1.png
    411.1 KB · Views: 74
  • 2.png
    2.png
    514.1 KB · Views: 71
  • 3.png
    3.png
    214 KB · Views: 72
Last edited:
Back
Top