Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jul 9, 2011
Messages
29
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900k
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
  1. Im using the Samsung 970 SSD and not the plus. In the other build I used a different ssd and it works
  2. I tried putting the card into a different slot but I only powered the unit off but didn’t switch the PSU off so I’ll try that next.
@CaseySJ I just moved the card into a different slot and. still no wifi... Bluetooth works but no wifi
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ I wonder if i need to update my EVO 970 Firmware
That is usually an issue with EVO 970 Plus, but not the standard EVO 970. However, try the following as well:
  • Option 1: Move EVO 970 to a the other M.2 slot.
    • Does WiFi work?
  • Option 2: If you have a spare SATA SSD, try cloning the EVO 970 to that SSD (including the EFI partition) and then:
    • Remove the EVO 970
    • Boot from the SATA SSD
    • Does WiFi work?
By the way, when you say WiFi doesn't work, what does that mean exactly?
  • You cannot see anything under System Information --> WiFI?
  • WiFi logo appears in menu bar, but you cannot scan for any SSIDs?
  • WiFi logo appears in menu bar and you can connect to an SSID, but transfer rate is zero?
  • Are you using a 2.4 GHz WiFi network or 5 GHz?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
But this will still require flashing the ROM of the AIC?
No. Flashing is only needed for enabling Thunderbolt Bus. The card will work without flashing.
 
Joined
Feb 10, 2019
Messages
285
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
No. Flashing is only needed for enabling Thunderbolt Bus. The card will work without flashing.
Oh.. now that is really worth checking out, i know a few would love to get more TB3 ports!
Thanks for all your work @CaseySJ, much appreciated!
 
Joined
Aug 4, 2020
Messages
46
Motherboard
Gygabite Z390 Designare
CPU
INTEL Core I7-9700K
Graphics
Sapphire Pulse Radeon RX 580 8GD5
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Fans should turn off. One of the steps in the Sleep Aid is the process of elimination, particularly with USB devices. Often we have to go through that process to determine what is interfering with sleep.

Thank you, @CaseySJ.

By "USB devices", do you mean external?
I have no external devices when making tries.
I have the mentioned internal USB for Fenvi.

I'll study carefully the whole Sleep Aid post, for elimination process.

However, also try this:
  • Run Activity Monitor and sort the list by % CPU.
  • Is any process pegging one of the CPUs with 100% CPU utilization (or close to 100%)?
    • Feel free to post a screenshot.

No. It's amazing Hackintosh world!
All is very low CPU usage.
I Attach image.
Thxx!

Screenshot 2020-08-16 at 21.23.22.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,182
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you, @CaseySJ.

By "USB devices", do you mean external?
I have no external devices when making tries.
I have the mentioned internal USB for Fenvi.
...
To continue the Process of Elimination, please try removing the Fenvi WiFi/BT card (but do not connect Corsair H115i). Before removing the Fenvi (or any other device on motherboard) we must shutdown the system and flip power switch on PSU to OFF.
 
Joined
Jan 4, 2015
Messages
411
Motherboard
Gigabyte Z390 Designare
CPU
i7 9700K
Graphics
RX 560
Mac
  1. MacBook Pro
Hello.
As I said earlier in this enormous post, I was successful in installingCatalina with that guide:


All is perfect, but I have two problems. Both of them I think are fully reported, but there are lot of solutions and I'm lost!

1. Sleep mode: Then I left the computer ON, for a long time (i.e. the whole night), at morning the fans are all ON.
Is there a way of entering in Sleep mode and switching OFF the fans?

2. In that situation, for recovering from Sleep, I have to press the computer "switch on" button for rebooting it. Keyboard and mouse don't respond.

3. When I force "Sleep mode" at the Apple system menu (apple logo), It goes to sleep but in less than a minute it restarts.

I can obviously switch off the computer every time instead of going to sleep, but what do you think solutions are?

Thank you for your help.
Fernando
If you are using Clover, uncheck the « Fix Shutdown » patch in ACPI section. On mine, the LEDS were on at shutdown. No problems with sleep however...
 

Rag

Joined
Jul 5, 2019
Messages
134
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
@CaseySJ

Thank you for your brilliant contribution. I've been running OC 0.60 perfectly since you made it available.
For let me know, is there a place, post, that would feed only new versions of the OC? Because in this post, since the beginning it is treated as a clover. Is there another specific post for OC users?
Thank you
 
Joined
Feb 7, 2012
Messages
276
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
Vega 56
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
This seems quite normal. Have you tried this on a real Mac?

You're right, my work MacBook Pro 15" 2018 also does the same, albeit slightly less. Seems like a OS fault then (that I can live with!)
 
Top