Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ I moved both the voltage jumpers to the 3.3v position as the instructions appear to state that. I measured the voltage with a multimeter as well to be sure.

Glad you’ve got it working.
Mine came with some bent pins and no instructions. I tested with both jumpers in the 3.3V position as well as only one jumper. It seemed to produce the same result. Are the instructions available online?
 
Joined
Oct 30, 2014
Messages
274
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
i9-9900k
Graphics
RX 580
Mac
  1. iMac
Some questions:
  • What is the make/model of the docking station?
  • Was it working properly prior to 10.15.5?
  • Which USB port is the dock station plugged into? Or is it connected through a Hub?
It's a Unitek USB3.1 Type C to dual SATA HDD with offline clone.
I did not have it on the previous build.
I've tried it in various 3.1 ports directly on the rear IO and hub.
 
Joined
Jan 5, 2020
Messages
271
Motherboard
Gigabyte Z390 Gaming M
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Pro
Should I boot into windows and update the FW to the latest version before attempting the ROM Flash with the raspberry pi or does it not matter because I am going to overwrite it anyway? Gigabyte has an updated posted on 3/26/20.


Thanks for the info about the clip, I ordered the cheap one and hopefully that will do the job for me.
 
Joined
Aug 10, 2012
Messages
63
Motherboard
Gigabyte Z390 Designare
CPU
i7-8700K
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Did anyone run into any issues trying to upgrade from Catalina 10.15.4 to 10.15.6 ? I have followed the instructions exactly as in https://www.tonymacx86.com/threads/...700k-amd-rx-580.267551/page-1729#post-2092711 to install 15.4 - by the way it was very nice and worked beautifully, thanks so much CaseySJ - and then it crashes when installing 15.6. My hardware is very similar Designare z390 (BIOS F8), i8700k, Sapphire Pulse Radeon RX580 8GB, 64GB memory 2666, 1TB Samsung 970 EVO, and Fenvi T919. Thanks so much for any ideas on upgrading to 10.15.6
 
Joined
Jun 15, 2013
Messages
38
Motherboard
Gigabyte Z390 Aorus Pro - Flashed
CPU
i9-9900K
Graphics
RX 580
@CaseySJ Want to update that the ATEN 7220 Thunderbolt Switch (TB2 with Apple TB2->TB3 adapters) is working well on my flashed Designaire running Catalina. The unit can be hot plugged. USB and display (DP and HDMI) work well. Unable to get it to work on the first Big Sur Public Beta.

Update Aug 13: After some time, the TB connected display started blanking out every 30-90 seconds. Installing Amphetamine initially helped, but the problem returned during CCC backups. Logfiles showed multiple errors coming from Spotlight. I realized that I had not excluded the Big Sur volumes from Spotlight, but the problem remained after exclusion (in retrospect, I should have rebuild the index but forgot).

Since Big Sur does not work with the ATEN 7220 in my testing, I decided to simplify and removed the Big Sur volume and uninstalled Amphetemene. The problem has gone, Spotlight errors are absent, and the system is working as expected (which is great if you want to share a single high quality display/camera/audio setup with two servers). At some point I will try again with Big Sur, but am 'stuck' on Catalina for the moment.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Should I boot into windows and update the FW to the latest version before attempting the ROM Flash with the raspberry pi or does it not matter because I am going to overwrite it anyway? Gigabyte has an updated posted on 3/26/20.


Thanks for the info about the clip, I ordered the cheap one and hopefully that will do the job for me.
It does not matter because it will be overwritten anyway.
 
Joined
Dec 16, 2019
Messages
9
Motherboard
z370 gigabyte aorus
CPU
intel 8700
Graphics
intel u630
Nope, all good to my devices.
Sure! "change _E17 to XE17 for TB hotplug" find 5F453137 replace 58453137
@StefanAM kool, thanks. :) so i gonna reflash the original firmware to the alpine ridge, change _E17 to XE17 and RP21 to RP05 (Z370).
do you have the THB_C cable normally connected to the board without jumping any pins?
thnks!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Did anyone run into any issues trying to upgrade from Catalina 10.15.4 to 10.15.6 ? I have followed the instructions exactly as in https://www.tonymacx86.com/threads/...700k-amd-rx-580.267551/page-1729#post-2092711 to install 15.4 - by the way it was very nice and worked beautifully, thanks so much CaseySJ - and then it crashes when installing 15.6. My hardware is very similar Designare z390 (BIOS F8), i8700k, Sapphire Pulse Radeon RX580 8GB, 64GB memory 2666, 1TB Samsung 970 EVO, and Fenvi T919. Thanks so much for any ideas on upgrading to 10.15.6
Hello @telicha,

Some questions:
  • At what point does it crash when installing 10.15.6?
    • During the initial boot?
    • During one of the subsequent reboots?
  • Have you tried adding the -v flag to Boot Arguments in order to see the detailed boot log?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Want to update that the ATEN 7220 Thunderbolt Switch (TB2 with Apple TB2->TB3 adapters) is working well on my flashed Designaire. USB and display (DP and HDMI) works well. Has to be plugged in on boot and doesn't seem to be working on hot-swap. For some reason it works on Catalina but not on Big Sur Beta.
Thanks! Will add this to Thunderbolt 3 Experiences in Post 1 shortly.
 
Joined
Feb 15, 2012
Messages
124
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ is it normal for thunderbolt NVM from same boards to be different?
After I dumped my board NVM and compared it to the patched one I found a lot of bytes changed. Would it be better to patch the dumped NVM or just patch the one posted here?
I have attached my dump. SHA 3e0184a538b6ad7323a8f6b536524becb8a89f6d
 

Attachments

  • designare.zip
    267.5 KB · Views: 55
Top