Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Apr 16, 2019
Messages
26
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radaeon VII
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
If you are planning to install (or reinstall) Catalina, simply follow the Catalina 10.15.4+ Mini-Guide, which is Clover Based, but can be replaced with OpenCore afterwards using the OpenCore mini-guide. Links to both guides are at the top of Post 1, just under the photograph.
I bit the bullet and followed the Catalina mini guide. Start to finish in 30 min and zero issues
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,899
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello @CaseySJ
nothing to do with Hackintosh but I would like to know if I can use this guide to dump an eeprom 95160
I believe EEPROMs are wired differently from SPI flash ROMs so I would not recommend that guide. Instead, the CH341a device might work. EEPROMs have to be placed in the specially marked slot on the CH341a.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,899
Motherboard
Asus Z690 ProArt Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I used the new lilu and weg that was posted and hdmi is indeed working, typing from it now, ive been doing a run through on this clean catalina install and i have almost everything working, bluetooth and wifi are good (azurewave/fenvi), hw acc seems good, only issue im getting is the computer does not appear to be able to wake from sleep, the fans stop when it goes to sleep and a click of the mouse wakes the machine, but the display never comes back, dont know whats up with that, could be the early lilu and weg

edit: when attempting to open premiere pro the system hard freezes, is there a known issue around that/solution?
lightroom c, photoshop and afteraffects all seem to work fine though i noted some slight sluggishness moving around the frame while zoomed in, could just be the 45mp raw photo taking the igpu to task, idk. Im attaching the crash report if that provides any insight, thanks

panic(cpu 2 caller 0xffffff80004469aa): Kernel trap at 0xffffff7f80e79803, type 0=divide error, registers:
CR0: 0x0000000080010033, CR2: 0xffffff839bb2d000, CR3: 0x000000089064c045, CR4: 0x00000000003626e0
RAX: 0x0000000000000000, RBX: 0xffffff80402d46c0, RCX: 0x0000000000000000, RDX: 0x0000000000000000
RSP: 0xffffff839a513920, RBP: 0xffffff839a513990, RSI: 0x0000000000000000, RDI: 0xffffff83793a7000
R8: 0x0000002604dcef67, R9: 0x0000000000000000, R10: 0x0000020000011000, R11: 0x00000000004f0004
R12: 0xffffff80574d7f10, R13: 0xffffff80402d46c0, R14: 0xffffff8000e2346c, R15: 0x0000000000000010
RFL: 0x0000000000010246, RIP: 0xffffff7f80e79803, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0xffffff839bb2d000, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 0

Backtrace (CPU 2), Frame : Return Address
0xffffff839a513380 : 0xffffff800031a65d mach_kernel : _handle_debugger_trap + 0x49d
0xffffff839a5133d0 : 0xffffff8000454a75 mach_kernel : _kdp_i386_trap + 0x155
0xffffff839a513410 : 0xffffff80004465fe mach_kernel : _kernel_trap + 0x4ee
0xffffff839a513460 : 0xffffff80002c0a40 mach_kernel : _return_from_trap + 0xe0
0xffffff839a513480 : 0xffffff8000319d27 mach_kernel : _DebuggerTrapWithState + 0x17
0xffffff839a513580 : 0xffffff800031a117 mach_kernel : _panic_trap_to_debugger + 0x227
0xffffff839a5135d0 : 0xffffff8000ac1abc mach_kernel : _panic + 0x54
0xffffff839a513640 : 0xffffff80004469aa mach_kernel : _sync_iss_to_iks + 0x2aa
0xffffff839a5137c0 : 0xffffff80004466a8 mach_kernel : _kernel_trap + 0x598
0xffffff839a513810 : 0xffffff80002c0a40 mach_kernel : _return_from_trap + 0xe0
0xffffff839a513830 : 0xffffff7f80e79803 com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient22registerClientBuffer64EP13IOAudioStreamyjj + 0x583
0xffffff839a513990 : 0xffffff7f80e77981 com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient26safeRegisterClientBuffer64EjPyjj + 0x75
0xffffff839a5139d0 : 0xffffff8000a2ea28 mach_kernel : __ZN13IOCommandGate9runActionEPFiP8OSObjectPvS2_S2_S2_ES2_S2_S2_S2_ + 0x138
0xffffff839a513a30 : 0xffffff7f80e79014 com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient21_registerBufferActionEP8OSObjectPvS2_S2_S2_ + 0x78
0xffffff839a513a70 : 0xffffff8000a2bcde mach_kernel : __ZN10IOWorkLoop9runActionEPFiP8OSObjectPvS2_S2_S2_ES1_S2_S2_S2_S2_ + 0x3e
0xffffff839a513ab0 : 0xffffff7f80e78f41 com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient16registerBuffer64EP13IOAudioStreamyjj + 0x81
0xffffff839a513b00 : 0xffffff7f80e78ce1 com.apple.iokit.IOAudioFamily : __ZN23IOAudioEngineUserClient14externalMethodEjP25IOExternalMethodArgumentsP24IOExternalMethodDispatchP8OSObjectPv + 0x117
0xffffff839a513b60 : 0xffffff8000a5cbf3 mach_kernel : _is_io_connect_method + 0x223
0xffffff839a513ca0 : 0xffffff80004035e2 mach_kernel : _iokit_server_routine + 0x4e62
0xffffff839a513db0 : 0xffffff80003203c8 mach_kernel : _ipc_kobject_server + 0x238
0xffffff839a513e10 : 0xffffff80002f6d15 mach_kernel : _ipc_kmsg_send + 0x135
0xffffff839a513e70 : 0xffffff800030db22 mach_kernel : _mach_msg_overwrite_trap + 0x2d2
0xffffff839a513f00 : 0xffffff800042c065 mach_kernel : _mach_call_munger64 + 0x205
0xffffff839a513fa0 : 0xffffff80002c1226 mach_kernel : _hndl_mach_scall64 + 0x16
Kernel Extensions in backtrace:
com.apple.iokit.IOAudioFamily(300.2)[FF04A21E-1A94-3252-9D31-C2859F555BC2]@0xffffff7f80e6c000->0xffffff7f80eaafff
dependency: com.apple.vecLib.kext(1.2.0)[1A3939E8-3FBC-3690-9B9A-767E2C96C7E3]@0xffffff7f80dc0000

BSD process name corresponding to current thread: coreaudiod
Boot args: keepsyms=1 debug=0x100 dart=0 shikigva=80 igfxfw=2

Mac OS version:
19G73

Kernel version:
Darwin Kernel Version 19.6.0: Sun Jul 5 00:43:10 PDT 2020; root:xnu-6153.141.1~9/RELEASE_X86_64
Kernel UUID: 783946EA-6F11-3647-BF90-787AEA14B954
__HIB text base: 0xffffff8000100000
System model name: iMac19,1 (Mac-AA95B1DDAB278B95)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 1129938215344
last loaded kext at 10338710130: >AudioAUUC 1.70 (addr 0xffffff7f83fa2000, size 32768)
last unloaded kext at 212476872306: com.osy86.USBWakeFixup 1 (addr 0xffffff7f84999000, size 16384)
loaded kexts:
com.uaudio.driver.UAFWAudio 4.3.1 47542
com.uaudio.driver.UAD2System 9.12.1
as.acidanthera.BrcmPatchRAM3 2.5.3
com.smalltree.driver.SmallTree!I82576 1.0.6
ru.joedm.SMCSuperIO 1.1.3
as.acidanthera.mieze.!IMausi 1.0.2
as.vit9696.SMCProcessor 1.1.3
as.vit9696.VirtualSMC 1.1.3
com.rehabman.driver.USBInjectAll 0.7.1
org.acidanthera.NVMeFix 1.0.2
as.vit9696.!AALC 1.4.9
as.vit9696.WhateverGreen 1.4.1
as.acidanthera.BrcmFirmwareStore 2.5.3
as.lvs1974.AirportBrcmFixup 2.0.7
as.vit9696.Lilu 1.4.6
>AudioAUUC 1.70
@AGDCPluginDisplayMetrics 5.2.6
@fileutil 20.036.15
@filesystems.autofs 3.0
>AGPM 111.4.4
>!APlatformEnabler 2.7.0d0
>X86PlatformShim 1.0.0
>!AUpstreamUserClient 3.6.8
>!AMCCSControl 1.14
>!AHDA 283.15
@private.KextAudit 1.0
>!A!IKBLGraphics 14.0.7
>!AHV 1
|IOUserEthernet 1.0.1
|IO!BSerialManager 7.0.6f7
>pmtelemetry 1
@Dont_Steal_Mac_OS_X 7.0.0
>!A!IPCHPMC 2.0.1
>!A!ICFLGraphicsFramebuffer 14.0.7
>!A!ISlowAdaptiveClocking 4.0.0
@filesystems.apfs 1412.141.1
>!AVirtIO 1.0
@filesystems.hfs.kext 522.100.5
@!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1
@BootCache 40
>AirPort.Brcm4360 1400.1.1
@!AFSCompression.!AFSCompressionTypeZlib 1.0.0
>AirPort.BrcmNIC 1400.1.1
>!AAHCIPort 341.140.1
>!ARTC 2.0
>!AACPIButtons 6.1
>!AHPET 1.8
>!ASMBIOS 2.1
>!AAPIC 1.7
$!AImage4 1
@nke.applicationfirewall 303
$TMSafetyNet 8
@!ASystemPolicy 2.0.0
|EndpointSecurity 1
@kext.triggers 1.0
>!ASMBus!C 1.0.18d1
|IOSMBus!F 1.1
>DspFuncLib 283.15
@kext.OSvKernDSPLib 529
|IOAVB!F 850.1
>!AHDA!C 283.15
|IOHDA!F 283.15
@plugin.IOgPTPPlugin 840.3
|IOEthernetAVB!C 1.1.0
|IONDRVSupport 576.1
|IOFireWire!F 4.7.5
|IOAccelerator!F2 438.7.3
@!AGPUWrangler 5.2.6
@!AGraphicsDeviceControl 5.2.6
|IOGraphics!F 576.1
|IOSlowAdaptiveClocking!F 1.0.0
>X86PlatformPlugin 1.0.0
>IOPlatformPlugin!F 6.0.0d8
|IOAHCIBlock!S 316.100.5
|Broadcom!BHost!CUSBTransport 7.0.6f7
|IO!BHost!CUSBTransport 7.0.6f7
|IO!BHost!CTransport 7.0.6f7
|IO!B!F 7.0.6f7
|IO!BPacketLogger 7.0.6f7
>usb.!UHub 1.2
>usb.networking 5.0.0
>usb.!UHostCompositeDevice 1.2
>!AThunderboltNHI 5.8.6
|IOThunderbolt!F 7.6.1
|IOAudio!F 300.2
@vecLib.kext 1.2.0
|IOSerial!F 11
|IOSurface 269.11
@filesystems.hfs.encodings.kext 1
|IO80211!F 1200.12.2b1
>mDNSOffloadUserClient 1.0.1b8
>corecapture 1.0.4
|IONVMe!F 2.1.0
|IOSkywalk!F 1
|IOAHCI!F 290.0.1
>usb.!UXHCIPCI 1.2
>usb.!UXHCI 1.2
>usb.!UHostPacketFilter 1.0
|IOUSB!F 900.4.2
>!AEFINVRAM 2.1
>!AEFIRuntime 2.1
|IOHID!F 2.0.0
$quarantine 4
$sandbox 300.0
@kext.!AMatch 1.0.0d1
>DiskImages 493.0.0
>!AFDEKeyStore 28.30
>!AEffaceable!S 1.0
>!ASSE 1.0
>!AKeyStore 2
>!UTDM 489.120.1
|IOSCSIBlockCommandsDevice 422.120.3
>!ACredentialManager 1.0
>KernelRelayHost 1
>!ASEPManager 1.0.1
>IOSlaveProcessor 1
|IOUSBMass!SDriver 157.140.1
|IOSCSIArchitectureModel!F 422.120.3
|IO!S!F 2.1
|IOUSBHost!F 1.2
>!UHostMergeProperties 1.2
>usb.!UCommon 1.0
>!ABusPower!C 1.0
|CoreAnalytics!F 1
>!AMobileFileIntegrity 1.0.5
@kext.CoreTrust 1
|IOTimeSync!F 840.3
|IONetworking!F 3.4
|IOReport!F 47
>!AACPIPlatform 6.1
>!ASMC 3.1.9
>watchdog 1
|IOPCI!F 2.9
|IOACPI!F 1.4
@kec.pthread 1
@kec.corecrypto 1.0
@kec.Libm 1

/SPOILER]
When we use iGPU to drive a monitor, some apps crash immediately upon launch. Final Cut Pro, iMovie, ACDSee Photo Editor for Mac being three of several examples. We have not found a solution, so an AMD GPU is strongly recommended when using such apps.
 
Joined
May 4, 2011
Messages
134
Motherboard
Gigabyte Z370-HD3
CPU
i7-8700K
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Air
The cheaper SOIC8 clip usually comes in a packet with some accessories, one of which is in the photo below. The regular jumper wires fit onto the accessory.

View attachment 481665

I guess I got ripped off by Amazon then - there were no ribbon cables, just the clamp. Oh well.

edit: argh - i can see that they sell it with and without ribbon cables and i didn't notice that when ordering. well, tomorrow i should have the headers/cables i bought separately anyway.
 
Last edited:
Joined
May 15, 2020
Messages
1,188
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
I believe EEPROMs are wired differently from SPI flash ROMs so I would not recommend that guide. Instead, the CH341a device might work. EEPROMs have to be placed in the specially marked slot on the CH341a.
worked thanks
IMG_0971.JPG
 
Joined
May 15, 2020
Messages
1,188
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Did you use CH341a or Raspberry Pi?
CH341a (with sopic 8 when I bought the RP4 for the TB firmware flash)
In 2h only 2 times I was able to get the same dump, very difficult :banghead:
Winbond took me only 1 attempt
 
Joined
May 15, 2020
Messages
1,188
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Hello @CaseySJ
In OC 0.6 Pre-release change log's page I can see "OcDevicePathLib: Added a workaround for PCI0 with 0x1 _UID"
Do you know what are the benefits for us?

Capture d’écran 2020-07-26 à 10.59.55.png
 
Joined
Aug 5, 2019
Messages
9
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
GTX 1080 Ti + RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
Hi, I have done the installation of mac os 10.15.6 perfectly, but I have a problem with the colors of the monitor that are tending to yellow and in general are very saturated,can someone help me ?

-My video card is a RX 580 and is connected via HDMI to the monitor, the model of the monitor is XB272, I tried to also connect to other monitors, also via DP, but have the same problem....
 
Joined
Jul 15, 2019
Messages
172
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
Sapphire RX580 Pulse 8GB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@CaseySJ Regarding no onboard HDMI on Catalina...
Thanks! I'm using Catalina. Is there any known workaround? Can I downgrade?

Do I need to perform a clean installation of Mojave? Or is there a safe downgrade path?
Would you know if this is something that could be fixed by new versions of WEG?
Would OpenCore help?
 
Top