Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Wow, didn't expect such a prompt response. How do you have time to compile and share all this knowledge and then provide individual support? So generous of you. Hate to take advantage of your kindness, but could I confirm that the new SSDT I will need to replace the older one is SSDT-TBOLT3-RP05-V3.alm?

Huge thanks to you in advance!

Ver
Correct, except that the file extension is .aml instead of .alm. Just a typo, I know. AML = ACPI Machine Language.

Enabling Thunderbolt Bus through a firmware flash incurs risk of electrical and physical damage. Near-sighted individuals have the advantage here, but they should remove corrective lenses in order to focus their eyes more easily and without fatigue when attaching the SOIC clip. Far-sighted individuals should, of course, wear corrective lenses or delegate the clipping/unclipping task to someone one. Steady hands are also necessary because there are tiny surface mount resistors in the immediate vicinity that may be dislodged if the SOIC clip strikes them.

It's very important to read the relevant guides two or three times in advance. Shortcuts can lead to disaster. Impatience can lead to disaster. Frustration can lead to disaster.

After attaching the SOIC clip, if the Winbond chip is not readable for any reason, do not force it. Try very gently to reseat the SOIC clip, and if the problem persists STOP immediately and let us know. Take a coffee break or even call it a day and resume the next morning. This gives time to decompress and reflect on what might be going wrong.

Remember, most people will encounter chip-read failures, but they will eventually figure out the solution. If you use the simple circuit board with a single resistor and capacitor (please see Quick Reference Guide, section 8.2.6 -- I'll let you figure out where that section is :)) you should have the least amount of difficulty. But if you take a shortcut (i.e. not use the circuit) you may still succeed, but may run into some difficulty.

And finally, if you succeed, we'll welcome you into the Society of Mad Scientists! :)
 
Joined
Feb 3, 2011
Messages
65
Motherboard
Gigabyte Designaire z390
CPU
i9-9990
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
USB dropping out here with 0.7.1 on Mojave. Rolled back to 0.6.9 for s*&ts and giggles- will report any success.
update: same story USB still dropping out . About to give up- I'm used to the PPC macs of yesteryear that used to crash all the time but have never been nostalgic about trying to get work done with them. The siren song of windows beckons.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
update: same story USB still dropping out . About to give up- I'm used to the PPC macs of yesteryear that used to crash all the time but have never been nostalgic about trying to get work done with them. The siren song of windows beckons.
I have two Designare Z390 systems and one Z490 Vision D. Not once have I encountered a USB instability problem. It didn't happen when I was running Mojave. And it hasn't happened with Catalina. My first Z390 Designare has been in commission since November 2018 without a single USB instability problem.

Someone recently found USB instability issues in macOS and also after installing and running Windows. That led them to replace the motherboard, after which the problem went away.

Are the USB ports stable in Windows or Linux?

Maybe the problem is happening with a certain USB device or combination of devices?

Maybe the problem is happening with a particular use case (i.e. is it reproducible when repeating a certain sequence of actions)?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
*** Are you experiencing USB port stability problems? ***


There have been an uncomfortable number of complaints about USB port instability. If you're experiencing this problem, please answer the questions below in the hopes that some common thread or clue might emerge.

  • Are you running Mojave or Catalina?
  • Are you using Clover or OpenCore?
  • Are you using the USB SSDT from this thread (SSDT-UIAC-Z390-DESIGNARE-V7.aml)?
  • Are you using USBPorts.kext instead?
  • What is the make/model of your power supply?
  • What USB devices are connected when instability occurs?
    • Which of these devices has its own power supply?
  • What Thunderbolt devices are connected when USB instability occurs?
  • When USB instability occurs, what exactly happens on screen? What do you experience?
  • Does the instability go away on its own? Does it require a reboot?
  • How often does it occur? Every time you use the computer? Every N hours? Every N minutes?
 
Joined
Jun 12, 2015
Messages
88
Motherboard
GIGABYTE Z390 Designare
CPU
i7-9900K
Graphics
RX580
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi CaseySJ,
I have a problem,
my AMD rx580 is sapphire brand, but video Proc is showing graphic n/a for both h264 and HEVC as shown in below screen shot,

Screen Shot 2020-06-14 at 9.10.01 PM.png

I tried solution in first post, and added dummy141.kext zip to my EFI but still the same,
attached my EFI,
can you check
 

Attachments

  • EFI.zip
    4.7 MB · Views: 54
Last edited:
Joined
Sep 10, 2019
Messages
1
Motherboard
Gigabyte Z390
CPU
Intel i9 9900K
Graphics
Vega 64
Hey CaseySJ,

I was updating my system from Mac OS Mojave to Catalina and disabled the Kext's and updated whatevergreen and once I restart my hackintosh to boot into the update it gets stuck on the screen I attached. Any ideas on how to resolve the problem?

Thanks in advance
 

Attachments

  • Screenshot Hackintosh.jpg
    Screenshot Hackintosh.jpg
    1.6 MB · Views: 61

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi CaseySJ,
I have a problem,
my AMD rx580 is sapphire brand, but video Proc is showing graphic n/a for both h264 and HEVC as shown in below screen shot,

View attachment 476085
I tried solution in first post, and added dummy141.kext zip to my EFI but still the same,
attached my EFI,
can you check
Have you tried clicking the two "refresh" icons:
Screen Shot 2020-06-14 at 9.10.01 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey CaseySJ,

I was updating my system from Mac OS Mojave to Catalina and disabled the Kext's and updated whatevergreen and once I restart my hackintosh to boot into the update it gets stuck on the screen I attached. Any ideas on how to resolve the problem?

Thanks in advance
Hello @ethanmaxim,

Are you following this guide for upgrading from Mojave to Catalina?
 
Joined
Jan 12, 2019
Messages
60
Motherboard
Asus X99-A II
CPU
i7-6800K
Graphics
Radeon VII
Hello @Petros,

Regarding the DSDT.aml that you posted, is it the original DSDT.aml from your Asus X99A-II and was it exported in either of these 2 ways?
  • From Clover Boot Menu by pressing F4
  • From Hackintool --> Utilities --> Dump ACPI
The Asus Z370-A Prime II SSDT should not be able to activate your Thunderbolt Bus. Are you certain that Thunderbolt Bus is activated using the Asus Z370-A Prime II SSDT? If so, I have no explanation for that because:
  • Your DSDT.aml shows that there is no function named GPCB() that returns the base address of MMIO.
  • Your DSDT.aml shows that there is no device RP08.PXSX.
  • Because the Asus Z370-A Prime II SSDT is calling GPCB() and deleting device RP08.PXSX, neither of which exists, it means this particular SSDT should be rejected by macOS during boot, or it should generate numerous ACPI errors.


I got the DSDT from Clover with F2
The card stopped working about 6 months ago and I believe in my attempts to fix it I downloaded the wrong firmware from Intel's site and not Asus's and somehow did the update, I'm not 100% sure about this but do recall doing something that stupid. Now in windows in the about dialog box I get "No information" in the controller info. I guess I somehow bricked it as whatever I plug doesn't get recognised either in Windows or OSX(even though, as I mentioned, I get Thunderbolt Bus and device tree in IOReg).

Since I ordered a programmer cable and should arrive any day now, can I flash the chip with the original firmware using my Rpi? In windows I get an error when trying to do it using the Asus utility.
 
Top