Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
May 27, 2020
Messages
17
Motherboard
Gigabyte arous z390e pro wifi
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Couldn’t have done it with out ya! Thank you! Everything works. But I can't get the it to stay asleep. It wakes up after 2 seconds
 

Attachments

  • 79D946C2-5074-4C93-A479-8D156E78979A.jpeg
    79D946C2-5074-4C93-A479-8D156E78979A.jpeg
    2 MB · Views: 54
Joined
Jul 23, 2019
Messages
136
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX 590
Yup - and more and more people keep popping in with this same USB dropout issue (myself included). Unfortunately .... no one seems to have any clue. :/

It happens to me once or twice a week
 
Joined
May 10, 2010
Messages
36
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
Asus ROG Strix RX5700 XT
@CaseSJ - Just want to say thank you for this incredibly detailed guide, without which my custom hardline watercooling loop build would not have been possible. Even though I did not use your EFI package as-is, I had learnt so much from reading this 2,254 pages long thread.

IMG_3142.jpg


Unobvious problems to watch out for...
  • To unlock writing to MSR 0xE2 register for native NVRAM support, initially I went for the latest beta firmware version F9H (as of this writing, the latest official BIOS version is F9B which is locked.) However, while it could boot into the O/S perfectly fine, I could not ESC into the BIOS setup screen -- got a blank screen from both the dGPU and iGPU DisplayPort output. I ended up downgrading into F9G, which is also still in beta as of this writing, and everything worked fine.
  • After a period of flawless burn-in, it suddenly began to fail at POST after switching power off and back on. The BIOS error status LED's on the motherboard was stuck at the red "DRAM" LED in an infinite reboot cycle. BIOS reset pins, holding power button down trick to get into backup BIOS etc. did absolutely nothing. Taking out some/all RAM modules also didn't seem to work. I switched off the power, removed the onboard battery, and let it sit overnight -- same error next morning.
  • After many frustrating hours of trial-and-error, I noticed an important detail which I had missed until now: version numbers printed on the sticker on the RAM modules are different! I bought 2 separate packs of 2 x 16G each, and apparently there is no way to figure out without first opening the packaging -- I got both version 4.31 and 5.32, and only 5.32 is officially supported according to Gigabyte's Memory Support List. Thanks God, I was able to get pass POST once again with 2 sticks of 5.32! Moral of the story: read the fineprints...
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Couldn’t have done it with out ya! Thank you! Everything works. But I can't get the it to stay asleep. It wakes up after 2 seconds.
Is the Corsair all-in-one liquid cooler connected to the internal USB 2 header (F_USB)? If so, try disconnecting it (temporarily) to see if the system can stay asleep.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseSJ - Just want to say thank you for this incredibly detailed guide, without which my custom hardline watercooling loop build would not have been possible. Even though I did not use your EFI package as-is, I had learnt so much from reading this 2,254 pages long thread.

View attachment 475782
Just awesome! Love that distro-block/pump/res thing with two sets of radiator loops. (What is the make/model of that?) Finally someone posts a photo of their custom hardline build... :) I haven't personally graduated to that level as I mentioned once before in this thread, namely:
  • Freshman: air cooler
  • Sophomore: all-in-one liquid cooler
  • Junior: custom soft tubing
  • Senior: custom hardline tubing
I've been stuck at the sophomore level... :)
 
Joined
May 8, 2020
Messages
8
Motherboard
Z390 Designare
CPU
I5 9600k
Graphics
RX580 8gb
Even though I did not use your EFI package as-is, I had learnt so much from reading this 2,254 pages long thread.
I can not link for EFI folder to this guide. Please tell me where you can find it.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I can not link for EFI folder to this guide. Please tell me where you can find it.
There is no Clover EFI for this build, only OpenCore EFI in the OpenCore Mini Guide.
 
Joined
May 8, 2020
Messages
8
Motherboard
Z390 Designare
CPU
I5 9600k
Graphics
RX580 8gb
@CaseSJ
Big thanks! I specifically bought z390 Designare and i5 9600k for use this build! :)
 
Joined
Mar 2, 2011
Messages
166
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
I've been having a recurring issue.. happens once every day or two, where ALL of my USB ports just go offline.
Unplugging and replugging usb cables doesn't help. all I can do is reboot.

Anyone else seen this?
Yes. Was happening to me. I rolled back USBInjectall.kext to 0.7.1 and the issue is gone for me.
 
Top