Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Just a quick thanks to CaseySJ and other contributors for the amazing work on the Catalina fresh installation. My machine seems to be doing well and no major issues ( i9-9900k, z390, 5700XT).

Quick question, I'm using a RX 5700 XT. Will that override integrated graphics when using the AMD config.plist? Just wondering if I can use the integrated graphics for background tasks such as codec exports in Premiere, etc.
With config-AMD-GPU.plist you will get the best of both worlds: both AMD GPU and iGPU will be used for various tasks. Although iGPU will not drive a display monitor, its compute units will be fully used.
 
Joined
Jan 30, 2013
Messages
27
Motherboard
Gigabyte Z390 Designare (F9H BIOS)
CPU
i7-9700k
Graphics
RX 5700
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hey again, fellas. Just a little update on my USB freeze issue: I visited my local MicroCenter this morning and picked up a WD Blue 1TB SSD, cloned installation from the M.2 onto the SSD, reset SMBIOS and other necessary information, and it's now been running all day without any hiccups, everything working 100%.

Will probably leave it running tonight as well to test the longevity of it, as I will deliver it Wednesday morning this week. I know M.2 drives in general are "supposed" to work, but I think some are hit and miss. A lot of guys have had good luck with Inland M.2 hack builds, but I really believe I wasn't one of them. The M.2 drive we have was erased and partitioned to be used solely as extra storage in his system. Hope this helps someone out in the future! Thanks guys!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
No soft power table, I'm not using HWmonitor but I have the intel power gadget that I use to monitor the temp and the frequency.
Right now there is no overclock and temp are everywhere.
Attach some details and the high temps were on using safari on CNN page....
Something else happened, I try the Vega back and happens the same and update the bios to F9b with same effect.
Those temperatures are too high:
  • Is the CPU cooler working? Are all radiator and case fans running?
  • Is the cooler properly attached to the CPU? Was a thin amount of thermal paste used?
  • If you have Windows on this machine, HWINFO64 can be used to monitor temperatures. This can tell us whether the high temperature problem exists only in macOS or also in Windows.
HWInfo.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,127
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey again, fellas. Just a little update on my USB freeze issue: I visited my local MicroCenter this morning and picked up a WD Blue 1TB SSD, cloned installation from the M.2 onto the SSD, reset SMBIOS and other necessary information, and it's now been running all day without any hiccups, everything working 100%.

Will probably leave it running tonight as well to test the longevity of it, as I will deliver it Wednesday morning this week. I know M.2 drives in general are "supposed" to work, but I think some are hit and miss. A lot of guys have had good luck with Inland M.2 hack builds, but I really believe I wasn't one of them. The M.2 drive we have was erased and partitioned to be used solely as extra storage in his system. Hope this helps someone out in the future! Thanks guys!
Please let us know if the system remains stable. If so, I can add an appropriate warning.
 
Joined
Jul 1, 2013
Messages
7
Motherboard
Gigabyte Designare Z390
CPU
i9-9900k
Graphics
5700XT
Mac
  1. MacBook Pro
With config-AMD-GPU.plist you will get the best of both worlds: both AMD GPU and iGPU will be used for various tasks. Although iGPU will not drive a display monitor, its compute units will be fully used.

Sounds great, I do see it listed under PCI section system report. Thanks again, it was a breeze getting my build to 10.15.5!
 
Joined
Feb 3, 2011
Messages
65
Motherboard
Gigabyte Designaire z390
CPU
i9-9990
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi,

I purchased a SATA card because my two M.2 drives are eating up the internal ports/channels, and I needed more storage. I bought a iocrest 4 port SATA PCIe card:

https://www.newegg.com/syba-si-pex40057-sata-iii/p/N82E16816124060

It's Marvell 88se9230 based which I thought AHCI_3rdParty_SATA.kext would cover. It only works for a few minutes with a couple drives connected to it then the system reports the drives as unplugged. I'd try it on a different slot but my cooler is blocking the only other available one unless I move my graphics card which I'm hesitant to do. Can anyone recommend some troubleshooting steps or a known good card? I'm running 10.14.6. Thanks in advance.

Could also be faulty:
 
Joined
Jul 24, 2019
Messages
28
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hi,

I purchased a SATA card because my two m2 drives are eating up the internal ports/channels, and I needed more storage. I bought a iocrest 4 port SATA PCIe card:

https://www.newegg.com/syba-si-pex40057-sata-iii/p/N82E16816124060

It's Marvell 88se9230 based which I thought AHCI_3rdParty_SATA.kext would cover. It only works for a few minutes with a couple drives connected to it then the system reports the drives as unplugged. I'd try it on a different slot but my cooler is blocking the only other available one unless I move my graphics card which I'm hesitant to do. Can anyone recommend some troubleshooting steps or a known good card? I'm running 10.14.6. Thanks in advance.

Could also be faulty:

I was running this with no problems whatsoever - worked OTB without any additional tweaking.

https://www.amazon.ca/gp/product/B07MV23HJH/?tag=tonymacx86c0c-20

It's no longer in my Designare system but it's been working flawlessly in another hackintosh I'm using as a server.
 
Joined
Jun 7, 2020
Messages
13
Motherboard
Gigabyte Designare Z390-F9b
CPU
i9-9900K
Graphics
RX 580
When this keyboard/mouse lockup happens during Mojave "Welcome" screen, please try disconnecting both the mouse and keyboard, and connecting them into a USB 3 port (any of the blue, red, or yellow USB ports).
Casey, You're Genius !!! okay Mojave is Successfully installed.
could you tell me what Kexts should I pick with multibeast 11.3.0-4?
I got gigabyte Designare z390 with I9 AMD sapphire Radeon RX580, corsair Force mp510 NVME, Corsair Vengeance LPX 4x16 gb ram and highpoint rocket raid 2720SGL with 8 attached crucial MX500 Drives to it
UEFI boot mode? or Legacy?

Thank you SO very much!!
 
Joined
Dec 8, 2018
Messages
12
Motherboard
Gigabyte z390 Designare
CPU
i7-8700K
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Replacing OsxAptioFix2Drv-free2000 with OcQuirks / FwRuntimeServices fixed kernel panic on every shutdown for me and I finally installed latest updates on Mojave 14.6. Maybe it will be helpful for others.
 
Top