Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Aug 29, 2012
Messages
143
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Thx! I literally just did exactly this. and it worked!
Big thanks to Casey and all of you for your help! <3
I too noticed USBInjectAll 0.7.5 killed bluetooth for me. I can confirm rolling back to 0.7.1 re-enabled bluetooth.
 
Joined
Jul 23, 2019
Messages
136
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX 590
But I only saw F9h there, I saved F9g last week, please see attachment.

Just installed BIOS F9h, seems OK , CFG unlock option available
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,952
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,952
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,

Hope you are staying healthy, safe and sane.

I recently purchased the Fenvi T919 that you recommended in this guide and followed your directions for the installation and applied proper patches on the EFI directory. The computer booted up fine and worked with out flaws for 3-4 days but recently started giving issues on boot. I am attaching a photo here

Luckily I have bootable clone that is up to date and able to boot into that, but wondering if you can provide some tips for troubleshooting. The clone drive sees the WiFi/BT card and works with out issues. I can even clone back to my original boot drive and can boot from that drive, but only once for some reason. If I try booting from the Original drive again, after cloning from the backup, I have issues.

Happy to send along my EFI folder if you think that will help.

Thanks,
andre
Hello @andre4000,

This might indicate the need for a CMOS Reset. Have you already tried that? After a CMOS Reset we need to:
  • Configure BIOS parameters again, starting with Load Optimized Defaults
  • Unlock MSR 0xE2 again (if you had unlocked it before)
Please let me know if the problem persists. Another option, though less "scientific" is to connect PEG to power supply. PEG connector is located just below the six SATA ports.

Also, the Fenvi FV-T919 does not require any change to EFI whatsoever. It is truly plug-and-play. It may also be a good idea to undo any changes that were made to the EFI.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,952
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello
My device does not recognize the iPad Pro 2020 via type C
what the problem
Hello @qadri,

We have intentionally disabled USB 2 protocol on all of the USB-C/TB3 ports in order to maintain a limit of 15 USB ports. Only USB 3 and Thunderbolt devices will work.

The USB-C cable that comes in the iPad Pro box does not support USB 3. You have 3 options:
  • Use any Thunderbolt 3 cable
  • Purchase a USB-C to USB-C cable that supports USB 3.x (see bottom of Note 5 below)
  • Use a USB-C to USB Type A cable that supports USB 3.x
This is explained in the Catalina build guides as follows:

Screen Shot 2020-06-03 at 2.59.06 PM.png
 
Joined
Apr 18, 2011
Messages
1,435
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
So I went ahead and flashed my GC-Titan Ridge to NVM50 and the USB controller doesn't appear without something plugged in at boot. Is anyone else experiencing this?

Screen Shot 2020-06-03 at 17.03.52.png


I assume this is what you were talking about @CaseySJ on this post?

 
Joined
Feb 5, 2013
Messages
1,307
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
6800 XT
Mac
  1. iMac
So,
Unfortunately this is a known problem.

@CaseySJ:

Is this a problem that can only be solved by the jumper cable? If the jumper cable that shorts some pins on the TRidge card was plugged in at boot, then with nothing plugged in (other than the jumper cable), the TB tree would appear?

Of course, not everyone wants to do that, especially if they have the proper power connectors for the TR card. As long as TB works on the Titan Ridge when I do plug things in and the tree appears, that would be good enough for me.
 
Joined
May 15, 2020
Messages
1,302
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Congratulations! Welcome to the club (of mad scientists). :)
:lol: Thank you Sir!!
I'v definitely better UAD Thunderbolt experience with sample rates!

I just switched SMBIOS to iMacPro1,1 to have Apple TV and the all DRM stuff, and because I've i9-9900KF I guess this SMBIOS is better in my case. I'll let you know if I see some differences.

Where can I send you some beers? :mrgreen:

Really your guides are very easy to understand, thank you very much, you helped me a lot for my first hackintosh and computer build!
 
Top