[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Sure, it's a good idea to see if the bootable backup disk still works.

Also try CMOS Reset and configure BIOS parameters once again. This will also require unlocking MSR 0xE2 if it was previously unlocked.
Thank you for your guidance, CaseySJ, I will immediately follow this line of thought
It seems on-board HDMI port no longer works in Catalina. I'm not sure if this is due to WhateverGreen or macOS itself.
I asked about this earlier and got no response. But here's my fix for now (using external TV, via HDMI, on iGPU):

Change platform ID like so (if you're using Clover)

Mine was 07009B3E previously.

Everything works as before for me now. Please test and report if it works for you too!
The output from kextstat shows that USBInjectAll is not loaded. USB ports will not be configured properly until that driver works. If you recently copied it to /Library/Extensions, then please run Kext Utility to rebuild kernel cache.

  • Move all Hackintosh kexts to CLOVER/kexts/Other
  • Delete them from /Library/Extensions
  • Rebuild kernel cache by running Kext Utility
"Hackintosh" kexts are the ones listed in the table at the top of this post:

No joy so far. (still no hs11/12 in ioReg)
What I did:
Moved all hackintosh kexts to efi/...other as advised, removed from l/e (also re-checked if I had sth at s/l/e), then emptied trash, rebuilt kext cache and restarted.
After a first boot to black screen after the clover selection it booted well on second try and from there on.
But still the USBinjectall seems to be missing in kextstat. (although its there in the EFI where it should be)
Reinstalled it and rebuilt kext cache to be sure, but it still does seem to not inject/find USBinjectall...

Its def. there, but not recognized as installed by hackintool (for double checking purpose) as well.
its there.pngbut not found.png

Thx for all the hints so far! What can/should I do now? I'm pretty clueless rn.

Edit: Solved by rolling back to 0.7.3!
Last edited:
which firmware did you use did you maybe have a link or the file?
firmware of what? My Thundebolt chip originally have NVME33 version which Elias modified and published here "DESIGNARE-Z390-NVM33-Elias64Fr.bin" for this Z390 Designare on-board Titan Ridge Thunderbolt. Then I flashed it to my Motherboard's Winbond chip with a Raspberry Pi 4 using this guide and this.
@CaseySJ I wanted to bring to your attention a fun little app I've been using for sometime for updating Kext. It's from the main German hackintosh forum and has served me very, very well. It has quite a few other features worth tearing through too. It's also in English :)