Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Mar 2, 2015
Messages
78
Motherboard
Gigabyte Designare Z390
CPU
i7-8086K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Great thread, any Ultrafine 5K users out there with this set-up looking for some help...

When booting into macOS using Clover I have no luck after the bootloader screen (just a black screen) even when removing DP no.2 from the Alpine ridge card.

Not sure if its related to a memory issue, I’m not using any EFI fixes or iGPU modifications so that could be a route to go down. Any thoughts or feedback on this welcome.

Here are my specs:

Z390 Designare
i7-8086K
Sapphire Pulse Radeon RX 580
Alpine Ridge (2 DP connected to the RX 580 and USB-C connected to LG Ultrafine 5K)
LG Ultrafine 5K

SMBIOS iMac 18,3
macOS Catalina 10.15.5 – Clover r5118
 
Joined
Jun 13, 2019
Messages
271
Motherboard
ASUS ProArt Z690-CREATOR WIFI
CPU
i9-12900K
Graphics
RX 6900 XT
Great thread, any Ultrafine 5K users out there with this set-up looking for some help...

When booting into macOS using Clover I have no luck after the bootloader screen (just a black screen) even when removing DP no.2 from the Alpine ridge card.

Not sure if its related to a memory issue, I’m not using any EFI fixes or iGPU modifications so that could be a route to go down. Any thoughts or feedback on this welcome.

Here are my specs:

Z390 Designare
i7-8086K
Sapphire Pulse Radeon RX 580
Alpine Ridge (2 DP connected to the RX 580 and USB-C connected to LG Ultrafine 5K)
LG Ultrafine 5K

SMBIOS iMac 18,3
macOS Catalina 10.15.5 – Clover r5118

I've had a lot of issues with mine and the workaround for most has been to disable my iGPU and switch to iMacPro1,1, unfortunately.
 
Joined
Mar 2, 2015
Messages
78
Motherboard
Gigabyte Designare Z390
CPU
i7-8086K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I've had a lot of issues with mine and the workaround for most has been to disable my iGPU and switch to iMacPro1,1, unfortunately.
Thanks, I'll try that.

Any notable differences with changing to iMacPro1,1 SMBIOS apart from sacrificing Sidecar support?
 
Joined
Jun 13, 2019
Messages
271
Motherboard
ASUS ProArt Z690-CREATOR WIFI
CPU
i9-12900K
Graphics
RX 6900 XT
Thanks, I'll try that.

Any notable differences with changing to iMacPro1,1 SMBIOS apart from sacrificing Sidecar support?

Not in my case. Some people actually get better GPU performance that way.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,915
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I attached it below.

Excuse me, Sir, but i really don't understand: I cannot boot into Mojave, because I don't have it already installed anywhere. I am trying to do it right now. That's why I am bothering you.. All I have at this moment is USB "install Mojave" stick and target SSD (GPT formatted) with an error, which you can see on pic in my previous post.
Where can I find /Library/Extensions folder? Which kernel cache do you mean?
(I thought that kernel is a part of installed OS, so now I could have it only on my High Sierra laptop, where I prepare 'Mojave install stuff' to run it on Z390 mobo. But how rebuilding kernel cache on my laptop may help me install Mojave on other machine? I am trying to understand, but I don't get it. That's why I am asking all those questions. Please be patient.)
Okay, because you're performing a fresh installation of Mojave, please try the attached CLOVER folder.
  • Download and unzip the file
  • Rename the folder to CLOVER
  • Backup the existing CLOVER folder on USB flash disk and replace it with the new one
  • Boot with USB flash disk (press F12 during BIOS splash screen to open the BIOS boot menu and choose the USB)
  • At the Clover Boot Menu, choose the option to continue with the macOS installation
Ideally, however, there should be an entry called Boot macOS Install from <name of SSD>. I know you currently have a "Prebooter" entry. If that still fails, please try the installation again by selecting the first boot option from Clover Boot Menu (the USB disk --> Boot Install macOS from macOS Install).
 

Attachments

  • CLOVER-jwpb.zip
    2.2 MB · Views: 58
Joined
Mar 2, 2015
Messages
78
Motherboard
Gigabyte Designare Z390
CPU
i7-8086K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I've had a lot of issues with mine and the workaround for most has been to disable my iGPU and switch to iMacPro1,1, unfortunately.

I just tried changing my SMBIOS to iMacPro1,1 and made sure that Internal Graphics was disabled on my BIOS settings. Still black screen on boot.

Right now I've got two DP cables going from my Alpine Ridge to my Pulse RX 580 and then a USB-C cable from the Ridge to the LG 5K display, as mentioned Windows works well enough I think 4K output but can't get past last stage on macOS.

Do you mind to share your exact set-up just so I can compare? Interested to know if you're using any extra EFI fixes, kexts, boot flags or BIOS settings I may have missed.

Thanks for your help
 
Joined
Jun 13, 2019
Messages
271
Motherboard
ASUS ProArt Z690-CREATOR WIFI
CPU
i9-12900K
Graphics
RX 6900 XT
I just tried changing my SMBIOS to iMacPro1,1 and made sure that Internal Graphics was disabled on my BIOS settings. Still black screen on boot.

Right now I've got two DP cables going from my Alpine Ridge to my Pulse RX 580 and then a USB-C cable from the Ridge to the LG 5K display, as mentioned Windows works well enough I think 4K output but can't get past last stage on macOS.

Do you mind to share your exact set-up just so I can compare? Interested to know if you're using any extra EFI fixes, kexts, boot flags or BIOS settings I may have missed.

Thanks for your help

Does it boot from the Designare built in Titan Ridge? I do not have any Alpine Ridge cards in. Don't think I have any special fixes or tweaks beyond disabling iGPU. The reason I did that is I could run into boot failures, and also crash upon waking from sleep.
 
Joined
Aug 25, 2013
Messages
101
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
RX 6900 XT + UHD630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi all,

Beware of a bug with 10.15.5 update!

If you make a first backup with Carbon Copy Cloner, it won't be bootable!


The solution is to use the CCC 5.1.18 beta as detailed in the link above. The bombish developper is pretty mad against Apple, lol.

If you previously made a backup in 10.15.4, it seems ok tho.

hello,
Is this bug also affecting SuperDuper! ?
thank you!
 
Joined
Feb 19, 2018
Messages
795
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
hello,
Is this bug also affecting SuperDuper! ?
thank you!

A quick look on their web site would have answered that for you. You should at least try a little bit of self help.

Look here.
 
Joined
Mar 2, 2015
Messages
78
Motherboard
Gigabyte Designare Z390
CPU
i7-8086K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Does it boot from the Designare built in Titan Ridge? I do not have any Alpine Ridge cards in. Don't think I have any special fixes or tweaks beyond disabling iGPU. The reason I did that is I could run into boot failures, and also crash upon waking from sleep.
So actually it seems I'm not using the native Thunderbolt from the Designare Z390 - just the Alpine Ridge and RX580 GPU. Do you think it could be worth trying using the motherboard's Thunderbolt port for the USB-C to the monitor?
 
Top