Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Feb 10, 2020
Messages
56
Motherboard
Z390 Designare
CPU
i9-9900
Graphics
RX 5700 XT
Hi Casey,

I noticed your update to fresh install Catalina 10.15.4 you have not included the FSInject.efi which was previously included in 10.15.3. Is it okay to remove as I am updated to 10.15.4? Does it have something to do with updating Clover for kext injection?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,943
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,

I noticed your update to fresh install Catalina 10.15.4 you have not included the FSInject.efi which was previously included in 10.15.3. Is it okay to remove as I am updated to 10.15.4? Does it have something to do with updating Clover for kext injection?
Correct -- FSInject is (was) used to inject kexts from Clover's kext folder, but this is no longer required.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,943
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** Running Catalina and Want to Change CPU Name in About this Mac? **

Please see posts 21 and 22 here:
Before:
Screen Shot 2020-05-30 at 2.35.31 AM.png

After:
Screen Shot 2020-05-30 at 2.37.21 AM.png
 
Last edited:
Joined
Dec 6, 2010
Messages
68
Motherboard
AsRock Z490 ITX/TB3
CPU
i7 107000K
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Thanks @mango1122 and @dgsga => That worked! Turns out my TB3 issues were because of SSDT not the actual NVM version. Either way, I guess it doesn't hurt to be on the latest firmware. Now onto some testing this weekend :)

@dgsga Just out of curiosity, do you use a Vega 56/64 or a Navi card (5700 series) with this motherboard?
Unfortunately I don't. Still using my trusty Sapphire R9 380 as it does all I need! As my final contribution to "Alpine Mania" here is the current SSDT I'm using for the Z370itx/ac stripped to the bone and with all OperationRegion addresses calculated so no ACPI delay on startup. Note that I added a PINI condition to RP05.INI in the bios built-in DSDT so you no longer need the _INI to XINI ACPI rename.
 

Attachments

  • SSDT-TbtOnPch.dsl.zip
    4.3 KB · Views: 84
Last edited:
Joined
Mar 21, 2011
Messages
820
Motherboard
GA-Z390-Aorus Pro
CPU
i7-9700K
Graphics
RX 590
Unfortunately I don't. Still using my trusty Sapphire R9 380 as it does all I need! As my final contribution to "Alpine Mania" here is the current SSDT I'm using for the Z370itx/ac stripped to the bone and with all OperationRegion addresses calculated so no ACPI delay on startup. Note that I added a PINI condition to RP05.INI in the bios built-in DSDT so you no longer need the _INI to XINI ACPI rename.
I have an old Shuttle case (m-ITX) that has an H81 board in it that I've been wanting to upgrade. I took a quick look at the specs for your m-ITX and it looks like the only M.2 slot is an e-key slot for wifi, and no b-key slot or m-key slot for an SSD. is that right?
thanks!
 
Joined
Apr 1, 2011
Messages
348
Motherboard
Gigabyte z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. iOS
Hi All,
After a couple days using my new system, mostly organizing my data while a LOT of drives hooked up, it stops recognizing my keyboard and mouse and plugging them back in and switching does not help. A lot of my USB drives go offline as well. I’ve tried using decent powered usb hubs and different ports and still have the issue. The system is still running fine when this happens but I don't have any input. This isn’t happening in windows. Any tips or suggestions? Thanks in advance.
This happens to me about once a month. I've not been able to nail down a single cause that creates this condition.
 
Last edited:
Joined
Aug 22, 2014
Messages
342
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi @CaseySJ I followed the AppleIntelWiFi instructions (kext is in download folder, WiFi name and password entered in kext, ran the commands, removed my Fenvii card from computer), but I can't get it to work. Any suggestions on how to continue? See attached screenshot for the CNVW and WiFi settings.
 

Attachments

  • Screenshot 2020-05-30 at 14.19.34.png
    Screenshot 2020-05-30 at 14.19.34.png
    237 KB · Views: 84
  • Screenshot 2020-05-30 at 14.24.52.png
    Screenshot 2020-05-30 at 14.24.52.png
    233.5 KB · Views: 82
Last edited:
Joined
Feb 6, 2020
Messages
10
Motherboard
HP Probook 4540s
CPU
i5 3320M
Graphics
HD 4000, 1366x768
Mobile Phone
  1. Android
Following the Catalina 10.15.4 Mini-Guide to install 10.14.6 was really good idea. :) Thank you, @CaseySJ!
The "end randomseed" error appears no more.
Now I am on this step:
(...)
  • Then begin the macOS installer.
  • There might be one or two reboots.
    • Each time the system reboots, press F12 at BIOS splash screen to open the BIOS Boot Menu.
    • Select the USB install disk from the BIOS Boot Menu.
  • Now you'll be back at the Clover Boot Menu:
    • Whenever you see a boot option called Boot macOS Install from Catalina or Boot macOS Install from Catalina - Data, choose that option.
    • Do not select the USB disk.
(...)

After first reboot at this step on Clover screen I have 5 options:

1. Boot macOs Install from Install macOS Mojave (my USB stick)
2. Boot FileVault Prebooter from Preboot (this and next are on my target SSD)
3. Boot macOS Install Prebooter from Preboot
4. Boot macOS from Mojave
5. Boot Recovery from Recovery

There is no option like Boot macOS Install from Mojave or Boot macOS Install from Mojave - Data on my target drive. (Mojave instead of Catalina from quoted above, of course)

Does it mean, that I missed something?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,943
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Following the Catalina 10.15.4 Mini-Guide to install 10.14.6 was really good idea. :) Thank you, @CaseySJ!
The "end randomseed" error appears no more.
Now I am on this step:


After first reboot at this step on Clover screen I have 5 options:

1. Boot macOs Install from Install macOS Mojave (my USB stick)
2. Boot FileVault Prebooter from Preboot (this and next are on my target SSD)
3. Boot macOS Install Prebooter from Preboot
4. Boot macOS from Mojave
5. Boot Recovery from Recovery

There is no option like Boot macOS Install from Mojave or Boot macOS Install from Mojave - Data on my target drive. (Mojave instead of Catalina from quoted above, of course)

Does it mean, that I missed something?
Good question -- this sometimes happens. In this case, please choose option 3: Boot macOS Install Prebooter from Preboot.
 
Top