Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi CaseySJ

What is the purpose of the BIOS folder that contains the SMCHelper.efi file?
Better to remove SMCHelper.efi file?
Does our motherboard use the UEFI folder?

Sorry for the many questions ...

Thanks
The drivers/BIOS folder is for older, non-EFI motherboards. We can delete the entire BIOS folder.
 
Joined
Jun 8, 2019
Messages
101
Motherboard
Z490 Vision D
CPU
i9-10900K
Graphics
Sapphire RX Vega64
Mac
  1. MacBook Pro
@CaseySJ Continuing "Alpine Mania", here's an issue I found when trying the SSDT (thanks to @dgsga and @mango1122) Only approach on the ASRock Z390 Phantom Gaming ITX

TLDR => I was getting a "Thunderbolt failed to power on.." KP (see attached file) after wake-from-sleep when using Vega 64/5700XT. Strangely, I wasn't getting this when using iGPU (9900k) Only and RX 480/580. More details in the post here. So for some reason, I had issues with Vega & Navi but not with Polaris.

I'm not sure if there's any correlation between the TB SSDT & AMD Drivers but it is really strange. Did you come across this issue on your board w/the 5700XT?
 

Attachments

  • Z390_TB3_KPv2 (1).txt
    2.6 KB · Views: 24
  • SSDT-TbtOnPch_PINI (2).aml
    4.1 KB · Views: 30
Joined
May 19, 2017
Messages
22
Motherboard
Gigabyte Aorus Ultra Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
Looks like Internal Graphics might be disabled in BIOS. It must be set to Enabled (not Auto).

Finally got time to fiddle again. It was set to auto, enabled it and it works great now.
 
Joined
Mar 26, 2020
Messages
37
Motherboard
Gigabyte Z390 Designare
CPU
Intel i9 9900K
Graphics
Sapphire Nitro+ RX 580 8GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
The Intel CNVi card works well in Windows, but not so well (yet) in macOS despite the experimental AppleIntel drivers. I cannot in any good conscience recommend the CNVi in macOS at this time.
I know it is in Beta stage for MacOS, I have only the Bluetooth kexts installed and they seem to work fine. I disabled the card (BT & WiFi) from "Device Manager" in Windows, tested the restart from Windows into MacOS and for now I don't get any Kernel Panic after boot. I'll keep you updated!

Important to know: these KPs were present also when I didn't had the CNVi Bluetooth kext installed.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Keyboards only work when connected to a USB A port on the motherboard. I have 10 other devices ranging from hard drive docks, sound cards, DACs, speakers and so on that work fine when connected to the TB3 HUB.
When you say "keyboards" only work with USB Type-A ports, have you tried multiple different models?

Feel free to compress and upload your CLOVER folder with serial numbers removed from SMBIOS. However, also check BIOS configuration and perhaps update to latest firmware (F9b), which will also flush out the system.

Additionally, when all else fails it's a good idea to find a spare cheap SSD (128GB or 256GB) and install clean copy of macOS, then retest the keyboard situation. If keyboards work on the fresh install, we can conclude that perhaps one of the USB HID drivers in the main installation has been corrupted.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Continuing "Alpine Mania", here's an issue I found when trying the SSDT (thanks to @dgsga and @mango1122) Only approach on the ASRock Z390 Phantom Gaming ITX

TLDR => I was getting a "Thunderbolt failed to power on.." KP (see attached file) after wake-from-sleep when using Vega 64/5700XT. Strangely, I wasn't getting this when using iGPU (9900k) Only and RX 480/580. More details in the post here. So for some reason, I had issues with Vega & Navi but not with Polaris.

I'm not sure if there's any correlation between the TB SSDT & AMD Drivers but it is really strange. Did you come across this issue on your board w/the 5700XT?
Alas I've only tested the TbtOnPCH method with RX 580. The system with RX 5700 XT has a flashed on-board Titan Ridge. However, when using IGPU or RX 480/580, do Thunderbolt devices wake successfully from sleep? Or do they disconnect?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,184
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...
Important to know: these KPs were present also when I didn't had the CNVi Bluetooth kext installed.
Even without the beta AppleIntelBluetooth kext, macOS will natively detect the Intel Bluetooth module and attempt to use it. That's why in macOS we disable USB port HS14 so macOS won't see the Intel Bluetooth module.
 
Joined
Apr 30, 2020
Messages
8
Motherboard
Designare z390
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Firstly. Thank you so so much @CaseySJ ! I got my first Hackintosh up and running on Mojave a couple of days ago following your guide and even though I know basically nothing about computers it even made sense to me. You my friend are a legend.

The one piece of the puzzle that I can't get to work is the Bluetooth on my Fenvi T-919. WiFi is working fine. I spent the last few hours looking through the forum and can see tons of people with the same experience but I couldn't work out how to fix it. Maybe I'm missing something but it seems like the computer is recognizing the card just fine.

EDIT: Absolute dum dum over here. I hadn't screwed in the antennas on the card properly. Gave them a tighten and everything is fine after that.

On a separate note though. Has anyone else been having issues with Preview? Often when I try and open an image like a JPEG I just get the spinning beach ball and then preview wont respond and I have to force quit.

Any help here would be much appreciated.
 
Last edited:
Joined
Jun 8, 2019
Messages
101
Motherboard
Z490 Vision D
CPU
i9-10900K
Graphics
Sapphire RX Vega64
Mac
  1. MacBook Pro
Alas I've only tested the TbtOnPCH method with RX 580. The system with RX 5700 XT has a flashed on-board Titan Ridge. However, when using IGPU or RX 480/580, do Thunderbolt devices wake successfully from sleep? Or do they disconnect?

Ahh I see. Yes when using iGPU or RX480/580 Thunderbolt devices sleep and wake successfully.
 
Joined
Feb 19, 2018
Messages
796
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Is there a Motherboard that works just as well as the z390 Deisgnare? I have one build using that, but I am getting ready to build a second and it is sold out everywhere. I need to have something that has thunderbolt.

Thanks!

My Designare broke a week ago, one of the parts just fell off the board - very weird. They have a 3 year guarantee and Amazon said they would send me another one. The delivery was originally going to be mid-end June due to a shortage of them. However, every day Amazon emailed me bringing forward the expected delivery date. As of yesterday I should expect it to be delivered this Tuesday, 18th May.

So if it is saying temporarily out of stock, it may be worth buying one from Amazon and seeing when it is likely to be delivered. You won't lose out as you can cancel at any time and they don't take your money until they dispatch. Give it a few days and see if they bring the date closer as they have with mine.

I'm in the UK but will probably be the same wherever you are.
 
Top