Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I came to upgrade to Catalina 10.15.4, and I updated to clover r5109 as that was the latest, and I think it broke my system, or maybe it was something else I did.
After installing, on r5107 it worked fine.
I was editing my config.plist to take out the port limit patches as I had them enabled still with an SSDT.
I replaced my SSDT V7 which had one port disabled, to the original one in your post.
I updated to r5109, and my system stopped working. Never seen this kind of error before, so I wasn't sure where to start.
I attached my config.plist and an image of all my kexts, patched, drivers files
Any help is grateful
Does it still work with Clover 5107?
 
Joined
Sep 8, 2018
Messages
87
Motherboard
Asus Z690-Creator WIFI
CPU
i7-12700K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@yabusa, I have noticed that my hackintosh shows the same boot error. Today I updated my EFI with the newest kexts (AppleALC, WEG, Lilu, VirtualSMC, etc., with kext updater), Clover 5109 and the newest OCQuirks revision 22 driver from github. After I remove the OCQuirks driver and install the older OCQuirks driver revision 20 (from my rescue USB-stick) on my hackintosh started without any failure. But there's one (cosmetic) thing in the Cover boot menu since I installed clover 5109: my customized theme icons no longer displayed in the boot menu. Now the standard icons of the installed theme are shown instead.
 
Joined
Jul 13, 2016
Messages
2,941
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
I came to upgrade to Catalina 10.15.4, and I updated to clover r5109 as that was the latest, and I think it broke my system, or maybe it was something else I did.
After installing, on r5107 it worked fine.
I was editing my config.plist to take out the port limit patches as I had them enabled still with an SSDT.
I replaced my SSDT V7 which had one port disabled, to the original one in your post.
I updated to r5109, and my system stopped working. Never seen this kind of error before, so I wasn't sure where to start.
I attached my config.plist and an image of all my kexts, patched, drivers files
Any help is grateful

I had a similar error. When I updated with OpenCore, the system did, however, boot. Once booted I updated my OpenCore, and everything seems peachie since. Yesterday, my GF updated her system to 15.4, and she got the same error. I did what I normally do and that is get the latest pastrychef EFI since her system is the same. Everything booted and worked without error, version 5107. I have however removed WEG from both systems and use Pike R. Blackscreen patch.
 
Joined
Feb 19, 2018
Messages
795
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Silly question, but how do I downgrade without being able to boot in?

Do you have a rescue USB stick with your previous EFI with 5107 on it? If so then boot from that. Always a good idea to make/update a bootable USB to your latest working EFI before upgrading.

5108 broke my system so I think I'll give 5109 a miss for the time being.
 
Joined
Feb 10, 2020
Messages
64
Motherboard
Z490 ASUS Maximus XII Formula
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
According to @rj510, both WiFi and Bluetooth performance of the Fenvi FV-T919 might be improved if we use these additional kexts:
  • BrcmPatchRAM3.kext
  • BrcmBluetoothInjector.kext
  • AirportBrcmFixup.kext
  • BT4LEContinuityFixup.kext
  • BrcmFirmwareData.kext
Attached ZIP contains all five. If you'd like to try this, simply copy all kexts to CLOVER/kexts/Other and reboot.

I will try it tomorrow and describe the results here. Thank you very much
 
Joined
Jun 18, 2010
Messages
130
Motherboard
z390 Designaire
CPU
i9-9900K
Graphics
AMD Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. Lisa
  5. Plus
  6. Portable
  7. Power Mac
  8. PowerBook
  9. Quadra
Mobile Phone
  1. iOS
After I remove the OCQuirks driver and install the older OCQuirks driver revision 20 (from my rescue USB-stick) on my hackintosh started without any failure. But there's one (cosmetic) thing in the Cover boot menu since I installed clover 5109:
ocquirks v22 requires edits to the plist to function. Theme rendering in 5109 has changed. Many older themes no longer render correctly.
 

Attachments

  • ocquirksv22.plist.zip
    895 bytes · Views: 63

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,719
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ I just noticed a nifty little feature in OC Configurator but I imagine you already did. Either way, I think it's worth noting. In Device Properties there is a drop down list of your PCI devices. That beats the hell out of other methods of importing devices. Less steps, less room for error.

...and before anyone chimes in about not using OC Config. I think thats a dated idea and like most of this community you need to try things yourself and help things improve by reporting issues. Early versions did in fact hurt things. From my experiences, 056 to now have been excellent with the app.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,923
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ I just noticed a nifty little feature in OC Configurator but I imagine you already did. Either way, I think it's worth noting. In Device Properties there is a drop down list of your PCI devices. That beats the hell out of other methods of importing devices. Less steps, less room for error.

...and before anyone chimes in about not using OC Config. I think thats a dated idea and like most of this community you need to try things yourself and help things improve by reporting issues. Early versions did in fact hurt things. From my experiences, 056 to now have been excellent with the app.
That's exactly how I created the two OpenCore 0.5.7 ZIP files yesterday and today. The devices --> properties section was created simply by using the pop-up menu. There are other pop-up menus too!
 
Top