Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
So I should not use the USB hub that is on my desk?
It is best not to use a USB hub. Reading and writing to the SPI ROM Chip requires 3.3V and a certain amount of current. If the USB hub is self-powered and devoid of other devices then it might be reliable. The more devices on the hub, the more risk you take.
What is the final step after you have checked that everything is being read correctly and is the same?
Guide is still under construction so additional details are coming soon.
Glad you wrote the little guide because I am not one to triple check stuff without being told.

Also SSDT to edit it would I just need to edit it to RP21 similar to the other SSDT for TB3?
I'll provide some guidelines for this as well.
 
Joined
Jul 13, 2016
Messages
2,937
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
It is best not to use a USB hub. Reading and writing to the SPI ROM Chip requires 3.3V and a certain amount of current. If the USB hub is self-powered and devoid of other devices then it might be reliable. The more devices on the hub, the more risk you take.

Guide is still under construction so additional details are coming soon.

I'll provide some guidelines for this as well.

Cool nothing is plugged into it and it is powered but I get the cable extension.

Yea I noticed that after I made the post I guess I should have edited my post.

Cool thanks.
 
Joined
Dec 21, 2013
Messages
68
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
RX6900XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Plus
Mobile Phone
  1. iOS
Please note that USB 3 devices will connect and function properly on the two Thunderbolt USB-C ports on the rear IO panel. However:
  • The USB-C cable must support USB 3.0 protocol. Believe it or not, most USB-C cables do not support USB 3. So look for a cable that specifically mentions USB 3 support such as this one.
  • The device (iPad, iPhone, etc.) must also support USB 3.0 protocol. As far as I know, only iPad Pros support USB 3.0, and only with third-party USB-C cables with USB 3.x support. The USB-C cable that comes in the box with an iPad Pro does not support USB 3.x.
Thank you for the info....
Another question.... The F_USB31C port on MB is only disable the 2.0 part, so if I connect on NZXT 510 (USB C) port it should work as USB 3.1 with no issues..Correct????
Regarding the 5700XT....any big difference on compatibility between the XT and VII....As I said before I lost my VII and I'm using the Vega64 on temporary base...So, I'm looking for the pros and cons on both ones regarding stability and performance on our machine....Saw in your profile that you are using the XT....

Thanks again
 
Last edited:
Joined
Mar 3, 2020
Messages
3
Motherboard
Z390x Thunderbolt
CPU
9600k
Graphics
RX Pro 580x
Thanks for the reply and sorry for the “New-Bin-Tosh” post I’ll read up on everything it’s been a while. :)
 
Joined
Sep 12, 2012
Messages
27
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you for the info....
Another question.... The F_USB31C port on MB is only disable the 2.0 part, so if I connect on NZXT 510 (USB C) port it should work as USB 3.1 with no issues..Correct????
Regarding the 5700XT....any big difference on compatibility between the XT and VII....As I said before I lost my VII and I'm using the Vega64 on temporary base...So, I'm looking for the pros and cons on both ones regarding stability and performance on our machine....Saw in your profile that you are using the XT....

Thanks again
Yes the USB-C port on the top of NZXT H510 will work with USB 3.x devices when you connect the cable to F_USB31C header on motherboard. I have the NZXT H510 Elite so I can confirm this.
 
Joined
Sep 12, 2012
Messages
27
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
You might have seen this already...

If anyone has successfully enabled Audio/Video Bridging (AVB), please let us know. I vaguely recall a discussion of this earlier in this thread.

UPDATE: Please see this post.
View attachment 452798
awesome, thank you, that's exactly what I've been looking for ! I ordered on Amazon an adaptor early today, so I'll test it tomorrow ! I guess when I'll plug the console on it, the missing thick box would appears. I'll let you know. thanks again
 
Joined
Dec 1, 2014
Messages
70
Motherboard
Z390
CPU
i9-9900K
Graphics
RX 580
First of all. Thanks for the great help. Especially Casey.
I never had a weirder install than this install of catalina.
System blacks out when installing. Had to wait till system shuts down. Powered up again and welcome screen appeared. Installed normally after that with one reboot. Weird.

System works now. Only thing is shut down is really slow. Is this normal?
Auto boot isnt working. How do I enable this in clover boot?

Thanks for all the help!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
First of all. Thanks for the great help. Especially Casey.
I never had a weirder install than this install of catalina.
System blacks out when installing. Had to wait till system shuts down. Powered up again and welcome screen appeared. Installed normally after that with one reboot. Weird.
Perseverance pays off. Glad to hear it.
System works now. Only thing is shut down is really slow. Is this normal?
This might be okay. If shutdown is still slow after one week then let us know.
Auto boot isnt working. How do I enable this in clover boot?
...
What do you mean by "auto boot"? Do you want to skip the Clover Boot Menu? If so, try setting Timeout to 0 in Clover Configurator --> Boot.
 
Joined
Dec 1, 2014
Messages
70
Motherboard
Z390
CPU
i9-9900K
Graphics
RX 580
Perseverance pays off. Glad to hear it.

This might be okay. If shutdown is still slow after one week then let us know.

What do you mean by "auto boot"? Do you want to skip the Clover Boot Menu? If so, try setting Timeout to 0 in Clover Configurator --> Boot.

Normally clover boots automaticly. Now I have to select the drive with the mouse.

And I dont think the slow shut down will go away. Should be fast now when using NVME? Or am I Wrong?

Thanks for the help Casey. Really Dont know how you can stll stay positive with people like me... ;)

In clover configurator I tried this:
- Default boot volume: Last booted volume ( isnt any other I can select)
- Legacy boot volume

Time out is on 5 sec....Dont get any time out or count down.

I Changed time out to 0. The same as before. Need to activate the volume/ssd with the mouse.
 
Last edited:
Top