Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Feb 19, 2018
Messages
795
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Will the benefits outweigh the effort? It all seems like a lot or work, I'm unsure if there is something I am missing?

If you are not a Thunderbolt user then you aren't missing anything. However, if you are then you are missing quite a bit.
 
Joined
Apr 4, 2011
Messages
106
Motherboard
Gigabyte Designare Z390 - F6
CPU
i5-9600
Graphics
Sapphire Pulse RX550
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
You may post your config.plist with serial numbers removed from SMBIOS and I'll see what might be wrong with the frame buffer patch.

Thanks Casey. Attached is my config.plist

I've attached the one using the framebuffer patch from this guide as that was my last working config before updating to Catalina.

Further to my testing: if I remove device properties (i.e. framebuffer patch), enable Graphics->Inject Intel, and (as iGPU is fully supported) leave Fake ID IntelGFX blank - then the system works fine with TB-DP monitor, however if I hot plug the HDMI cable the whole system crashes and reboots instantly. With this config the system won't boot at all either. At least if I used the framebuffer hotpluging the HDMI didn't cause a reboot!

In case it matters I'm using WEG 1.3.6 + Lilu 1.4.1
 

Attachments

  • config.plist
    8.9 KB · Views: 60
Joined
Feb 10, 2020
Messages
9
Motherboard
Gigabyte Z390 Designaire
CPU
i7 9700k
Graphics
RX 580 8GB
WOW! I've found the solution!
Just change the shikigva=32 to shikivga=80.
and done!

P E R F E C T!

now everything works like a charm.
Thanks guys, im very happy!
Thanks, my airplay and sidecar never worked. Changing to that value worked!!
 
Joined
May 3, 2019
Messages
51
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Sapphire Nitro+ RX 5700 XT
Mac
  1. MacBook Air
Classic Mac
  1. iBook
Mobile Phone
  1. iOS
@CaseySJ, I’m thinking on implementing a way to remote start and login to my hackintosh (used this build guide with same mobo) and I saw you mentioned IPMI somewhere. Is this a possibility? The problem is I usually turn off the computer when I go to class but when I need to access it, it’s always off. I switched to Ethernet recently instead of my spotty WiFi card. I know I can’t use wake for network access too. Not sure a way to get around that besides Raspberry Pi to send keystrokes to wake it up... thoughts?
 
Joined
Feb 15, 2020
Messages
5
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
If you are not a Thunderbolt user then you aren't missing anything. However, if you are then you are missing quite a bit.

I've completed my first ever PC build - a Hackintosh! Many thanks to everyone who's contributed to this extensive build guide. My build seems to work perfectly except I'm not sure the Thunderbolt is working. I purchased a USB-C to Lightning cable to connect my iPad/iPhones, but none of those devices show up using the cable in any of the three available USB-C ports. I read through a lot of threads re: Thunderbolt problems, but most were unrelated to my issue, many not even using the Designare board like I'm using. It sounds like it should be working natively according to everyone here. I am getting power through them, but no data. I may be missing something simple perhaps? Any help is appreciated. I was really looking forward to the Thunderbolt/USB-C feature. Thanks in advance.

Specs:

i9 9900K CPU
Radeon RX 580 GPU
64GB 3600Mhz RAM
Zalman CPU Liquid Cooler
Gigabyte Designare Z390 MB
850w EVGA Power Supply
Corsair Carbide Case
Fenvi Wifi/Bluetooth
3 Case Fans/Cables
2TB Pioneer NVMe M.2
4TB HDD
 

Attachments

  • Archive.zip
    521.4 KB · Views: 69
Joined
Mar 3, 2020
Messages
3
Motherboard
Z390x Thunderbolt
CPU
9600k
Graphics
RX Pro 580x
Hello,

I have followed the site for years but just never the right time. I saw this post and success with a focusrite Thunderbolt 2pre. I have the Focusrite 8pre
TB1. Killer latency on my old ass Mb pro but I’ve just about had it w Apple locking us in a cage with limited choices and the gaping void between prosumer and pro in price. My goals are to run Logic X and have a decent 4K editing system for video. Sorry for the blind post CaseyJ can you direct me to your build instructions I’m grabbing up the parts for this build over the weekend. Not concerned about WiFi or anything other than Logic and the 8-pre focusrite at first. I’ll try to work out the 4K edit side on the PC w premier. Anyways sorry for the rambling I just blew 4 hours getting OBS working on a Dell G7 with a horrible conflicts between 630 intel and the GTX. This throttling issue makes this laptop unreliable and frankly a POS joke. Disabled one GPU in the DM and presto. I was like ahh my old girlfriend the PC I had literally left it behind running XP, pro fools and an AMD yes that long ago. Ancient stuff but believe it my old rack DAW still boots and runs 32 tracks of pro tools and waves stuff easy. The kicker though is all AAX 32 bit stuff I paid for light years ago. Can’t justify a MacBook Pro, or an Icrap and frankly the stock logic plug ins and the workflow of Logic tickles my fancy over the clunky pro tools 12 and all of the nightmares that go along with it. So here I go guys I’m back on the wagon after 10 years of no PC but before that I built my first daw in 1998 and literally hundreds after that so my old hands are scared from cheap new egg Lian Li edges and old Intel 865 chipsets with Zalmans. Lol My how time fly’s and we are still needing to do this ultra tweak stuff just to get what we want? Anyways I appreciate all the hard work and effort that goes into a site like this. I’m looking forward to this challenge. 8-Cores w 32g of ram hoping more than enough juice. I can still do 32 tracks full plug ins on the MacBook with 16x inputs low latency but it stalls on the heavier instruments with high sample polyphony.
 
Joined
Mar 3, 2020
Messages
3
Motherboard
Z390x Thunderbolt
CPU
9600k
Graphics
RX Pro 580x
I was reading other pc motherboard users having a bios revision issue. Also deleting the drivers in the device manager booted into windows 10. Reboot it reinstalls the drivers then soft boot into Mac OS. Maybe search the bios updates related to yours. Power w no data can be firmware controller chip. Correct bios and drivers on the Win 10 side. Worth a try to get that stuff tested and working fully as a PC...???
 
Joined
Jul 13, 2016
Messages
2,942
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
I'm thinking of creating an illustrated Mini-Guide using low-cost parts so that anyone wishing to flash their cards can do so cheaply, privately, and assume all risk for themselves. :)
  • Low-cost version is this onefrom Amazon.
    • This device can be used under Windows and also under macOS using flashrom in Terminal.

Ordered the low-cost version Hope you can get a mini guide going even without illustration... Ready to assume all risk!
 
Joined
Jul 13, 2016
Messages
2,942
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
I've completed my first ever PC build - a Hackintosh! Many thanks to everyone who's contributed to this extensive build guide. My build seems to work perfectly except I'm not sure the Thunderbolt is working. I purchased a USB-C to Lightning cable to connect my iPad/iPhones, but none of those devices show up using the cable in any of the three available USB-C ports. I read through a lot of threads re: Thunderbolt problems, but most were unrelated to my issue, many not even using the Designare board like I'm using. It sounds like it should be working natively according to everyone here. I am getting power through them, but no data. I may be missing something simple perhaps? Any help is appreciated. I was really looking forward to the Thunderbolt/USB-C feature. Thanks in advance.

Specs:

i9 9900K CPU
Radeon RX 580 GPU
64GB 3600Mhz RAM
Zalman CPU Liquid Cooler
Gigabyte Designare Z390 MB
850w EVGA Power Supply
Corsair Carbide Case
Fenvi Wifi/Bluetooth
3 Case Fans/Cables
2TB Pioneer NVMe M.2
4TB HDD

Thunderbolt and USB -C are not the samething so getting a USB-C to Lighting is not Thunderbolt 3. That said the USB C/Thunderbolt 3 ports on your board are only TB3 in per this guide. If you go back to the first page and look at the image of the back of the board you will see a note that says the USB2.0 is turned off on the USB-C ports to meet the 15 port per controller limitation. Pretty sure that iPhones/Ipads work on USB2.0.
 
Joined
Feb 15, 2020
Messages
5
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Thunderbolt and USB -C are not the samething so getting a USB-C to Lighting is not Thunderbolt 3. That said the USB C/Thunderbolt 3 ports on your board are only TB3 in per this guide. If you go back to the first page and look at the image of the back of the board you will see a note that says the USB2.0 is turned off on the USB-C ports to meet the 15 port per controller limitation. Pretty sure that iPhones/Ipads work on USB2.0.

Thanks for that clarification. I was looking to connect my iPad to the Hackintosh using Duet through the USB-C to Lightning cable for maximum throughput, but I see what you mean after looking into it now... Thunderbolt and USB-C are two different things. It looks like Thunderbolt is used mainly for display output, peripherals, network interfaces, etc. Appreciate the quick response! Many thanks
 
Top