Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jan 3, 2020
Messages
16
Motherboard
z390 designare
CPU
i9-9900k
Graphics
Vega 64
We fully expect your next post to be a carbon copy of this post! :)
OK, as requested:
Thank you for an excellent build guide. I followed the Catalina Mini Guide and it works flawlessly.
OMG I can't believe it, built the beast this evening, fired it up, modified BIOS, ran 10.15.2 first try!

UNBELIEVABLE. I will start testing everything tonight tomorrow, THANKS EVERYONE...
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,124
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
OMG I can't believe it, built the beast this evening, fired it up, modified BIOS, ran 10.15.2 first try!

UNBELIEVABLE. I will start testing everything tonight tomorrow, THANKS EVERYONE...
Glad to hear it! Reading and rereading and re-rereading can pay off! Of course, if you do encounter problems, just let us know.
 
Joined
Sep 20, 2013
Messages
1,115
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
It would seem you're seeing the exact same thing I am. I can attest to the problem still existing in 10.15.4 beta 1. Who knows when or if they will push out a driver update that fixes the issues. I didn't realize users of eGPUs were experiencing problems with these cards too.




Yeah, I too suspect that it's related to the video card and unfortunately, I have only my old Nvidia 1080 which I got the RX 5700 XT due to the Nvidia not working beyond High Sierra. I'm hesitant to downgrade back to a RX 5700 as I do occasionally use this system to game in windows, and the XT is at least on par with my old 1080 for the most part, and I think the RX 5700 would fall short.



I have read in here that the Radeon VII supposedly works well, and without issues on Catalina. I've literally only got a couple of days left that I can return this RX 5700 XT and get my money back, and if I'm going to change it out, I'd prefer something that can still at least keep up with my 1080. This is all very reminiscent of when I tried a Vega 64 about a year ago. Had random crashes with that too. I don't know what it is about AMD cards, but I never have had these issues with Nvidia hardware. It's just sad there is zero support for them anymore.


What are your thoughts on the Radeon VII? The XFX AMD Radeon VII isn't that much more on top of what this RX 5700 XT cost. I just don't want to swap it out only to encounter problems with that card too, but at this point, I'm thinking the best thing to do is just get a different card.

Return the 5700 XT and get a Sapphire Pulse RX-580 8GB. Flip the switch on it to compute mode. After you get it working, consider disabling the iGPU and go with an iMP SMBIOS.
 

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,201
Hi, CaseySJ! I am having a problem with my installation. Phase 1 and Phase 2 done without any errors. But, after choosing "Boot macOs from Mojave", the verbose screen appears. Some activites happen and 3 times busy timeout APPLEACPICPU comes and goes to the welcome screen (A blank white screen, Frozen), at that moment my MSI RX 580 fans stops working and stays like that for a long time. Followed your bios configs, kexts etc. Please help me.

Specs:
Z390 Designare, BIOS F8
32GB G.Skill Ttrident Z RAM
500GB Samsung 970 EVO Plus M.2 SSD
i9-9900K
MSI RX 580 8GB OC
Nzxt Kraken x52
 
Last edited by a moderator:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,124
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ
and for CONF02 to CONF01 compare :

On first screenshot, there is tagged Correctable error on Device Status register of CONF02 (don't know why this is not corrected :lol:.. in fact this conf doesn't work).

On UpStreamBridge (second screenshot), differencies are on CLKPM (Clock PM) and CommClk (Common Clock) bits disabled on Link Control register of CONF02.

On DownStreamBridge0 (third screenshot), CONF02 has this device on D3 state (inactive state). There is another difference on CommClk bit configuration !

On last screenshot, optionally for our need, we can see that CONF02 Cache Line Size is not defined on XHC2 controller. Like CommClk is not same.

Conclusion: some work is required to correctly setting all theses registers ;)! This might help us for Thunderbolt full tree populating.

Another ACPIDebugLog required for our progressing work.. at begin and end of ICMB method
Code:
            DBG2 ("NH00- Read VID/DID =", NH00)
            DBG2 ("XH00- Read VID/DID =", XH00)
            DBG2 ("RP18 =", RP18)
            DBG2 ("RP19 =", RP19)
            ...
            until RP28
            ...
            same for other sub-devices
Thanks @CaseySJ !
If you could also take screenshot of current BIOS setting related to Thunderbolt and PCIe PM/ASPM, that will be much appreciated :)
Hello @Elias64Fr,

Here's Part 1:
ACPI Debug Log showing register values at the start of ICMB and again at the end of ICMB. The value of XH00 may not be correct. I obtained it like this:

(a) Created "Case (0x09)" in MMBA:

Screen Shot 2020-02-13 at 7.33.08 PM.png


(b) Added XHCM registers:
Screen Shot 2020-02-13 at 7.32.20 PM.png

Code:
ICMB START — COLD BOOT

2020-02-13  ACPIDebug: { "R_18 =", 0x0, }
2020-02-13  ACPIDebug: { "R_19 =", 0x6, }
2020-02-13  ACPIDebug: { "R_1A =", 0x70, }
2020-02-13  ACPIDebug: { "R_1C =", 0xf0, }
2020-02-13  ACPIDebug: { "R_20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "R_24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "R_28 =", 0x60, }
2020-02-13  ACPIDebug: { "R_2C =", 0x60, }
2020-02-13  ACPIDebug: { "UP18 =", 0x6, }
2020-02-13  ACPIDebug: { "UP19 =", 0x7, }
2020-02-13  ACPIDebug: { "UP1A =", 0x70, }
2020-02-13  ACPIDebug: { "UP1C =", 0x1f1, }
2020-02-13  ACPIDebug: { "UP20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "UP24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "UP28 =", 0x60, }
2020-02-13  ACPIDebug: { "UP2C =", 0x60, }
2020-02-13  ACPIDebug: { "DP18 =", 0x7, }
2020-02-13  ACPIDebug: { "DP19 =", 0x8, }
2020-02-13  ACPIDebug: { "DP1A =", 0x8, }
2020-02-13  ACPIDebug: { "DP1C =", 0x1f1, }
2020-02-13  ACPIDebug: { "DP20 =", 0x82008200, }
2020-02-13  ACPIDebug: { "DP24 =", 0x1fff1, }
2020-02-13  ACPIDebug: { "DP28 =", 0x0, }
2020-02-13  ACPIDebug: { "DP2C =", 0x0, }
2020-02-13  ACPIDebug: { "D418 =", 0x7, }
2020-02-13  ACPIDebug: { "D419 =", 0x3c, }
2020-02-13  ACPIDebug: { "D41A =", 0x3c, }
2020-02-13  ACPIDebug: { "D41C =", 0x1f1, }
2020-02-13  ACPIDebug: { "D420 =", 0x6bf06bf0, }
2020-02-13  ACPIDebug: { "D424 =", 0x1fff1, }
2020-02-13  ACPIDebug: { "D428 =", 0x0, }
2020-02-13  ACPIDebug: { "D42C =", 0x0, }
2020-02-13  ACPIDebug: { "D518 =", 0x7, }
2020-02-13  ACPIDebug: { "D519 =", 0x3d, }
2020-02-13  ACPIDebug: { "D51A =", 0x70, }
2020-02-13  ACPIDebug: { "D51C =", 0x1f1, }
2020-02-13  ACPIDebug: { "D520 =", 0x81f06c00, }
2020-02-13  ACPIDebug: { "D524 =", 0x49f12001, }
2020-02-13  ACPIDebug: { "D528 =", 0x60, }
2020-02-13  ACPIDebug: { "D52C =", 0x60, }
2020-02-13  ACPIDebug: { "DVES =", 0x130004, }
2020-02-13  ACPIDebug: { "NH00- Read VID/DID =", 0x15eb8086, }
2020-02-13  ACPIDebug: { "XH00- Read VID/DID =", 0xffffffff, }
2020-02-13  ACPIDebug: { "NH10 =", 0x82000000, }
2020-02-13  ACPIDebug: { "NH14 =", 0x82040000, }


ICMB START — WARM BOOT

2020-02-13  ACPIDebug: { "R_18 =", 0x0, }
2020-02-13  ACPIDebug: { "R_19 =", 0x6, }
2020-02-13  ACPIDebug: { "R_1A =", 0x70, }
2020-02-13  ACPIDebug: { "R_1C =", 0xf0, }
2020-02-13  ACPIDebug: { "R_20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "R_24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "R_28 =", 0x60, }
2020-02-13  ACPIDebug: { "R_2C =", 0x60, }
2020-02-13  ACPIDebug: { "UP18 =", 0x6, }
2020-02-13  ACPIDebug: { "UP19 =", 0x7, }
2020-02-13  ACPIDebug: { "UP1A =", 0x70, }
2020-02-13  ACPIDebug: { "UP1C =", 0x1f1, }
2020-02-13  ACPIDebug: { "UP20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "UP24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "UP28 =", 0x60, }
2020-02-13  ACPIDebug: { "UP2C =", 0x60, }
2020-02-13  ACPIDebug: { "DP18 =", 0x7, }
2020-02-13  ACPIDebug: { "DP19 =", 0x8, }
2020-02-13  ACPIDebug: { "DP1A =", 0x8, }
2020-02-13  ACPIDebug: { "DP1C =", 0x1f1, }
2020-02-13  ACPIDebug: { "DP20 =", 0x82008200, }
2020-02-13  ACPIDebug: { "DP24 =", 0x1fff1, }
2020-02-13  ACPIDebug: { "DP28 =", 0x0, }
2020-02-13  ACPIDebug: { "DP2C =", 0x0, }
2020-02-13  ACPIDebug: { "D418 =", 0x7, }
2020-02-13  ACPIDebug: { "D419 =", 0x3c, }
2020-02-13  ACPIDebug: { "D41A =", 0x3c, }
2020-02-13  ACPIDebug: { "D41C =", 0x1f1, }
2020-02-13  ACPIDebug: { "D420 =", 0x6bf06bf0, }
2020-02-13  ACPIDebug: { "D424 =", 0x1fff1, }
2020-02-13  ACPIDebug: { "D428 =", 0x0, }
2020-02-13  ACPIDebug: { "D42C =", 0x0, }
2020-02-13  ACPIDebug: { "D518 =", 0x7, }
2020-02-13  ACPIDebug: { "D519 =", 0x3d, }
2020-02-13  ACPIDebug: { "D51A =", 0x70, }
2020-02-13  ACPIDebug: { "D51C =", 0x1f1, }
2020-02-13  ACPIDebug: { "D520 =", 0x81f06c00, }
2020-02-13  ACPIDebug: { "D524 =", 0x49f12001, }
2020-02-13  ACPIDebug: { "D528 =", 0x60, }
2020-02-13  ACPIDebug: { "D52C =", 0x60, }
2020-02-13  ACPIDebug: { "DVES =", 0x130004, }
2020-02-13  ACPIDebug: { "NH00- Read VID/DID =", 0x15eb8086, }
2020-02-13  ACPIDebug: { "XH00- Read VID/DID =", 0xffffffff, }
2020-02-13  ACPIDebug: { "NH10 =", 0x82000000, }
2020-02-13  ACPIDebug: { "NH14 =", 0x82040000, }


ICMB END

2020-02-13  ACPIDebug: { "R_18 =", 0x0, }
2020-02-13  ACPIDebug: { "R_19 =", 0x6, }
2020-02-13  ACPIDebug: { "R_1A =", 0x70, }
2020-02-13  ACPIDebug: { "R_1C =", 0xf0, }
2020-02-13  ACPIDebug: { "R_20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "R_24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "R_28 =", 0x60, }
2020-02-13  ACPIDebug: { "R_2C =", 0x60, }
2020-02-13  ACPIDebug: { "UP18 =", 0x6, }
2020-02-13  ACPIDebug: { "UP19 =", 0x7, }
2020-02-13  ACPIDebug: { "UP1A =", 0x70, }
2020-02-13  ACPIDebug: { "UP1C =", 0x1f1, }
2020-02-13  ACPIDebug: { "UP20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "UP24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "UP28 =", 0x60, }
2020-02-13  ACPIDebug: { "UP2C =", 0x60, }
2020-02-13  ACPIDebug: { "DP18 =", 0x7, }
2020-02-13  ACPIDebug: { "DP19 =", 0x8, }
2020-02-13  ACPIDebug: { "DP1A =", 0x8, }
2020-02-13  ACPIDebug: { "DP1C =", 0x1f1, }
2020-02-13  ACPIDebug: { "DP20 =", 0x82005400, }
2020-02-13  ACPIDebug: { "DP24 =", 0x49f10001, }
2020-02-13  ACPIDebug: { "DP28 =", 0x60, }
2020-02-13  ACPIDebug: { "DP2C =", 0x60, }
2020-02-13  ACPIDebug: { "D418 =", 0x7, }
2020-02-13  ACPIDebug: { "D419 =", 0x3c, }
2020-02-13  ACPIDebug: { "D41A =", 0x3c, }
2020-02-13  ACPIDebug: { "D41C =", 0x101, }
2020-02-13  ACPIDebug: { "D420 =", 0x0, }
2020-02-13  ACPIDebug: { "D424 =", 0x10001, }
2020-02-13  ACPIDebug: { "D428 =", 0x0, }
2020-02-13  ACPIDebug: { "D42C =", 0x0, }
2020-02-13  ACPIDebug: { "D518 =", 0x7, }
2020-02-13  ACPIDebug: { "D519 =", 0xa, }
2020-02-13  ACPIDebug: { "D51A =", 0xa, }
2020-02-13  ACPIDebug: { "D51C =", 0x101, }
2020-02-13  ACPIDebug: { "D520 =", 0x0, }
2020-02-13  ACPIDebug: { "D524 =", 0x10001, }
2020-02-13  ACPIDebug: { "D528 =", 0x0, }
2020-02-13  ACPIDebug: { "D52C =", 0x0, }
2020-02-13  ACPIDebug: { "DVES =", 0x0, }
2020-02-13  ACPIDebug: { "NH00- Read VID/DID =", 0x15eb8086, }
2020-02-13  ACPIDebug: { "XH00- Read VID/DID =", 0xffffffff, }
2020-02-13  ACPIDebug: { "NH10 =", 0x54000000, }
2020-02-13  ACPIDebug: { "NH14 =", 0x54040000, }
Part 2: BIOS Images
200214031718.jpg 200214031724.jpg 200214031729.jpg 200214031735.jpg 200214031749.jpg 200214031802.jpg 200214031813.jpg
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,124
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, CaseySJ! I am having a problem with my installation. Phase 1 and Phase 2 done without any errors. But, after choosing "Boot macOs from Mojave", the verbose screen appears. Some activites happen and 3 times busy timeout APPLEACPICPU comes and goes to the welcome screen (A blank white screen, Frozen), at that moment my MSI RX 580 fans stops working and stays like that for a long time. Followed your bios configs, kexts etc. Please help me.

Specs:
Z390 Designare, BIOS F8
32GB G.Skill Ttrident Z RAM
500GB Samsung 970 EVO Plus M.2 SSD
i9-9900K
MSI RX 580 8GB OC
Nzxt Kraken x52
Please remove the build guide from your post. Note the following:
Screen Shot 2020-02-13 at 7.23.07 PM.png


Because you're using a Samsung 970 EVO Plus, is it running the latest firmware? The firmware can be checked and updated using Samsung Magician software in Windows. Please see NOTE 5a at the top of Post #1:
Screen Shot 2020-02-13 at 7.27.40 PM.png
 
Joined
Aug 29, 2012
Messages
141
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Return the 5700 XT and get a Sapphire Pulse RX-580 8GB. Flip the switch on it to compute mode. After you get it working, consider disabling the iGPU and go with an iMP SMBIOS.
Yeah, I've been considering the RX-580. It's just a huge step down in performance from the Nvidia 1080 FTW2 I replaced with the FX 5700 XT. I'm wondering if a Vega-64 will be less of a performance hit? I'm just worried about encountering stability issues with one.
 
Joined
Nov 1, 2018
Messages
19
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
Yeah, I've been considering the RX-580. It's just a huge step down in performance from the Nvidia 1080 FTW2 I replaced with the FX 5700 XT. I'm wondering if a Vega-64 will be less of a performance hit? I'm just worried about encountering stability issues with one.

I have tried a sapphire rx580, MSI Vega 56, Vega FE and Radeon VII. All have been completely reliable. Going from a 5700 xt to a 580 is going to be rough performance-wise. I ditched the Vega 56 because it ran too hot.
 
Joined
Aug 29, 2012
Messages
141
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I have tried a sapphire rx580, MSI Vega 56, Vega FE and Radeon VII. All have been completely reliable. Going from a 5700 xt to a 580 is going to be rough performance-wise. I ditched the Vega 56 because it ran too hot.

Good to know. Thanks for the info! Were you using multiple monitors with any of those cards perchance?
 
Joined
Dec 31, 2019
Messages
11
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 5700 XT / RX 580
Mac
  1. MacBook Pro
Yes, just one monitor. Mostly with DP, but I've also tried HDMI.

I use a Sapphire Pulse 5700XT with two DP monitors and have been running Ableton fine for a few weeks now without any apparent lag or delays, in case that helps.

Clover, iMac19,1 with iGPU enabled.
 
Top