Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
So my Catalina 10.15.3, Z390 Designare, i9-9900K, Vega VII, 64GB is absolutely brilliant. Everything working 100% and blazing fast. The only features that do not seem to be available is handoff and Sidecar. iMessage and FaceTime perfect and native WiFi with Bluetooth is flawless (broadcom94360CS2)
Any clues as to why?
Please check that Location Services are enabled in System Preferences:
Screen Shot 2020-02-04 at 2.25.55 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Today I updated AppleALC.kext from version 1.3.8 to version 1.4.6 and lost all audio. Anyone else had any experiences with this?

Similarly, updating to the latest Lilu (1.4.1) and WEG(1.3.6) caused a kernel panic on boot. Unfortunately I don't know if it was Lilu or WEG that used the panic as I didn't have time to test, sorry! I replaced the kexts in both /L/E/ and EFI/CLOVER/kexts/other, was this the right thing to do? I did repair permissions with kext utility.
  • In Mojave we install all third-party kexts in /Library/Extensions and keep a minimum set in CLOVER/kexts/Other.
    • Kext Utility needs to be run afterwards.
  • In Catalina we just copy them to CLOVER/kexts/Other. This might change in a future revision to Catalina Mini-Guide.
    • No need to run Kext Utility (but it won't hurt).
What version of Clover are you running?
 
Joined
Sep 15, 2017
Messages
29
Motherboard
Gigabyte Z390 Designare F9b
CPU
i7-8700K
Graphics
UHD 630 / Vega
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
Classic Mac
  1. 512K
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. Android
  2. iOS
Most likely the problem is Couldn't allocate runtime area or no slide value. Check that Internal Graphics (IGPU) is Disabled in BIOS. It's also a good idea to perform a CMOS Reset to retrain the memory map. After a CMOS Reset, it's necessary to configure all BIOS parameters once again, starting with Load Optimized Defaults.

Thanks. IGPU was disabled and I had slide=0. Screen just goes dark as soon as I select the partition in the picker (solid black, no activity/lights on the case). I'll try the CMOS in a few.
 
Joined
Apr 4, 2011
Messages
106
Motherboard
Gigabyte Designare Z390 - F6
CPU
i5-9600
Graphics
Sapphire Pulse RX550
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  • In Mojave we install all third-party kexts in /Library/Extensions and keep a minimum set in CLOVER/kexts/Other.
    • Kext Utility needs to be run afterwards.
  • In Catalina we just copy them to CLOVER/kexts/Other. This might change in a future revision to Catalina Mini-Guide.
    • No need to run Kext Utility (but it won't hurt).
What version of Clover are you running?

I'm still on mojave for now. Plan to update soon. In CLOVER/kexts/Other I have Lilu, WhateverGreen, USBInjectAll and FakeSMC. ALC resides only in /Library/Extensions.

I was running clover 4987 (I think - but definitely <5), I have recently updated to 5103 but haven't tried to update the kexts again.
 
Joined
Nov 2, 2018
Messages
20
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
Thanks. IGPU was disabled and I had slide=0. Screen just goes dark as soon as I select the partition in the picker (solid black, no activity/lights on the case). I'll try the CMOS in a few.

Just chiming in to say a full CMOS reset by shorting the pins was absolutely necessary in order to get native NVRAM running. It was the one thing that finally made everything work like it's supposed to.
 
Joined
Sep 21, 2013
Messages
1,094
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Yeah, it's not for pro recording purposes, but I was surprised by the quality. And that's from someone using a ULN-8/3D (and an AKG712 Pro headphone, I only use the hp out of the builtin audio for the occasional Spotify/Youtube playback)

Sweet device. Trade you my Apollo 8 Quad for it! :lol:
Can you go S/PDIF out from the mobo and into the Metric Halo to make an aggregate device? All I see are SMPTE i/o and DB-25 connections. Is it all AES for digital connections?
 
Joined
Oct 27, 2017
Messages
203
Motherboard
Asus Rog Z390 Maximus Apex XI
CPU
i7 9700KF
Graphics
GTX 1080 Ti
Mobile Phone
  1. Android
Thank Very Much to You Casey SJ! Install completed and all works fine! i9 9900KF oc 5,2Ghz on all cores rock stable. One bad think is no WiFi. "No device detected" when I check it. I don't have installed Clover for emulated Nvram. Are You think is it really necessary?

Someone have issues on Final Cut Pro X in hackintosh with Catalina? Thanks in advance
 
Last edited:

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,739
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ @Elias64Fr, I had such good luck with Osy86's ThunderboltReset.kext and Al3x's TbtForcePower.efi along side KGP's TBHP (attached). I'm able to cold boot with no device attached and hot plug away. Most of my joy comes from the cold boot side which might be more about the TbtForcePower.efi.

Good work on the new progress! Any chance I can be a guinea pig on my z370+ex3?
 

Attachments

  • SSDT-DTPG.aml
    455 bytes · Views: 64
  • SSDT-Z370-TB3HP.aml
    5.8 KB · Views: 53
  • TbtForcePower.efi
    9.9 KB · Views: 57
Last edited:
Joined
Feb 5, 2020
Messages
46
Motherboard
Designare z390
CPU
i9-9900k
Graphics
RX 580
@CaseySJ I've been trying to get OpenCore properly configured on my own for the last week, to no avail. I will try out this awesome guide you guys have been working on, but I have some questions before proceeding:

(Background info: been on Mojave/Catalina for the last several months via Clover; SMBIOS iMac18,3; i9-9900k; RX580).
  1. I saw you mention that iGPU needs to be disabled for 19,1 or 1,1.
    • Does this mean SideCar does not work?
    • What limitations are there from having the iGPU disabled?
  2. Has anyone had success with 18,3, or should I just go with 19,1 or 1,1 and generate new serial number etc?
    • (Maybe the iGPU could be enabled with another SMBIOS?)
  3. Is the newer F9b BIOS update untested or not recommended for any reason? Do you know if F8 cause any issues with existing Clover installs?
I happen to have built an almost identical machine at work, but I have it populated with 4x32GB DIMMs (mapped as 8x16 in Clover) instead of 4x16. Once I get things working at home, I can test it out over there.

Thanks for all you've done so far - I hope I can contribute.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,739
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Apple has both TbtOnPch and TbtOnPci depending on the Mac model. We're specifically looking for TbtOnPch, so if either iMac19,1 or MacPro7,1 has this then we can examine and borrow from it. However, all of these SSDTs are also contained in the Apple firmware.bin files.
Still reading through this thread but I recently pulled out all TB firmware files from Sierra thorough Catalina for all board IDs. Still need em?
 
Last edited:
Top