Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Aug 25, 2016
Messages
4
Motherboard
ASUS ROG Z390 Maximus XI Hero (Wi-Fi)
CPU
i9-9900K
Graphics
RX 580
Even though it's not the same motherboard, I used this guide for my build on the ASUS MAXIMUS ROG XI HERO (Wi-Fi) and it worked PERFECTLY! Huge thanks!

Here are the specs of my new build that this guide worked for:
  • ASUS ROG MAXIMUS XI HERO (WI-FI)
  • Intel Core i9-9900K Processor
  • be quiet! Dark Rock Pro 4 CPU Cooler
  • Samsung 970 EVO SSD 1TB
  • 32GB Crucial Ballistix Sport LT 2400 MHz DDR4 RAM
  • ASUS ROG Strix Radeon RX 580 O8G Gaming OC Edition Graphics Card
 
Joined
Dec 31, 2019
Messages
26
Motherboard
Z390
CPU
i7-9700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Other
After 2 weeks of delay for changing my faulty PSU, I've managed to put all the parts together. I've also created a Catalina USB to boot from and have followed the instructions for Catalina install from @CaseySJ 's guide. I have a 2TB Samsung EVO Plus which I haven't been able to update the firmware for yet.
My questions:
•Do I need an updated firmware for the SSD or can I do this once I've installed Catalina.
•When the system boots from the USB and I choose to install Catalina, it shows an apple logo and stays there. Nothing happens after.

Have looked all over the net for solutions to no avail.
Any ideas?
Thank you
 
Joined
Dec 10, 2019
Messages
9
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 580
Mobile Phone
  1. Android
@CaseySJ
I have uploaded the config.plist you attached and now instead of the computer restarting over and over, it gets stuck at the 15 minute mark on phase 2 when installing Mojave on the SSD.
Am I missing any drivers? Or kexts?
Thanks!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,113
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
After 2 weeks of delay for changing my faulty PSU, I've managed to put all the parts together. I've also created a Catalina USB to boot from and have followed the instructions for Catalina install from @CaseySJ 's guide. I have a 2TB Samsung EVO Plus which I haven't been able to update the firmware for yet.
My questions:
•Do I need an updated firmware for the SSD or can I do this once I've installed Catalina.
•When the system boots from the USB and I choose to install Catalina, it shows an apple logo and stays there. Nothing happens after.

Have looked all over the net for solutions to no avail.
Any ideas?
Thank you
Hello @HackDeMac

The Samsung 970 EVO Plus must have latest firmware before installing macOS. The firmware can be checked and upgraded using Samsung Magician software under Windows.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,113
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ
I have uploaded the config.plist you attached and now instead of the computer restarting over and over, it gets stuck at the 15 minute mark on phase 2 when installing Mojave on the SSD.
Am I missing any drivers? Or kexts?
Thanks!
I'm wondering if Clover 5xxx supplied with UniBeast 9.3.0 might be an issue.

Can you please try creating the USB install disk again from scratch (reformat the USB disk with Disk Utility) and use UniBeast 9.2.0 from this link.
 
Joined
Dec 31, 2019
Messages
26
Motherboard
Z390
CPU
i7-9700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Other
Hello @HackDeMac

The Samsung 970 EVO Plus must have latest firmware before installing macOS. The firmware can be checked and upgraded using Samsung Magician software under Windows.
Thank you @CaseySJ. I guess I'll have to look for a windows machine.
So probably the Apple logo screen is also because of that. Could it be?
Thanks again
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,113
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you @CaseySJ. I guess I'll have to look for a windows machine.
So probably the apple logo screen is also because of that. Could it be?
Thanks again
Yes, that would be consistent with "eyewitness" reports. The NVMe SSD can be installed into an external USB 3 enclosure such as this one:
https://www.amazon.com/dp/B07MNFH1PX/?tag=tonymacx86com-20

There are plenty of other enclosures on the market as well, but be sure to choose one that says "PCIe" rather than "SATA". Once installed in the enclosure, it can be connected to any Windows machine or laptop.

On the other hand, if you have a simple 128GB or 256GB SATA SSD, you can install Windows on it and do all your troubleshooting from the Hackintosh itself...
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,113
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...
NOTE: As mentioned earlier, my SOIC8 clip is not very effective in attaching to the Winbond SPI chip. I may not be able to reliably flash patched firmware into the chip until the Pomona 5250 arrives on Tuesday, January 28.
Was just informed that the Pomona 5250 will be delivered tomorrow! Hopefully this will provide a more reliable attachment to SPI flash ROM chips.
 
Joined
Dec 31, 2019
Messages
26
Motherboard
Z390
CPU
i7-9700K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Other
Yes, that would be consistent with "eyewitness" reports. The NVMe SSD can be installed into an external USB 3 enclosure such as this one:
https://www.amazon.com/dp/B07MNFH1PX/?tag=tonymacx86com-20

There are plenty of other enclosures on the market as well, but be sure to choose one that says "PCIe" rather than "SATA". Once installed in the enclosure, it can be connected to any Windows machine or laptop.

On the other hand, if you have a simple 128GB or 256GB SATA SSD, you can install Windows on it and do all your troubleshooting from the Hackintosh itself...
Thank you - I'll check and report back!
 
Joined
Jan 1, 2020
Messages
525
Motherboard
Gigabyte Z390 Designare
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
thanks a lot for this hard work. I'm trying to adapt this over PEG (I´m over X299 plattform).
I backup the eprom from Alpine Ridge EX3 & Titan Ridge AIC (23 & 43)
Can you upload your modified SSDT-TbtOnPch_Designare-Draft07.aml?
Thx.
@juantrix

From your GC-TitanRidge NVM23, you have the following ThunderboltDROM property:
71000000 000000ED 00D9F6C7 E2016900 ED0007A2 01010881 80028000 00000882 90018000 00000883 80048001 00000884 90038001 00000585 50000005 86500000 02C70B88 20010064 00000000 00038980 058A5040 00058B50 40000B01 47494741 42595445 00110247 432D5449 54414E20 52494447 4500

Seem to be same as Designare ThunderboltDROM !

From your GC-TitanRidge NVM43, we don't have any thunderbolt conf., only TI PD Firmware (TPS65983b)

From your GC-AlpineRidge, you have the following ThunderboltDROM property:
37000000 00000031 00CBD78E AE025D00 31001111 01010881 80028000 00000882 90018000 00000883 80048001 00000884 90038001 000002C5 0B862001 00640000 00000003 878002C8 02C9058A 50000002 CB070141 53555300 12025448 554E4445 52424F4C 54455820 3300
>> TbtSwitch on port 5

You can test your add-on board by following the post https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.267551/post-2063008

BUT we have to know which Root port (RPxx) is linked to your add-on board AND which event is used for Thunderbolt Hotplug on this board (like _E17 on Z390 Designare) !
 
Last edited:
Top