Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jan 16, 2011
Messages
33
Motherboard
Gigabyte Z390 Designare
CPU
i7-8700
Graphics
Vega 64
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I have found that recent versions of Google Backup and Sync took up a lot of CPU time right after logging in. The version I have now (the latest available version) seems to have largely solved this problem, but I still need more time to make sure.

Try running Activity Monitor immediately after logging in to identify any high-CPU process(es).

Are you running latest Firefox?


Newest Firefox! Even all apps closed running often at highspeed
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Greetings fellow hackintoshers;)

First of all a big thank you to the tonymac community which has allowed me to run several builds over the years, which I use for my work more than my regular Macs.

Specially @CaseySJ, I basically was able to upgrade to a Z390 fully functional build thanks to your guide. Many many thanks!

My build (Z390 Designare, i9-9900k, 64GB DDR4 3000, Radeon Vega Frontier Air) runs stable and functional (H264 rendering with FCPx, Thunderbolt 3 support, USB) with Mojave using your guide, installed on a SATA SSD.

I've now followed your Catalina fresh install guide, installed on an HP EX950 NVMe, my system appears to be running perfect though I experience occasional system total freezes (nothing to do except reset button).

Those can happen irrespective of what the computer is doing (so should be unrelated to overheating, I think). Only thing I've noticed is that I can't stream protected content (Netflix) on Safari. Console reports:

default 19:59:19.363959+0100 kernel [3:0:0] AMD Error:
default 19:59:19.363960+0100 kernel Failed HDCP: status 4

Has anyone experienced the same thing or have any ideas on how to troubleshoot? I don't care for HDCP at all. Just trying to achieve a reliable build on Catalina, as I have on Mojave. Attaching EFI folder, I am open to test any ideas,

Thanks
Hello @m.figueras

It seems quite a few users are experiencing total system freezes. We have found that disabling WhateverGreen by adding the boot argument -wegoff solves this problem in most cases. If you're using WhateverGreen 1.3.5 or older, please try adding the boot argument. You may also try updating to 1.3.6, which was released yesterday. Version 1.3.6 may help with Netflix as well (but let's work on one issue at a time).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Newest Firefox! Even all apps closed running often at highspeed
When this problem occurs, please run Activity Monitor and click the % CPU column as shown and post a screenshot.
Screen Shot 2020-01-14 at 11.23.09 AM.png
 
Joined
Jun 30, 2015
Messages
11
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega Frontier Air
Mac
  1. iMac
  2. MacBook Pro
Hello @m.figueras

It seems quite a few users are experiencing total system freezes. We have found that disabling WhateverGreen by adding the boot argument -wegoff solves this problem in most cases. If you're using WhateverGreen 1.3.5 or older, please try adding the boot argument. You may also try updating to 1.3.6, which was released yesterday. Version 1.3.6 may help with Netflix as well (but let's work on one issue at a time).

Thanks for replying so quick @CaseySJ !

I already tried updating all kexts via Hackintool, will try -wegoff and report back
 
Joined
Jun 30, 2015
Messages
11
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega Frontier Air
Mac
  1. iMac
  2. MacBook Pro
Hello @m.figueras

It seems quite a few users are experiencing total system freezes. We have found that disabling WhateverGreen by adding the boot argument -wegoff solves this problem in most cases. If you're using WhateverGreen 1.3.5 or older, please try adding the boot argument. You may also try updating to 1.3.6, which was released yesterday. Version 1.3.6 may help with Netflix as well (but let's work on one issue at a time).

Hi again, so I tried -wegoff. System loads slower, and now only outputs to 1 monitor via HDMI - before, I was using 3 monitors, DP-DP-hdmi in 3 monitors.

Is there any way to retain a fully functional GPU using the -wegoff flag?

(btw just in case you don't see a previous reply, I already updated WEG before my first post)

edit: do you recon the problem is gpu related? would you recommend using a 5700 xt instead of a Vega frontier?
 
Joined
Jan 14, 2020
Messages
2
Motherboard
Z390 Designare
CPU
i7-8700k
Graphics
xfx 5700 xt
**Mini-Guide for Direct Installation of Catalina 10.15.1 and Newer **
UPDATED 15-Dec-2019
MSI RX 5700 XT may not work with this guide. Please follow the previous guide (
click here).
** Please do not quote this guide in any post -- use a link instead **


Anyone know if rx 5700 xt issue is specific towards MSI version of the card or all rx 5700xt cards? I currently have an xfx 5700xt thicc and not sure to follow the most recent mini-guide or previous guide. If anyone can clear this up for me i'd really appreciate it.
 
Joined
Mar 13, 2010
Messages
351
Motherboard
Gigabyte Z370N WIFI
CPU
i7-8700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey CaseySJ,

I have a question regarding the OcQuirks experiment you're describing here: https://www.tonymacx86.com/threads/...700k-amd-rx-580.267551/page-1009#post-2033519

I'm on Clover v5.x using AptioMemoryFix.efi on a different motherboard.
Is OcQuirks just an alternative to OsxAptioFix2Drv-free2000 or can it be used with any memory fix driver (in my case AptioMemoryFix.efi)?

Thanks in advance and for all the effort you're putting in this – this is not a guide, it's a compendium. :clap:
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi again, so I tried -wegoff. System loads slower, and now only outputs to 1 monitor via HDMI - before, I was using 3 monitors, DP-DP-hdmi in 3 monitors.

Is there any way to retain a fully functional GPU using the -wegoff flag?
This might require some experimentation. For example, in Clover Configurator --> Graphics, we can see what happens if we enable Inject ATI and/or Radeon DeInit. These are just off-the-cuff suggestions. Nevertheless, the first question to ask is whether your system is now stable, or whether it still freezes after a few minutes.
(btw just in case you don't see a previous reply, I already updated WEG before my first post)
Interesting; so WhateverGreen 1.3.6 does not help.
edit: do you recon the problem is gpu related? would you recommend using a 5700 xt instead of a Vega frontier?
At this time we're not sure about the cause of the sudden freeze. By disabling WEG, most users are able to circumvent the problem. So it could be an issue between WhateverGreen and certain graphics cards. I have not experienced the problem with my PowerColor Red Dragon RX 5700 XT. Other things to check are:
  • Universal Audio Devices (UAD) device drivers.
  • Other third-party kexts in /Library/Extensions that were installed after macOS installation was completed.
If you still have a bootable backup that was made immediately after macOS installation -- and before any third-party apps or drivers were installed -- then it may be a good idea to boot from that backup and test for system stability.
 
Joined
Jun 20, 2019
Messages
48
Motherboard
Gigabyte z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Hi @CaseySJ. I tried the EFIClone-v3.sh script but it didn't run as expected. The script portion of clone task took several minutes and the clone task never completed successfully. I had just run the clone task a few minutes before without the script so there should have been very little to clone. The log file references files that are not on the source or destination disks. Is the intent with the script just to clone the efi from the source to the destination efi and let ccc deal with all the other files? The log file is almost 900MB and contains the names of the files of my vast collection of porn so I'd prefer not to post it. ;) Can you point me in the right direction?

Screen Shot 2020-01-14 at 12.37.11 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Anyone know if rx 5700 xt issue is specific towards MSI version of the card or all rx 5700xt cards? I currently have an xfx 5700xt thicc and not sure to follow the most recent mini-guide or previous guide. If anyone can clear this up for me i'd really appreciate it.
We are seeing some issues specifically with with MSI RX 5700 cards. These issues may be related to WhateverGreen. Numerous people have reported reliable system behavior with Sapphire RX 5700 XT and PowerColor RX 5700 XT. These two brands might be your safest bets...but if anyone is successfully using a different brand, please let us know.

Because you have the XFX 5700 XT THICC, you should follow the most recent Mini-Guide. If the system fails (i.e. black screen) then you may try the previous guide.
 
Top