Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...
@CaseySJ mind if I send you the EFI to take a look see if everything checks out? Or any instruction on some tests to make sure everything is running properly?
...
Feel free to post it, but remove serial numbers from SMBIOS. Not sure why the config in Catalina Mini-Guide did not work so maybe there’s something significantly different in your EFI.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I downgraded to F6 BIOS then back to the F8.
Unpluged: the Vega 56, Kraken X67, NVMe 970 Plus, WiFi card, fans.
Still still still same message!!
I’m desperate :rolleyes:

Otherwise, Mojave run very well..
The i9-9900KS is not supported on F6, but should work fine on F8. Do you have a “regular” 9th Gen CPU to test? For example: i5-9500, i7-9700K, i9-9900K.
 
Joined
Nov 17, 2019
Messages
209
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Feel free to post it, but remove serial numbers from SMBIOS. Not sure why the config in Catalina Mini-Guide did not work so maybe there’s something significantly different in your EFI.

Here is the Final EFI I was able to get success with, I used F6 BIOS, if you'd like I can share the setting I used for BIOS, only modification I made was disabling VT-d
 

Attachments

  • EFI-success.zip
    3.3 MB · Views: 92
  • Screen Shot 2019-12-22 at 9.06.49 PM.png
    Screen Shot 2019-12-22 at 9.06.49 PM.png
    142.5 KB · Views: 99
  • Screen Shot 2019-12-22 at 9.08.21 PM.png
    Screen Shot 2019-12-22 at 9.08.21 PM.png
    72 KB · Views: 91
  • Screen Shot 2019-12-22 at 9.08.28 PM.png
    Screen Shot 2019-12-22 at 9.08.28 PM.png
    152 KB · Views: 81
  • Screen Shot 2019-12-22 at 9.08.35 PM.png
    Screen Shot 2019-12-22 at 9.08.35 PM.png
    82 KB · Views: 95

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Here is the Final EFI I was able to get success with, I used F6 BIOS, if you'd like I can share the setting I used for BIOS, only modification I made was disabling VT-d
The build guide explicitly calls for disabling Vt-d.
 
Joined
Nov 17, 2019
Messages
209
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
The build guide explicitly calls for disabling Vt-d.

Yes I know. When I attempted the build using the mini guide, I kept getting CPU halt with the BIOS settings in Post #1, and I did have it disabled. But I could never succeed using the mini guide. So I used the first method that I had got success with, and it called for the EFI. I had a Settings Preset for my BIOS, but in those presets that the file would set VT-d was enabled. So I disabled it knowing that is a setting that should be turned off and was able to succeed with it. I used the patch, drivers, and kexts from the mini guide, but a different config file and succeeded so don't know what the difference between configs are.
 
Joined
Nov 17, 2019
Messages
209
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Yes I know. When I attempted the build using the mini guide, I kept getting CPU halt with the BIOS settings in Post #1, and I did have it disabled. But I could never succeed using the mini guide. So I used the first method that I had got success with, and it called for the EFI. I had a Settings Preset for my BIOS, but in those presets that the file would set VT-d was enabled. So I disabled it knowing that is a setting that should be turned off and was able to succeed with it. I used the patch, drivers, and kexts from the mini guide, but a different config file and succeeded so don't know what the difference between configs are.

If you notice anything different between the config files and want me to test if something is working, let me know.

As it stands, I’ve been able to use everything without issue.

SMBIOS is on iMac Pro 1,1.
 
Joined
Aug 16, 2012
Messages
385
Motherboard
Asus X299 DELUXE II
CPU
i9-10940X
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
The i9-9900KS is not supported on F6, but should work fine on F8. Do you have a “regular” 9th Gen CPU to test? For example: i5-9500, i7-9700K, i9-9900K.
No, I don’t have regular i9.
I test, too, with a beta BIOS F9b. It still doesn’t work.
I don’t know what can I do.
Return to Amazon the motherboard? The CPU? :|
 
Joined
Oct 18, 2011
Messages
67
Motherboard
Gigabyte Z370 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Anyone having issues with upgrading to 10.15.2 from 10.15.1? I've tried from System Preferences and get to a screen with an Apple logo and progress bar but eventually that crashes. Have never seen a boot option in Clover.

That being said, I can hard reset the machine and boot into 10.15.1 without any issues.

Just FYI - update worked fine once I had updated Lilu, WhateverGreen and AppleALC.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
If you notice anything different between the config files and want me to test if something is working Let me know.

As it stands I’ve been able to use everything without issue

SMBIOS is on iMac Pro 1,1
Some of the differences in your config.plist:
  • ACPI
    • All APCI Fixes are unchecked except FixRegions, FixMCFG, FixHeaders, HaltEnabler
    • PluginType is unchecked
    • All ACPI renames are disabled
  • Kernel and Kext Patches
    • AppleIntelCPUPM is unchecked
  • RtVariables
    • ROM = UseMACAddr0
    • No MLB specified
Native CPU power management is disabled.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,941
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
No i don’t have regular i9
I test too with a beta bios F9b, still doesn’t works.
i don’t know what can I do.
Return to amazon the motherboard? The cpu? :|
Because this seems to be related directly to CPU and/or Motherboard (has nothing to do with macOS) I would urge you to contact Gigabyte Tech Support using their website. Tell them what CPU and motherboard you have, what firmware version is running, and the exact error message.
I downgraded to F6 BIOS then back to the F8.
Unpluged: the Vega 56, Kraken X67, NVMe 970 Plus, WiFi card, fans.
Still still still same message!!
I’m desperate :rolleyes:

Otherwise, Mojave run very well..
Wait...So macOS runs properly even when the error message appears?
 
Top