Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jul 27, 2012
Messages
173
Motherboard
Gigabyte Z390 Aorus Wifi
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
The problem you're facing seems to be due to a bad memory fix driver in the CLOVER/drivers/UEFI folder. You will have to be able to mount the EFI partition of USB install disk and use a different driver such as:
  • OsxAptioFix2Drv-free2000.efi
or both of these files:
  • OcQuirks-4.efi
  • FwRuntimeServices.efi
Well I am going to share the Clover folder as required. Sir, please find the attachment and do the needful.

Thanks and will try to look for these drivers and try to boot from USB Drive If possible
 

Attachments

  • CLOVER.zip
    3 MB · Views: 38
Joined
Dec 7, 2019
Messages
16
Motherboard
Asus z390 Designare
CPU
i9-9900k
Graphics
rx5700xt
That's a nice configuration. On the NZXT X62 we can monitor and control the LEDs, connected fans, and pump speed. On the H510 Elite we can monitor and control the NZXT Smart Device V2, allowing us to monitor and control connected AER RGB accessories such as AER RGB 2 fans/lights, lighting strips, NZXT Under Glow, NZXT cable comb, etc.

It requires liquidctl from here:

The best part is that liquidctl now supports Homebrew on macOS. This means we can install current version and future updates as follows:
  • First, install Xcode from the Mac App Store.
  • Then install Homebrew from Terminal by typing:
    • /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
  • Finally, install liquidctl from Terminal by typing:
    • brew tap jonasmalacofilho/liquidctl
    • brew install liquidctl
That's it. When new versions of liquidctl are released, just type:
  • brew upgrade liquidctl
To use liquidctl, please see the docs located here:

WOW! You even did the extra for me! Great thanks! I will install that later when I finished the whole installation.
I have tried to do the iGPU method, with your iGPU config and added fakeid also InjectIntel ticked.
Although I also get the gIOScreenState error at the end of verbose, the installer boot successfully, and I installed Catalina 10.15.1 at the end!
So from now, I will try the reinstall my RX 5700 XT and Fenvi WiFi card to see what's what.
Big thanks again!
 
Joined
Aug 6, 2019
Messages
66
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ is it normal not to have any HW acceleration when booting with the iGPU in the first steps of your guide? I mean, the dock and a lot of other GUI elements haven't the classic transparency as we have with the 5700XT installed, weird resolution and so on...
 
Joined
Dec 7, 2019
Messages
16
Motherboard
Asus z390 Designare
CPU
i9-9900k
Graphics
rx5700xt
I just finished the whole process in #10201, installed RX 5700XT and Fenvi WiFi card.
All works! Including the Fenvi card and RX 5700 XT. However, since my NZXT fans and x62 cooler both need the f_usb of the mobo to work, there is no place for me to plug in the Bluetooth port of the Fenvi card into the mobo. So, I currently don't have Bluetooth and cannot test the AirDrop. Any suggestions for a workable Bluetooth dongle?

Also, anything I should check? Can I login to iCloud / use Apple Music / app store?

Thank you so much for the help!!!!

Screenshot 2019-12-09 at 5.37.15 PM.png
 
Joined
Jun 19, 2011
Messages
87
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I just finished the whole process in #10201, installed RX 5700XT and Fenvi WiFi card.
All works! Including the Fenvi card and RX 5700 XT. However, since my NZXT fans and x62 cooler both need the f_usb of the mobo to work, there is no place for me to plug in the Bluetooth port of the Fenvi card into the mobo. So, I currently don't have Bluetooth and cannot test the AirDrop. Any suggestions for a workable Bluetooth dongle?

Also, anything I should check? Can I login to iCloud / use Apple Music / app store?

Thank you so much for the help!!!!

View attachment 439530
If you look at the USB plugs which come with the Fenvi and NZXT you will see that they only use one port on the M.B. socket, which has two. If you're very careful you can release the individual pins from one of the black USB plugs and insert them into the other, below those already there (in the same order, ie red underneath red) The two pieces of hardware then sharing the same plug
 
Joined
Dec 7, 2019
Messages
16
Motherboard
Asus z390 Designare
CPU
i9-9900k
Graphics
rx5700xt
If you look at the USB plugs which come with the Fenvi and NZXT you will see that they only use one port on the M.B. socket, which has two. If you're very careful you can release the individual pins from one of the black USB plugs and insert them into the other, below those already there (in the same order, ie red underneath red) The two pieces of hardware then sharing the same plug
Yeah I know the f_usb plug can control two ports, but my h510i case also need one for the 3 fans installed.
So I already used up both of them.
thanks anyway! here is the photos of the f_usb port currently look like:

Screenshot 2019-12-09 at 6.33.58 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,382
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Well I am going to share the Clover folder as required sir please find the attachment and do the needful.

Thanks and will try to look for these drivers and try to boot from USB Drive If possible
Hello @luvlastcall

Your CLOVER folder is good -- I don't see any problem there. So please remind me again:
  • Are you installing Mojave or Catalina?
  • Is your monitoring connected to the RX 580?
  • Are you using HDMI or DisplayPort?
  • What is the make/model of your monitor?
  • When you boot from the USB install disk (F12 at BIOS splash screen) and then try to boot into macOS from the Clover Boot Menu, do you immediately get the Couldn't allocate runtime area error?
  • You are already using OsxAptioFix2Drv-free2000, which is recommended when all other drivers fail. So for now, I wouldn't worry about that. Later we can switch you to OcQuirks-4 and FwRuntimeServices. But first we need to make sure your system can boot up.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
17,382
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Yeah I know the f_usb plug can control two ports, but my h510i case also need one for the 3 fans installed.
So I already used up both of them.
thanks anyway! here is the photos of the f_usb port currently look like:

View attachment 439541
Please use something like this:
https://www.amazon.com/dp/B079CBQ11Q/?tag=tonymacx86com-20

This works very well:
  • It adds a USB hub to the F_USB header on the motherboard.
  • The F_USB header has 9 pins:
    • 4 pins are needed for one USB 2.0 port
      • This is mapped to HS11 in the USB SSDT
    • 4 pins are needed for a second USB 2.0 port
      • This is mapped to HS12 in the USB SSDT
    • 1 pin is a no-function orientation pin
  • So F_USB actually provides two USB ports.
  • This splitter expands that into 4 USB ports, which means:
    • HS11 gets 2 ports
    • HS12 gets 2 ports
  • The splitter has 2 circuit boards (attached together).
  • You should connect all internal devices (NZXT Kraken and Bluetooth) to one of the circuit boards in the splitter.
  • You should connect any external devices to the other circuit board in the splitter. But if you don't have any external devices, you can certainly connect internal devices to all 4 ports.
WOW! You even did the extra for me! great thanks! will install that later when i finished the whole installation.
Feel free to ask questions about this.
I have tried to do the iGPU method, with your iGPU config and added fakeid also InjectIntel ticked,
although i also get the gIOScreenState error at the end of verbose, the installer boot successfully and I installed catalina 10.15.1 at the end!
So the config.plist provided in the Catalina Mini-Guide would not work with iGPU until you checked on Inject Intel and specified a Fake IntelGFX device ID?
 
Last edited:
Joined
Jul 25, 2012
Messages
44
Motherboard
Gigabyte Z390 M
CPU
i9-9900K
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
@CaseySJ After days 2 days working flawlessly today I installed a driver for my Wacom tablet and then when I restarted the system I got a "Can't allocate runtime area" error.

Luckly my backup disk was using the free2000 one, so I had to revert back to it.

Just to inform you in case you see a similar problem elsewhere, maybe the alternative solution isn't as stable as the risky old free2000 :lol:.
 
Top