Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Oh, there's a bigger problem in screenshot #2 that I didn't notice before:

The first item in Properties is "framebuffer-patch-enableframebuf..." but it should be only "framebuffer-patch-enable".
Thanks

Rectified this and removed also the "0x" for ig-platform-id, but it seem it does not have any effect on the preview.
 
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Also, check your BIOS and ensure that iGPU is enabled. This is what is used for .jpg preview among other things.
I've been searching in BIOS, but I can't find the way to enable the iGPU. Can you give me some directions? Thank you!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,452
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I've been searching in BIOS, but I can't find the way to enable the iGPU. Can you give me some directions? Thank you!
Please see "Chipset" section of BIOS:
  • Chipset
    • Vt-d → Disabled
    • Internal Graphics → Enabled
    • DVMT Pre-Alloc → 64M
    • DVMT Total Gfx Mem → 256M
    • Audio Controller → Enabled
    • Above 4G Decoding → Enabled
 
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Please see "Chipset" section of BIOS:
  • Chipset
    • Vt-d → Disabled
    • Internal Graphics → Enabled
    • DVMT Pre-Alloc → 64M
    • DVMT Total Gfx Mem → 256M
    • Audio Controller → Enabled
    • Above 4G Decoding → Enabled

Oh I see.... thank you. But that was already enabled .... now there's no more options....
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,452
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Oh I see.... thank you. But that was already enabled .... now there's no more options....
Let’s make sure your iGPU is attached to proper driver. Run IORegistryExplorer and scroll the tree on the left side until you see IGPU, then grab a screenshot.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,452
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Is this correct?
Please clear the search bar by clicking on the little X on the far right side of the search field. Then the tree on the left will expand. And grab another screenshot. It looks like wrong driver is attached.
 
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Please clear the search bar by clicking on the little X on the far right side of the search field. Then the tree on the left will expand. And grab another screenshot. It looks like wrong driver is attached.

There's more down there. Should I take the remaining as well or this is enough?
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,452
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
There's more down there. Should I take the remaining as well or this is enough?
This screenshot is good enough. It confirms that iGPU is not activated in Mojave. Can you please post your config.plist, but remove serial number from SMBIOS.
 
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
This screenshot is good enough. It confirms that iGPU is not activated in Mojave. Can you please post your config.plist, but remove serial number from SMBIOS.

Here you have. My friend I feel sorry about this... I don't know how to thank you!
 

Attachments

Top