Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Nov 18, 2015
Messages
123
Motherboard
GIGABYTE Z390 Designare
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Thanks CaseySJ

I'am very happy to report you
Finally My z390 Disignare+8700+RX580 work Perfectly. Actually much better than real Mac !!!!

Works
1. HEVC Decoding with UHD630 & RX580 works together (CPU load usage less than 10%)
2. HEVC Encoding on Davinci 15 & Finalcut X with UHD630 & RX580 together (CPU load usage less than 20%)
3. H264 Encoding on Davinci 15 & Finalcut X with UHD630 & RX580 together (CPU load usage less than 20%)
4. Finalcut X background proress transcoding UHD630 & RX580 together (CPU load usage is high)

5. Thunderbolt3 Hot swap work perfectly with Highpoint Rocket Raid 4520
6. All USB3.1 3.0 2.0 Ports
7. All other function

All function worked well before, based CaseySJ's guide except UHD630+RX580 works.
I spent 3 weeks to solve this problem but it was not possible for me.

Today @KaseyRamge helped me by Teamviewer remote access. after that like a magic every function related GPU works perfectly.

Thank you for all who share valuable knowleadge to me.
kenntkim66,

I'm assuming the "config.plist" from this post is after @KaseyRamge helped you tweak it. I'm putting together an identical system to your's next week, and I'd like to use your "config" w/ my own serial # of course. (You probably should conceal your's next time.)

Curious as to why you went w/ SMBIOS "iMacPro1,1" vs CasySJ's suggestion of "MacMini8,1"?

Thanks in Advance.
 
Joined
Apr 3, 2013
Messages
64
Motherboard
Gigabyte Z390 Disignare
CPU
i7-8700
Graphics
Vega 56
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Curious as to why you went w/ SMBIOS "iMacPro1,1" vs CasySJ's suggestion of "MacMini8,1"?
It was recommended by @KaseyRamge. Actually, I tried both and there is nothing different result. I choice iMac Pro only cosmetic reason. Looks Pro is cooler than Mini right ? ;)

Make iGPU work perfectly first that is one of the key I guess. UHD630 on Disignare has 3 port.

Yes sure confi.plist I upload is the file after he tweak for me.
 
Joined
Feb 11, 2014
Messages
173
Motherboard
Z390 Designare
CPU
i7-9700
Graphics
Radeon Pro WX 9100
Mac
MacBook Pro
Mobile Phone
iOS
All right, thanks DJ4
do you have a good reference to advise ?
Ensure the are rated for 40GB. I have a couple Apple and a couple from OWC. The "real" ones are about $40 each. The connector on the Designare MB seem to have better retaining force than my MacBook. :-/
 
Joined
Jan 21, 2018
Messages
171
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Hello,

I don't know if it was after the FCP fix I did, but jpg files preview are not working. Do anyone know how to fix?

Thanks
 
Joined
Feb 11, 2014
Messages
173
Motherboard
Z390 Designare
CPU
i7-9700
Graphics
Radeon Pro WX 9100
Mac
MacBook Pro
Mobile Phone
iOS
Hello,

I don't know if it was after the FCP fix I did, but jpg files preview are not working. Do anyone know how to fix?

Thanks
Double check the fix for FCP. You are missing something as you need the iGPU for jpg preview to work. I have both working.
 
Joined
Jan 21, 2018
Messages
171
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Double check the fix for FCP. You are missing something as you need the iGPU for jpg preview to work. I have both working.
After double checking, it seems to be ok as explained on FCP fix. I attach screenshot. Cam please someone take a look?

Thanks
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,220
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
After double checking, it seems to be ok as explained on FCP fix. I attach screenshot. Cam please someone take a look?

Thanks
In screenshot 1 you have "0x" for ig-platform-id. Try deleting those characters so that the field is completely empty, then save, reboot, and test again.

Not sure if this will have any effect, but probably worth doing.
 
Joined
Feb 11, 2014
Messages
173
Motherboard
Z390 Designare
CPU
i7-9700
Graphics
Radeon Pro WX 9100
Mac
MacBook Pro
Mobile Phone
iOS
In screenshot 1 you have "0x" for ig-platform-id. Try deleting those characters so that the field is completely empty, then save, reboot, and test again.

Not sure if this will have any effect, but probably worth doing.
Also, check your BIOS and ensure that iGPU is enabled. This is what is used for .jpg preview among other things.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,220
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
After double checking, it seems to be ok as explained on FCP fix. I attach screenshot. Cam please someone take a look?

Thanks
Oh, there's a bigger problem in screenshot #2 that I didn't notice before:

The first item in Properties is "framebuffer-patch-enableframebuf..." but it should be only "framebuffer-patch-enable".
 
Top