Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Casey & Co,

After 8 months of smooth sailing my "Messages" app stopped working and I decided to finally update my SMBIOS to iMac 19,1 as recommended for Headless igpu in 10.14.6. I did my best to follow the instructions but now I've lost the ability to "Preview" any jpegs and the machine neither sleeps or shutdown properly. I've spent 1.5 days troubleshooting to no avail. I suspect the trouble is in my Config.plist which I attached below. My goal is Headless igpu as described in "Going the Extra Mile". My graphics card is a RX580. Lilu and WEG and CLover are all current.

Can any kind soul please have a look? I'm sure I borked it somehow. Serial # has been removed..

Thanks in Advance
Hello @Lensjocky,

Can you compress and post your CLOVER folder? Because you’ve already posted a redacted config.plist, you may simply remove that file from this upload.

Quick Check: If any files were replaced, removed, or added to /Library/Extensions, the kernel cache must be rebuilt.
 
Joined
Nov 18, 2015
Messages
176
Motherboard
GIGABYTE Z390 Designare
CPU
i7-8700K
Graphics
RX Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Casey,

Here's the Clover folder without the config.plist or the theme folder. All my kexts (lilu, weg, appleALC, USBinjectall, etc..) are in L/E thanks to "Kext Beast" and yes I rebuilt the cache w/ "kext Utility". FakeSMC is in in CLover/Kexts/other.


Thanks
 

Attachments

  • CLOVER.zip
    2.8 MB · Views: 36
Joined
Feb 26, 2010
Messages
119
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. Android
  2. iOS
Build has been working no probs. Received Fenvi T 919 from China/Newegg. Installed. Wifi works but no Bluetooth. Cable plugged in to f_usb on motherboard. Doesn't show in system report. How should I investigate?
 

Attachments

  • Screen Shot 2019-08-22 at 4.36.28 PM.png
    Screen Shot 2019-08-22 at 4.36.28 PM.png
    571.3 KB · Views: 52
  • Screen Shot 2019-08-22 at 4.37.10 PM.png
    Screen Shot 2019-08-22 at 4.37.10 PM.png
    829.9 KB · Views: 45
Joined
Feb 26, 2010
Messages
119
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. Android
  2. iOS
Took out CNVI module and Fenvi Bluetooth shows in system report. Won't connected to Trackpad 2. Magic Mouse connects.
Trackpad connected. Problem solved. Don't know why...
 
Last edited:
Joined
Jul 2, 2016
Messages
23
Motherboard
Gigabyte Designare Z390 (F9b)
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@archalys @CaseySJ
I finally got VirtualSMC to work after updating Clover to 5045 and renaming things (-64), as well as moving them to the right folder.
have to say that having an external bootable OS on TB3 really comes in handy when you want to mess things up :D

I finally have all the cores temps and fans readings correctly showing up in HWMonitorSMC2.
Out of this a new question came up: how do I get to control fans? Macs Fan Control showed me the middle finger saying that something else is controlling the fans... now that's a surprise :D
any hints? do I need some other kext or config file?

@svandive
I am not overclocking (cores get to a max of 4.7GHz) and temps rise to 85/88 degrees during raytracing.
HWMonitorSMC2
Control of the fans is handled by some poltergeist because I am sure not doing anything.

What cooler do you use on the i9-9900K?
what are your temps under stress?
I'm worried since I don't know how high they're supposed to be while crunching.

running in Windows I tried mining bitcoins with all the cores at max and while iCue was running I had no alerts.
the alerts, by the way, are only triggered by HWMonitor (not SMC2) at close to 90ºC.
HWMonitorSMC2 doesn't seem to throw a fit :)
 
Joined
Apr 23, 2019
Messages
46
Motherboard
Gigabyte Designare Z390
CPU
i9 9900k
Graphics
RX 580
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Noted! Thanks for helping.



I do have the list, and I noticed that quite a few of them only work with 2 sticks, but not 4. That made me think I should do more research and ask for actual direct user experience building a hackintosh.



You're right, memory compatibility seems much better these days... but does hackintosh affect this at all? Could a memory that is validated for this motherboard on Windows or Linux not play ball when installing Mac OS? Or is it just theoretically impossible?

Thanks for helping!
I did not get the 128GB kit to work (see my posts). And so far, I haven’t heard of anyone who did that. It is possible for sure! But at this point, it is not certain how and which brand of RAM. I couldn’t get any RAM with XMP for a decent price for example.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Took out CNVI module and Fenvi Bluetooth shows in system report. Won't connected to Trackpad 2. Magic Mouse connects.
Trackpad connected. Problem solved. Don't know why...
Removing the CNVi module should not be necessary. We just need to copy SSDT-DESIGNARE-Z390-NO-CNVW.aml to CLOVER/ACPI/patched folder. From the problem description, it seems that the Bluetooth module probably needed to be reset, like this:
  • SHIFT-OPTION-Click the Bluetooth icon on menu bar.
  • You will see a Debug option.
  • The first item in that menu will be Reset the Bluetooth module.
Screen Shot 2019-08-22 at 6.08.21 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Casey,

Here's the Clover folder without the config.plist or the theme folder. All my kexts (lilu, weg, appleALC, USBinjectall, etc..) are in L/E thanks to "Kext Beast" and yes I rebuilt the cache w/ "kext Utility". FakeSMC is in in CLover/Kexts/other.


Thanks
Please try the attached CLOVER folder:
  • The CLOVER/drivers64UEFI folder contained both:
    • AptioMemoryFix
    • OsxAptioFix2Drv-free2000
  • Only 1 memory fix driver is allowed; so I've deleted AptioMemoryFix.
  • The CLOVER/ACPI/patched folder contained several outdated SSDTs, so the following were replaced/added:
    • USB SSDT updated to V7
    • SSDT-EC.aml added
    • NO-CNVW SSDT added to disable Intel CNVi module
    • Thunderbolt Hot Plug SSDT updated to V4
The config.plist in this CLOVER folder is unmodified, but please remember to copy serial numbers back into RtVariables and SMBIOS.
 

Attachments

  • CLOVER-Lensjocky.zip
    2.8 MB · Views: 58

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@archalys @CaseySJ
I finally got VirtualSMC to work after updating Clover to 5045 and renaming things (-64), as well as moving them to the right folder.
have to say that having an external bootable OS on TB3 really comes in handy when you want to mess things up :D

I finally have all the cores temps and fans readings correctly showing up in HWMonitorSMC2.
Out of this a new question came up: how do I get to control fans? Macs Fan Control showed me the middle finger saying that something else is controlling the fans... now that's a surprise :D
any hints? do I need some other kext or config file?

@svandive
I am not overclocking (cores get to a max of 4.7GHz) and temps rise to 85/88 degrees during raytracing.
HWMonitorSMC2
Control of the fans is handled by some poltergeist because I am sure not doing anything.

What cooler do you use on the i9-9900K?
what are your temps under stress?
I'm worried since I don't know how high they're supposed to be while crunching.

running in Windows I tried mining bitcoins with all the cores at max and while iCue was running I had no alerts.
the alerts, by the way, are only triggered by HWMonitor (not SMC2) at close to 90ºC.
HWMonitorSMC2 doesn't seem to throw a fit :)
Alas there's no poltergeist :), but fan control is not currently possible. Only fan monitoring is possible. But even monitoring was not available until VirtualSMC, so this is a start. I use BIOS to control fans as described here:
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,463
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Are you going to release the latest versions of SSDT? Are you going to attach it to the instructions? Can I get a copy to test out?
I’ll send you a copy of both SSDTs by private mail later this evening.

I don’t expect to release this version in the near term because it is still highly experimental. Releasing it now can lead to a huge list of problem reports.

You can certainly help by doing the following:
  • Checking whether hot plug works on your Thunderbolt devices.
  • Checking whether the system can still sleep and wake properly with connected Thunderbolt devices.
  • Checking for any unusual behavior from Thunderbolt devices and drivers. If you own a UAD audio controller and UAD plug-ins, testing them would be especially helpful.
Files sent via PM.
 
Top