Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Feb 18, 2019
Messages
45
Motherboard
ASRock Z390 Ph-Gam ITX
CPU
i9-9900K
Graphics
Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
With MSR unlocked, have you tried replacing OsxAptioFix2Drv-Free2000.efi with AptioMemoryFix-64.efi and removing slide=0?
I too unlocked the MSR on the Designare mobo and ran the tests you ask about. Since unlocking the MSR, I've un-checked KernelPM (and AppleIntelCPUPM is also un-checked), and booting is fine.

I tried:
  • AptioMemoryFix-64.efi ± slide=0
  • AptioMemoryFix-64.efi + EmuVariableUefi-64.efi ± slide=0
All of the above won't boot (crossed circle).

I returned to OsxAptioFix2Drv-Free2000.efi + EmuVariableUefi-64.efi + slide=0, and all is well again.

***

BTW, on the ASRock Z390 Phantom Gaming ITX mobo, it appears that v1.6 BIOS is natively unlocked. While the Designare CFG Lock is at 0x5C1, the ASRock is at 0x5C4 and shows 0x00 if booted with Grub. (I did start a new thread but it's waiting on Moderator approval, and posted these results.) The ASRock works well with OsxAptioFix2Drv-Free2000.efi alone, but panic re-starts on AptioMemoryFix-64.efi alone, but is stable if EmuVariableUefi-64.efi is also present.
 
Joined
Mar 3, 2019
Messages
1
Motherboard
Gigabyte Z390 Designare
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Air
Hi, newbie to this mackintosh stuff and actually had someone help me install it so not totally familiar with the whole process.
Overall, the setup has been working but after I did migration assistant to move over some files and applications, I now have sound that will drop out after prolonged sleep (i.e. overnight. I get sound working normally with short periods of sleep--put it to sleep for 5s, 5 min, etc.) It comes back normally after I reboot. It doesn't seem to do this in Windows.

Anyone else with similar problem or suggestion? Should try the fix suggested in post 4,319?
Thanks.
 
Joined
Jun 13, 2012
Messages
80
Motherboard
GA-Z97X-UD7 TH
CPU
i7_4790k
Graphics
270x [x2]
Mac
Mac Pro
Classic Mac
Mobile Phone
Other
MacOS 10.14.5 has robust support for Vega 56, Vega 64, and Radeon VII. I'll add this statement to the build guide shortly, but for 10.14.5 we should not need to apply any fix whatsoever for these GPUs.

EDIT: Added the following statement in red to build guide:
View attachment 407091
OK cool I got it
deleted the Vega64 fan and power
however...
Im confused about the platform IDs specified under the 'Going the extra mile' chapter.
if i keep my iMac 19,1 SMBIOS and want iGPU in headless mode
where do i input that configuration under the 'devices' tab of config.plist?
am i missing a PciRoot under 'devices'?

I've attached screenshot

thank you Sir!
 

Attachments

Joined
Apr 20, 2010
Messages
30
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Ps Speed seems higher with 10.14.5
My Geekbench scores are a bit lower than yours (6290/34014) on 10.4.5, but my memory is only 2666Mhz...
What's your memory speed and do you have any BIOS memory/CPU optimisation or overclock ?
 
Joined
May 20, 2019
Messages
2
Is this build still relevant in May 2019? When you would build it today - would you take newer components? i9?
 
Top