Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Nov 3, 2017
Messages
201
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
I have experienced this myself, but the root cause is different! As soon as I run Windows, it initializes the Titan Ridge chip in a different way than MacOS.

Before I boot back into MacOS, I have to do a full power shutdown, boot into MacOS, then unplug and replug my Thunderbolt dock, and everything is fine again.

In other words, in my experience, Windows interferes with the initialization done by MacOS.
What happened to me was I look at the PCI in "About This Mac" and the only PCI info was the RX580, but after I booted into Windows and hooked up to mu M.2 thunderbolt connection, it showed the Titan information. That was quite odd.
 
Joined
Apr 3, 2019
Messages
5
Motherboard
designare z390
CPU
9900k
Graphics
vega 56
Hi @CaseySJ
I am having issues with wifi/BT. My system was unable to detect my 2.4ghz network (though I fixed this by following this guide: https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/ ). However, I am getting only 70-80 down on my 5ghz network. Sometimes it falls off to around 30mb.
I have extensively tested my wifi and should be getting about 300mbps.
I tried following this to get the AirportBrcmFixup to work. I tried it with and without the "brcmfx-country=#a" boot argument, no luck.

It does not detect bluetooth devices either. When I plug in a magic keyboard 2, it was displayed as connected and charging in the bluetooth device list and was useable. When unplugged, the keyboard remained in the list but was not functional.
I then tried downloading BT4LEContinuityFixup (here; also described in "an idiots guide..") but was unsure of what to do with the files contained in the .zip from github. I searched around and found only a couple other outdated guides to solving the BT issue.

Suggestions?
Thanks
 
Joined
Apr 19, 2019
Messages
1
Motherboard
Gigabyte Z390 Designare
CPU
Intel i9 - 9900K
Graphics
Sapphire Radeon Vega 64
Hey CaseySJ, I put together my computer with your guide and it's worked perfectly. Thank you so much. Your thorough walkthrough and all the supporting documentation was helpful and educational. I can't imagine how much work you've put into this guide and supporting this community, but it really is appreciated. A very sincere thanks from the bottom of my heart.
 
Joined
Aug 13, 2010
Messages
30
Motherboard
Gigabyte Designare z390
CPU
i9 9900k
Graphics
Vega Frontier
Classic Mac
LC
Mobile Phone
Android
Some initial comments (which means additional steps might be needed, but we should start with this):
  • Because you’re using sysdef iMacPro1,1 it is best to delete the IGPU settings from Devices —> Properties.
  • The iMacPro uses an Intel Xeon and X299 chipset. There is no IGPU in a Xeon, hence iMacPro requires dGPU.
  • Because you’ve disabled IGPU in BIOS, there’s no need for “ig-platform-id” or “device-id” or “framebuffer-patch-enable”.
  • Latest version of Lilu and WhateverGreen should be installed in /Library/Extensions and in CLOVER/kexts/Other. Must run Kext Utility to rebuild kernel cache after any modification to /L/E folder.
  • To identify cause of sleep/wake problems, it’s best to unplug all USB devices with the exception of keyboard and mouse, test sleep/wake, and if it’s okay, plug in one USB device at a time and recheck sleep/wake (no need to reboot).
  • If sleep/wake is a problem even with all USB devices removed, then check for differences between single monitor and multiple monitors.
  • Are you using a kext or SSDT or Clover to control Vega fan and power?
I did everything, removed VegaTab, nothing works. DP monitor will usually not wake and then KP.
I have a feeling I need to choose the right FrameBuffer. In Clover, Graphics --> FB Name, I have tried Iriri and Kamarang. Nothing changed but I am not sure if I need to do some other patch?

I did download a vega Frontier SSD I found around here (attached) and now my Vega Frontier shows properly in "About this Mac", I achieved about 10fps more in DavinciResolve but on idle the fans are 40+% (even after adding VegaTab Kext.)

And still DP monitor does not wake up (most times). About 2 out of 8 times, the computer will wake just fine. No KP.
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,134
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Hi @CaseySJ
I am having issues with wifi/BT. My system was unable to detect my 2.4ghz network (though I fixed this by following this guide: https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/ ). However, I am getting only 70-80 down on my 5ghz network. Sometimes it falls off to around 30mb.
I have extensively tested my wifi and should be getting about 300mbps.
I tried following this to get the AirportBrcmFixup to work. I tried it with and without the "brcmfx-country=#a" boot argument, no luck.

It does not detect bluetooth devices either. When I plug in a magic keyboard 2, it was displayed as connected and charging in the bluetooth device list and was useable. When unplugged, the keyboard remained in the list but was not functional.
I then tried downloading BT4LEContinuityFixup (here; also described in "an idiots guide..") but was unsure of what to do with the files contained in the .zip from github. I searched around and found only a couple other outdated guides to solving the BT issue.

Suggestions?
Thanks
Which Broadcom card are you using? The BCM94360 series will work without any drivers or patch RAM or fix-up kexts. There can be signal attenuation issues due to any combination of:
  • Low gain / low quality antennas.
  • Metal surfaces / other obstructions between the antenna and router / wireless device.
Some suggestions:
  • Please post a screenshot of “System Information —> WiFi” (you may redact any private info) and “Bluetooth”
  • It’s may be possible to connect the relocatable antenna that comes in the Designare box to two of the antenna connectors on the WiFi card. That can boost the signal to local Bluetooth devices.
  • It’s also possible to purchase high gain antennas, but this should only be done once signal attenuation is found to be the cause.
  • If you have another computer or smartphone in the same location as the antennas, you can check it’s signal strength / transfer speed from that location.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,134
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Hey CaseySJ, I put together my computer with your guide and it's worked perfectly. Thank you so much. Your thorough walkthrough and all the supporting documentation was helpful and educational. I can't imagine how much work you've put into this guide and supporting this community, but it really is appreciated. A very sincere thanks from the bottom of my heart.
Thank you; glad to hear the process went well! And of course, welcome to the forum!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,134
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I did everything, removed VegaTab, nothing works. DP monitor will usually not wake and then KP.
I have a feeling I need to choose the right FrameBuffer. In Clover, Graphics --> FB Name, I have tried Iriri and Kamarang. Nothing changed but I am not sure if I need to do some other patch?

I did download a vega Frontier SSD I found around here (attached) and now my Vega Frontier shows properly in "About this Mac", I achieved about 10fps more in DavinciResolve but on idle the fans are 40+% (even after adding VegaTab Kext.)

And still DP monitor does not wake up (most times). About 2 out of 8 times, the computer will wake just fine. No KP.
Hello @mattbatt, it may be helpful to examine the Clover configuration. Can you compress and upload the Clover folder from the Mojave SSD?

Have you searched for any AGDP (Apple Graphics Display Policy) patches?

WhateverGreen supports 3 “agdpmod” arguments as well, described midway down this link:

Also give this a try:
  • Boot from the USB install disk (F12 at BIOS splash screen) and choose standard “Boot macOS from Mojave”.
  • This will use the Clover settings on the USB.
  • Login to Mojave and check sleep/wake behavior.
 
Joined
Oct 18, 2012
Messages
70
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
Hi CaseySJ,
Thanks again for the nice guide!! Is there a way to check if the iGPU is really handling some compute tasks?
I have attached a screenshot from VideoProc and it says that both H264 and HEVC hardware acceleration are available. But it's not showing anything about iGPU. Is it possible that this means that they are supported by the RX 580?

Hi...for everyone that want
to check if you are in Headless Mode and you have IGPU for the task like Quick Look :

Download VideoProc:

Download this Video:

Download Intel Power Gadget:

To check in VideoProc:
Open the APP, click on Video Tab, then Options. (eventually click the refresh button on the right side).
If you see the green light on HEVC and H264 you are ok.

Test the Sony Demo Video with Intel Power Gadget open.
Open Activity Monitor, and select from Window menu Gpu History.
If you see Low Cpu Load on Intel Power Gadget you are ok.

My Cpu is I5 8400.
Use Device-Id and Platform for your CPU!
 

Attachments

Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,134
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Hi everyone, I was wondering if it is normal that on my build based on Z390 AORUS XTREME the Bluetooth and the Thunderbolt do not work or at least they do not appear in the system information. Thanks in advance for every suggestion.
Thunderbolt will not appear in the Thunderbolt section, but should appear in PCI section. This is because Thunderbolt Local Node and Thunderbolt Bus are not available on Hackintosh.

If you have a Broadcom WiFi/BT card plugged into a PCIe slot -- especially one with the BCM94360 chip -- then it should be available out-of-box with no drivers. The Intel CNVi that comes with the AORUS XTREME is not supported in macOS, so we install the following SSDT into CLOVER/ACPI/patched to make it invisible to macOS:

SSDT-Z390-DESIGNARE-NO-CNVW.aml

Despite the name, it is compatible with your motherboard. This SSDT can be found in Post-Install Files.zip at the bottom of Post #1.
 
Top