Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
12,214
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I apologize for not providing that to begin with, I will do better next time. I am using a sandisk cruzer 32gb, I also have a brand new Transcend 16gb if I need to use a different one. I have tried the following ports:

View attachment 399629

I have tried SS01/HS01, SS06/HS06, SS05/HS05 and the two usb ports in the front SS07/HS07 and SS08/HS08.
Step 1:
Please copy WhateverGreen.kext into CLOVER/kexts/Other, and delete WhateverGreen.kext.textClipping.

Screen Shot 2019-04-14 at 11.06.15 AM.png

Let's see if that allows you to move to the next step...
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
12,214
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello @CaseySJ, thank you so much for patience and help. I am still erroring out, with that same com.apple.xpc, and here is something I noticed that happened during booting from the usb:

View attachment 399634
This is going to be somewhat shaky advice based on some searches, but:
  • Enable CSM in BIOS, remove RX 580, set Initial Display Output to IGFX, connect HDMI cable to on-board HDMI port. While in BIOS, make sure correct BIOS version is still installed (motherboard can revert automatically to an older BIOS).
  • Power down. Remove power cable for 10 seconds to reset CMOS. Power up.
  • See if the Clover will start up.
  • If not, rebuild the USB install disk starting with Disk Utility --> View --> Show All Devices, select parent name of the USB disk, then erase the USB disk. Format the USB as "MacOS Extended (Journaled)" instead of APFS.
Also please confirm that WhateverGreen.kext has been copied to CLOVER/kexts/Other (file should be larger than 450KB).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
12,214
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
CSM enabled, I removed the RX 580, Set Initial Display to IGFX, HDMI connected to mobo. BIOS is good to go, and the WhateverGreen.kext I have downloaded is 1.2.8 and is 462kbs. That look good?
Yes, are you able to reach the MacOS installer?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
12,214
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Sadly, I haven't been able to. I suppose the next step is to do a complete creation of the USB.
Also uncheck “Plugin Type” from ACPI section of Clover Configurator.

Jbarnett has uploaded his EFI folder in his build guide, so that’s another option. Just copy that EFI folder to the EFI folder of your USB disk...
 
Joined
Mar 1, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
:headbang: I finally made it to step 1. So, I recreated the USB on another Mac. I have a 2018 MacBook Air that has Mojave. I initially was using my 2010 MacBook that HighSierra. The reason I didn't use the MacBook Air, was because that's my work laptop so I try to keep all personal stuff off of it.

Anyway, I followed all the instructions to redo the USB, while unchecking "Plugin Type".

So right now I'm at the Disk Utility, no RX 580 installed, and Bios setup the way you recently recommended. Now, my question is, when I complete this first phase, and move on to the second phase, should I install the RX 580 then and put everything back in the bios as per your OP recommendations?
 
Top