Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,121
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,121
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
well well.... tha's why I can't get iGPU in headless mode... didn't have a clue about this reverse byte order thing. :eek:
Yes, just one of those things!

Screen Shot 2019-04-08 at 7.42.29 PM.png
 
Joined
Jul 29, 2012
Messages
79
Motherboard
Gigabyte Desingnare
CPU
i9-9900
Graphics
RX 580
Mac
iMac, Mac Pro
Mobile Phone
iOS
Some comments:
  • It is a good sign that the fans are starting and stopping in relation to the load applied to the GPU.
  • But the screen should never flicker.
  • If you have a good HDMI cable (HDMI 2.0 compliant if using 4K at 60Hz), if the connections are okay, and if the power supply is good (750W), then I would do this:
    • Test the RX 580 in Windows. Do you have Windows installed on this machine?
    • If the screen flickers, then you may have a defective card.
    • If your RX 580 is still under warranty, you can contact the manufacturer's Tech Support department or use their website to open a ticket.
    • If you are within your return/exchange window, you could switch to a different make/model.
      • Sapphire Pulse RX 580 (not Nitro) is recommended.
      • MSI Gaming X (similar to mine) works well.
      • MSI Armor is also good.
      • Probably several other good choices out there.
My card is the Sapphire Pulse RX 580. Still under the Amazon returned time.
I don’t have a bootable Windows system. I don’t know how to install that. Is there any tutorial? I don’t want to destroy my Mojave installation. I guess I can install Windows 10?
I will wait for the new Display cable Just order it from Amazon. I will pass my results soon, I’m not going to be around for a few days tell F or Sat.,
Thanks again man.
Maybe i can just ask for a replace for the same card. And test other one.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,121
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
My card is the Sapphire Pulse RX 580. Still under the Amazon returned time.
I don’t have a bootable Windows system. I don’t know how to install that. Is there any tutorial? I don’t want to destroy my Mojave installation. I guess I can install Windows 10?
I will wait for the new Display cable Just order it from Amazon. I will pass my results soon, I’m not going to be around for a few days tell F or Sat.,
Thanks again man.
Maybe i can just ask for a replace for the same card. And test other one.
Because you're using HDMI, you can also test the HDMI cable by connecting it to the HDMI port on the rear IO panel of the motherboard. Are you using platform ID 0x3E9B0007 (non-headless)? And SMBIOS name Macmini8,1 or iMac18,3?

The on-board HDMI port can be enabled by following this part of the guide. However, this port supports maximum of 4K at 30Hz.
 
Joined
May 13, 2014
Messages
163
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
I ended up switching from MacMini8,1 to iMac19,1 since I was getting glitching through my second monitor which was hooked up to the UHD630 TB3 port (USB-C to DisplayPort cable) so it's working perfectly now. Interestingly, VideoProc actually does identify the CPU correctly as i9-9900K, as opposed to macOS System Information. No big deal anyway.

Had to add -no_compat_check to boot arguments too. While I know it's not ideal to run iMac19,1 on 10.14.4, I'm sure 10.14.5 is right around the corner.

I also realised I'm an idiot who didn't read properly. I kept mistyping 'shikigva=60' as 'shikivga=60' and was wondering why the flag wasn't doing anything. Same goes for setting Initial Display Output to 'IGFX' in UEFI. Setting that value properly got rid of all the display glitches I was getting.
 
Last edited:
Joined
Jul 14, 2011
Messages
10
Motherboard
Gigabyte Designare Z390
CPU
i7-8700K
Graphics
GTX 1080
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
CaseySJ, question for you - I have a multi-boot system and can use GTX 1080 for both Windows and High Sierra, but not Mojave. You also have an ACPI patch for disabling GPU in the 2nd PCIex16 slot. Do you have a patch for disabling the 1st slot to enable me to use the IGPU for Mojave without the need to remove my GPU? And if so, could you advice on how to properly set up the IGPU in config.plist, etc.?

Many thanks.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,121
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
shikigva=60 not working
Please compress and upload the CLOVER folder from your Mojave SSD. You may remove serial numbers from SMBIOS in confit.plist.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,121
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
CaseySJ, question for you - I have a multi-boot system and can use GTX 1080 for both Windows and High Sierra, but not Mojave. You also have an ACPI patch for disabling GPU in the 2nd PCIex16 slot. Do you have a patch for disabling the 1st slot to enable me to use the IGPU for Mojave without the need to remove my GPU? And if so, could you advice on how to properly set up the IGPU in config.plist, etc.?

Many thanks.
I’ll modify the SSDT for disabling slot 1 GPU soon.

As for IGPU, have you looked at the instructions here:
If you still require assistance, please upload your confit.plist minus any serial numbers in SMBIOS.
 
Top