Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,251
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Weird question, but how do I delete my "device-id" from the devices properties window? When I highlight just the device-id row and hit the minus (-) button in that window to delete the property, it deletes the entire entry in the "Devices" window right next to it.

Is that what you meant? Delete that entire entry? I'm on the latest version of Clover Configurator.
Screen Shot 2019-04-08 at 7.48.45 PM.png
 
Joined
Mar 5, 2019
Messages
53
Motherboard
Designare Z390
CPU
i7-9700K
Graphics
RX580 Pulse
Yup I did exactly that. Instead of just the row deleting though, I end up with this...

It deletes the entire device.
398386


Going to try doing it manually in Text Mode. Will make a backup of the config first of course.

**Edit: Removed it manually in TextEdit and it seems to have worked**.
 
Last edited:
Joined
Jan 29, 2019
Messages
59
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
The table below summarizes the various options available as of the release of macOS 10.14.4. For more information, refer to the section For Final Cut Pro X (FCPX) and iMovie Users below.
In the table on page 1 you suggest iMacPro1,1 as a headless option (for Pro Apps) with platform ID 0x3E980003 (IGFX disabled in BIOS). I don’t understand this yet: In my configuration (with Vega 64) I am using iMacPro1,1 SMBIOS, too. But I have Internal Graphics completely disabled in BIOS and I’m using no platform ID and headless configuration at all. I am just using the Vega 64, just as the original iMac Pro does, and everything (including HEVC and H264 encoding) is working just fine. So does this suggestion only refer to RX580?
 
Joined
May 22, 2011
Messages
917
Motherboard
GigaByte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Because you have an AMD graphics card installed, it is necessary to copy Lilu and WhateverGreen to the CLOVER/kexts/Other folder in the EFI partition of the USB flash disk.

If you continue to run into problems, please compress and upload the CLOVER folder from the USB install disk.
I think you got me wrong. I am not trying to install Mojave. I already install and everything working. When I change my primary GPU to IGPU on Bios with these ig-platform-id, I cant boot.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,251
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@CaseySJ , I might have lost the beginning of this discussion , but just to follow up and confirm HS08 and HS13 are the only USB 2.0 pieces of TB ports, and then what the HS01 and HS02 mentioned in @JimSalabim question belong to?
I'll make a note to double-check this later this evening. I think I know, but I would rather fact-check myself before posting.
After some fact-checking:
  • Designare Z390 supports one front-panel USB 3.1 Gen 2 connector via the onboard F_USB31C header.
  • This header is mapped as follows:
    • USB 3.x is mapped to SS01
    • USB 2.0 is mapped to HS01, but we have disabled HS01 because of the 15-port limit. (And of course who in their right mind would want to connect a prehistoric USB 2 device to a space-age USB-C port!)
  • HS02 is not used.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,251
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Yup I did exactly that. Instead of just the row deleting though, I end up with this...

It deletes the entire device.
View attachment 398386

Going to try doing it manually in Text Mode. Will make a backup of the config first of course.

**Edit: Removed it manually in TextEdit and it seems to have worked**.
You're right...this is a major BUG in Clover Configurator.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,251
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I think you got me wrong. I am not trying to install Mojave. I already install and everything working. When I change my primary GPU to IGPU on Bios with these ig-platform-id, I cant boot.
First let me define headless mode:
  • In headless mode the iGPU will not drive a display monitor. All the motherboard video ports will be turned off, but the iGPU will be used for compute tasks such as HEVC, H.264, Quick Look, Preview.
  • In standard non-headless mode the iGPU will drive a display monitor and be used for compute tasks (HEVC, H.264, etc.).
Next, there are 2 ways to turn on the iGPU:
  • Through Clover. This is done by enabling "Inject Intel", specifying IntelGFX (0x59128086 for High Sierra), and setting ig-platform-id from the Graphics page.
  • Through WhateverGreen. This is done by specifying Devices --> Properties.
We cannot use both Clover and WhateverGreen to control the iGPU. We must choose one or the other.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,251
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
In the table on page 1 you suggest iMacPro1,1 as a headless option (for Pro Apps) with platform ID 0x3E980003 (IGFX disabled in BIOS). I don’t understand this yet: In my configuration (with Vega 64) I am using iMacPro1,1 SMBIOS, too. But I have Internal Graphics completely disabled in BIOS and I’m using no platform ID and headless configuration at all. I am just using the Vega 64, just as the original iMac Pro does, and everything (including HEVC and H264 encoding) is working just fine. So does this suggestion only refer to RX580?
You're right. For iMacPro1,1 (Xeon CPU) there is no built-in iGPU so no need for ig-platform-id. I'll update the table shortly.
 
Top