Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Nov 3, 2018
Messages
307
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
something weird going here...
I enabled iGPU again in BIOS to try using new platform ID for 10.14.4 in headless mode (SMBIOS macMini8,1) and got stuck here on boot:

View attachment 398328

If I disable iGPU, everything goes fine (with no jpeg quick look and Geekbench slightly lower tho)

Anyone has an idea of what is going here?

thanks
Why do you use macmini8,1 SMBIOS? iMac19,1 is more suitable, update clover configurator to apply. Also you may need to run 10.14.5 beta.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,298
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Why do you use macmini8,1 SMBIOS? iMac19,1 is more suitable, update clover configurator to apply. Also you may need to run 10.14.5 beta.
Anyone wishing to run a beta version is free to do so on their own, in which case they must not ask for any help from this thread. They should post their issues directly to the Mojave Support Forum. This guide and this thread are based exclusively on Released versions.
 
Joined
Apr 25, 2011
Messages
22
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Why do you use macmini8,1 SMBIOS? iMac19,1 is more suitable, update clover configurator to apply. Also you may need to run 10.14.5 beta.
Because when I followed this guide (in January) I remember macmini8,1 was the one there. And now I'm not up to change Serial Number and deactivate/active all my audio plugins and softwares while my schedule has some jobs and clients to attend.
 
Joined
Jul 29, 2012
Messages
79
Motherboard
Gigabyte Desingnare
CPU
i9-9900
Graphics
RX 580
Mac
iMac, Mac Pro
Mobile Phone
iOS
@CaseyJS, I don't know if this make sense, I did a bit of research and I find this:

Run a good benchmark like Unigen Heaven, when the GPU gets over ~55-60C the fans will turn on. The fan is controlled by the vBios and will function the same way regardless of the OS. My GTX 970 is the same way.
I download the software and the fans run like crazy, I bench the extreme preset and It works, but a soon I stop this test the fans stop after a few seconds and the flickering start again. Any ideas?
Thanks again for all your help.
 
Last edited:
Joined
Oct 18, 2012
Messages
79
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
Hi Casey.

I have this on Memory Tab. The 4th slot is missing. (It's empty).
If I remember prior to 10.14.4 the slot was visible.
What do you think?
Thank you
Max
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,298
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@CaseyJS, I don't know if this make sense, I did a bit of research and I find this:

I download the software and the fans run like crazy, I bench the extreme preset and It works, but a soon I stop this test the fans stop after a few seconds and the flickering start again. Any ideas?
Thanks again for all your help.
Some comments:
  • It is a good sign that the fans are starting and stopping in relation to the load applied to the GPU.
  • But the screen should never flicker.
  • If you have a good HDMI cable (HDMI 2.0 compliant if using 4K at 60Hz), if the connections are okay, and if the power supply is good (750W), then I would do this:
    • Test the RX 580 in Windows. Do you have Windows installed on this machine?
    • If the screen flickers, then you may have a defective card.
    • If your RX 580 is still under warranty, you can contact the manufacturer's Tech Support department or use their website to open a ticket.
    • If you are within your return/exchange window, you could switch to a different make/model.
      • Sapphire Pulse RX 580 (not Nitro) is recommended.
      • MSI Gaming X (similar to mine) works well.
      • MSI Armor is also good.
      • Probably several other good choices out there.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,298
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Hi Casey.

I have this on Memory Tab. The 4th slot is missing. (It's empty).
If I remember prior to 10.14.4 the slot was visible.
What do you think?
Thank you
Max
First things that come to mind:
  • Power down the system and remove power cable. (Yes, remove power cable.)
  • Check that all 4 DIMMs are seated properly in their DIMM slots.
  • Power the system back on and enter BIOS Setup.
  • Check that BIOS F6 is running. Under certain circumstances the motherboard will automatically switch back to BIOS F3.
  • If F6 is running, go to "M.I.T." section and enable X.M.P. Memory Profile 1.
  • If F6 is not running, flash to F6 and set BIOS parameters.
  • Check that all 4 DIMMs are detected by the BIOS. One of the BIOS pages will show this.
 
Joined
Oct 18, 2012
Messages
79
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
removed power cable...
same situation:confused:
I have only 3 DIMMs installed.
Last check is to reseat the Dimms.
 

Attachments

Joined
Mar 23, 2019
Messages
14
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
GTX 1080 Ti
Mac
MacBook Pro
Mobile Phone
iOS
Some comments:
  • You will need the complete High Sierra installer (between 5 and 6 GB).
  • If you encounter the error again during Step 11 (or any other), please open the Installer Log from the Tools menu (CMD-L?) and grab a screenshot of the error.
This option should be available from the M.I.T. section of BIOS (Classic Mode, not "Easy Mode"). Also ensure that your RAM supports XMP 2.0.
@CaseySJ
Thank you for your comments.
I will try to get the log.

My RAM does not support XMP 2.0. Is XMP supports RAM required to install macOS to this motherboard?
In that case, I need to buy another RAM.
 
Joined
Mar 5, 2019
Messages
53
Motherboard
Designare Z390
CPU
i7-9700K
Graphics
RX580 Pulse
Hey Casey,

I noticed you updated your guide and included a handy platform chart. I was going to go with the 10.14.4 mac mini (non-headless) for now. Where do I set the platform for my system? Do I have to use 0x3E9B0007 like that exactly? Noticed in Devices --> Properties tab it doesn't look like that.
 

Attachments

Last edited:
Top