Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,354
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Interested
I see you edited your post! :)
  • With original BIOS, but Vt-d enabled, your Antelope Audio device connects, but Ethernet fails?
  • If so, can you please connect the Antelope Audio device and provide a screenshot of an application that shows it is working?
  • Also please run IORegistryExplorer and scroll down to RP05 section (do not use 'search') and post a screenshot of either DSB1 or DSB4 where the Antelope device is connected.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,354
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I'm having the same experience with these settings exactly. Apple Ethernet adapter is working, but the Fenvi card will not work. In fact, I'm seeing a message about the board in post, pre OpenCore.
Attached is the config.plist from my Z390 Designare (with DisableIoMapper unchecked and dart=0 removed). Please see if you can spot any meaningful differences between this file and your file.
 

Attachments

  • config-casey-z390-designare-vt-d.plist
    25.7 KB · Views: 20

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,354
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@mrfatcatt,

We managed to enable Apple Thunderbolt-to-Gigabit Ethernet adapter in Big Sur simply by enabling Vt-d as described here. This screenshot from Big Sur shows that AVB is indeed working.

Screen Shot 2021-06-22 at 10.46.56 AM.png
 
Joined
Jun 6, 2020
Messages
56
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
I see you edited your post! :)
  • With original BIOS, but Vt-d enabled, your Antelope Audio device connects, but Ethernet fails?
  • If so, can you please connect the Antelope Audio device and provide a screenshot of an application that shows it is working?
  • Also please run IORegistryExplorer and scroll down to RP05 section (do not use 'search') and post a screenshot of either DSB1 or DSB4 where the Antelope device is connected.
Sorry, I was a little confused… the antelope was still connected to usb…
But I can confirm that ethernet fails
 
Joined
Dec 15, 2010
Messages
261
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
HD 630HD + RX 6900 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Attached is the config.plist from my Z390 Designare (with DisableIoMapper unchecked and dart=0 removed). Please see if you can spot any meaningful differences between this file and your file.
Not seeing anything in settings. The main difference is ssdt and kext related. SSDT- I'm using my HackinDrom for thunderbolt and Kext- I'm not using either USBInjectAll kext as I have them mapped. Also not using USB Wakeup or RestrictEvents kexts.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,354
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
How did you managed to have theses IOAVB attached labels ?
As soon as I connect an Ethernet cable and obtain an IP address, then IOAVB labels appear.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,354
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Sorry, I was a little confused… the antelope was still connected to usb…
But I can confirm that ethernet fails
Thank you for volunteering. I would like to conduct this test somewhat methodically. Are you okay with the following approach?
  • First we will enable Vt-d and connect the Antelope Audio device. We'll examine the results.
    • This will be our baseline.
  • Then we can update the BIOS and check results again.
To begin, let's do the following:
  • State the make and model of your Antelope Audio interface.
  • Enable Vt-d by doing the following:
    • BIOS --> Enable Vt-d
    • config.plist --> Uncheck DisableIoMapper
    • config.plist --> Boot Arguments --> Remove dart=0
  • Reboot the system.
    • Antelope Audio device can be connected and powered before boot, or you may hot plug it afterwards. Either way is okay.
  • When system is rebooted, please ensure that Antelope device is now connected and powered up.
  • Run IORegistryExplorer and grab the following screenshots (press CMD-Shift-5 to capture screenshots):
    • At the very top of the IOReg tree you will see AppleVTD. Capture screenshot and post. It should look something like this:
      Screen Shot 2021-06-22 at 8.52.00 AM.png
    • Then scroll down to RP05 section (do not use 'search') and post screenshot of the DSB1 or DSB4 section where the Antelope device appears. In the screenshot below we can see that my Apple Thunderbolt-to-Gigabit Ethernet adapter is on DSB1:
      Screen Shot 2021-06-22 at 8.51.41 AM.png
If you have any questions, please ask at any time.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,354
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Not seeing anything in settings. The main difference is ssdt and kext related. SSDT- I'm using my HackinDrom for thunderbolt and Kext- I'm not using either USBInjectAll kext as I have them mapped. Also not using USB Wakeup or RestrictEvents kexts.
I have the Fenvi installed in a PCIe x1 slot (short slot). Is it the same for you?
 
Joined
Aug 23, 2018
Messages
170
Motherboard
GA Z390 Aorus Master
CPU
i9-9900K
Graphics
Radeon RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Enabling VTD, ethernet and wifi stay disconnected. No wifi kexts.
 
Top