Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

VVK

Joined
Aug 29, 2015
Messages
26
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
Sapphire Nitro+ RX 5700 XT
Mobile Phone
  1. iOS
You may install the Fenvi into any slot on the AORUS Pro. Some users have reported that their motherboard does not boot if the Fenvi is installed in a particular slot, but this can be different for every user. So please try a short slot first.
Got that Fenvi card. Installed in x1 slot, everything’s working like a charm, both in Windows 10 and Big Sur. Gigabyte Z390 Aorus Pro.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,826
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello @CaseySJ, I just tried but still, it does not open some JPG. I can open small JPG and PNG like 35KB, 10KB.
Also on Hackintool the Platform ID is still 0x00000000.
Thanks
This might indicate that WhateverGreen is not running. Please do the following:
  • Type kextstat | grep -v apple in Terminal and post the reply.
  • Download and run IORegistryExplorer and select File --> Save As..., then post the saved file.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,826
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
IIRC the kext and patch load order is still important?
The kext load order is specified in OpenCore, and the order matters. But in Clover we don't specify the order.
 
Joined
Nov 7, 2013
Messages
102
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
SIP has been enabled in the OC 0.6.7 EFI folder. Please see the red boldface lines in that post. Disabling SIP might solve this problem.
Thanks, disabling SIP fixed the issue. Odd that the application will not work without SIP disabled. :crazy:
 
Joined
Aug 13, 2010
Messages
109
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700
Mobile Phone
  1. Android
@casey and Master Hack Folks

Is there any way you can further investigate getting the Apple to Ethernet adapter working on this motherboard in Big Sur, per my issue of running my pro audio avb sound in Big Sur. I doubled check and took my audio interface to my other machine, a Gigabyte Z370, and the same issue of the Thunderbolt not showing up in Ethernet port occurred. I even pluged it into the original Alpine Ridge one controller that had TB2 ports on it as well as 3. The devs reached out to Apple, and Apple said basically they wont help us cause where not using their hardware. I really want to avoid buying a additional Ethernet card. All of the options we talked about are $90 plus. I dont even think I have a option slot in my motherboard as I have an Avid HD card and a UAD card already in them as well as my AMD 5700. Again this sound card works flawlessly on Catalina.

Should maybe I post in the main forum if there is no viable option here although im sure there is a work around cause you guys are stellar!!!

I tried all the security tb options, no luck.
Thanks all for you help.

Original post:
 
Joined
Dec 22, 2019
Messages
34
Motherboard
Gigabyte Z390 Designare
CPU
i5-9600k
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
This might indicate that WhateverGreen is not running. Please do the following:
  • Type kextstat | grep -v apple in Terminal and post the reply.
  • Download and run IORegistryExplorer and select File --> Save As..., then post the saved file.
HELLO @CaseySJ, please find the result below, Thanks
(note sure if this is the right way to post it)
Code:
  [Restored Mar 8, 2021 at 11:42:32 AM]
Last login: Mon Mar  8 08:53:11 on console
Restored session: Tue Feb 16 16:44:43 PST 2021
MusicDom:~ musicdom$ kextstat | grep -v apple
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
   16    5 0xffffff7f80d1a000 0x12000    0x12000    org.netkas.driver.FakeSMC (1800) FC7031CC-C949-35D1-AC1A-CA8DB349793E <12 8 6 5 3 1>
   17    0 0xffffff7f80ff4000 0x6000     0x6000     com.rehabman.driver.USBInjectAll (0.7.1) A5767EA0-3760-3131-B996-28EE85139CF5 <13 12 5 3>
   18    2 0xffffff7f8102c000 0x23000    0x23000    as.vit9696.Lilu (1.3.6) 793EEE62-381C-3F9D-B54F-8515397591B5 <8 6 5 3 2 1>
   19    0 0xffffff7f8104f000 0x64000    0x64000    as.vit9696.WhateverGreen (1.2.9) 7C9AFF33-DB1A-352E-9569-1F23DF0193BE <18 13 8 6 5 3 2 1>
   20    0 0xffffff7f811e1000 0x110000   0x110000   as.vit9696.AppleALC (1.3.8) 27CB586F-8863-3720-8EB4-A76EDF07E6D3 <18 13 8 6 5 3 2 1>
   66    0 0xffffff7f82cdb000 0x8000     0x8000     org.rehabman.driver.FakePCIID (1.3.15) B185B092-1FC9-308E-B093-32FD88E5822D <13 8 6 5 3 1>
   67    0 0xffffff7f811ad000 0x23000    0x23000    com.insanelymac.IntelMausiEthernet (2.4.0) F99BECF1-A2CE-3C72-A66F-FCFBD5395306 <21 13 6 5 3 1>
  107    0 0xffffff7f80fe0000 0xb000     0xb000     org.hwsensors.driver.ACPISensors (1800) FA4DF6C0-0D3A-3CE2-8569-0AB2C84053E7 <16 12 8 6 5 3>
  111    0 0xffffff7f80fed000 0x7000     0x7000     com.intel.driver.EnergyDriver (3.7.0) 35E739F9-BF6C-3024-A67C-750711B3FB64 <8 6 5 3>
  114    0 0xffffff7f8409c000 0x96000    0x96000    com.uaudio.driver.UAD2System (9.12.1) no UUID <113 87 13 6 5 3 1>
  115    0 0xffffff7f812f8000 0x5000     0x5000     org.hwsensors.driver.SMMSensors (1800) 97DDF4ED-310B-3123-988E-E1A9890743A6 <16 8 6 5 3>
  122    0 0xffffff7f81424000 0x22000    0x22000    com.smalltree.driver.SmallTreeIntel82576 (1.2.5) 0E5F5CDA-75BD-3359-8426-E494578D6491 <21 13 6 5 3 1>
  123    0 0xffffff7f811d0000 0xe000     0xe000     org.hwsensors.driver.LPCSensors (1800) EF5BB9DC-C33F-3EED-9F96-42A7F22D806F <16 13 12 8 6 5 3>
  127    0 0xffffff7f80e61000 0x7000     0x7000     org.hwsensors.driver.CPUSensors (1800) ED90DA0F-5876-3DB5-82EC-CEEA470A7479 <16 8 6 5 3>
  128    0 0xffffff7f80e68000 0x16000    0x16000    org.hwsensors.driver.GPUSensors (1800) C6BE6BDA-2398-3318-BCF0-F519AD4DB140 <16 13 12 8 6 5 3>
  135    0 0xffffff7f82fbb000 0x3b000    0x3b000    com.uaudio.driver.UAFWAudio (4.3.1 47542) 7768A827-9D44-3C93-9B59-9224F4F8C9CE <113 87 6 5 3 1>
  140    0 0xffffff7f81139000 0x39000    0x39000    tc.tctechnologies.driver.Saffire (4.3.0 41017) 3563D1B5-FFE0-380D-B232-6D2D6CF819F7 <113 87 6 5 3 1>
  141    0 0xffffff7f80e57000 0xa000     0xa000     com.Cycling74.driver.Soundflower (2) 2D779840-7439-31E5-8A66-D786C3F47B75 <87 6 5 3>
  146    0 0xffffff7f812fd000 0x43000    0x43000    com.paragon-software.filesystems.ntfs (143.5.15) 92FAB980-65D4-3DAF-8CE5-ACE15B78CF44 <8 6 5 1>
  150    0 0xffffff7f829e4000 0x4000     0x4000     com.paceap.kext.pacesupport.snowleopard (5.9.1) 25206F6A-6BC3-E93C-C31E-371502C8CE8E <8 6 5 3 1>
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,826
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ, please find it attached. Thanks
It seems that iGPU is disabled in BIOS. Please do the following:
  • BIOS Setup --> Internal Graphics --> Enabled (not Auto)
  • Save settings
  • Log back into macOS and check Hackintool --> Platform ID.
  • Then check QuickLook / Preview.
 
Top