Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Aug 18, 2020
Messages
25
Motherboard
Gigabyte Z390 Mater
CPU
Intel 9900k
Graphics
RTX2080
@zk2004mb

If you (a) cold boot into macOS and then (b) warm boot back into macOS, does the LG monitor work fully (both the display and its on-board devices)?

Then each time to reboot into macOS -- without booting into Windows -- does the LG monitor continue to work?

Any time we boot into Windows, we upset the 'balance in the Force' (i.e. Windows tries to re-initialize and reconfigure the Titan Ridge controller). So each time you switch from a Windows session to a macOS session, it may be best to cold boot.

I tried following two sets.
1. (a) cold boot into OSX, display works, no on-board devices. (b) warm reboot into OSX, display doesn't work but other devices all work including USB-C. (c) replug the monitor, display gets back, on-board devices all gone.

2. (a) cold boot into OSX, display works, no on-board devices. (b) warm reboot into OSX, display doesn't work but other devices all work including USB-C. (c) warm reboot again into OSX, the monitor works exactly the same as (b), no display, other devices works including usb. (d) then I replug the monitor, display gets back, on-board devices all gone.

Currently it all based on GC-TITAN-RIDGE_rev50_Elias64Fr.bin
 
Last edited:
Joined
Aug 18, 2020
Messages
25
Motherboard
Gigabyte Z390 Mater
CPU
Intel 9900k
Graphics
RTX2080
Hi all, back from a couple month break. anyway i followed the catalina guide to a T a while back, including putting my windows m2 drive closest to the cpu as stated in the instructions. Anyway during my windows gaming time, an update must have killed my macos install. Even my setup usb doesn't work in getting back in..

can anyone help me fix this? do i need to reinstall? if so will it kill my windows drive?

really appreciate any assistance,
pitt1717
Are you using separate ssd for both systems or just one? Also are you using OC?
 
Joined
Aug 18, 2020
Messages
25
Motherboard
Gigabyte Z390 Mater
CPU
Intel 9900k
Graphics
RTX2080
im still on clover, and i have separate m2 drives for each os
Sorry I have no experience in Clover. But technically, you can first format the drive with macos in it and physically remove the windows m2. Then do a clean reinstall for macos. It shouldn't affect your windows drive.

FYI, in OC, all you need to do is keep your fully configured EFI folder and do a simple re-install for macos, it will never affect the windows partition.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,787
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
im still on clover, and i have separate m2 drives for each os
Before you do anything, please describe the problem:
  • What do you mean by cannot "get back in"?
  • When you boot the computer and press F12 during the BIOS Splash Screen, the BIOS Boot Menu will appear.
  • Do you see the macOS SSD listed there?
  • If so, when you select that SSD, does Clover Boot Menu appear?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
15,787
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I tried following two sets.
1. (a) cold boot into OSX, display works, no on-board devices. (b) warm reboot into OSX, display doesn't work but other devices all work including USB-C. (c) replug the monitor, display gets back, on-board devices all gone.

2. (a) cold boot into OSX, display works, no on-board devices. (b) warm reboot into OSX, display doesn't work but other devices all work including USB-C. (c) warm reboot again into OSX, the monitor works exactly the same as (b), no display, other devices works including usb. (d) then I replug the monitor, display gets back, on-board devices all gone.

Currently it all based on GC-TITAN-RIDGE_rev50_Elias64Fr.bin
Do you have a second monitor with HDMI input? Some folks have found it necessary to connect a second monitor over HDMI (HDMI can be connected directly to the same AMD GPU) in order for the LG UltraFine or other Thunderbolt monitor to work more consistently.
 
Joined
Aug 18, 2020
Messages
25
Motherboard
Gigabyte Z390 Mater
CPU
Intel 9900k
Graphics
RTX2080
Do you have a second monitor with HDMI input? Some folks have found it necessary to connect a second monitor over HDMI (HDMI can be connected directly to the same AMD GPU) in order for the LG UltraFine or other Thunderbolt monitor to work more consistently.
Yes, I do have a working second monitor under DP cable connect to the graphics card. I will switch to HDMI and do the test again.
 
Joined
Feb 10, 2019
Messages
261
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 770
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Have you jumped Pins 1 and 3 together to enable the card? When holding the card vertically such that the PCIe pins are pointing to the floor, pins 1 and 3 are the top and middle pins of the J1 Thunderbolt header.

View attachment 484817
Yessir, tried with both 1,3 and 3,5 combos...
 
Joined
Apr 5, 2015
Messages
14
Motherboard
Gigabyte Z390 Designare
CPU
Intel i9-9900K
Graphics
Gigabyte Raedon 5700 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
This guide has truly been amazing and my system is 99% there. I decided to go with OSXWIFI's BCM943602CDP card for Bluetooth 4.2 and AC Wifi but am getting serious lag with both the Bluetooth and Wifi. My Wifi speeds are a 1/5th of what my other devices are seeing and the bluetooth constantly lags or skips with my mouse and keyboard. Any ideas here?
 
Last edited:
Joined
Jan 27, 2012
Messages
92
Motherboard
Gigabyte Z68-UD3H
CPU
i7
Graphics
HD 6850
without my (once good recovery usb):
reboot from windows (cold or warm) yes I can see both macOS and windows boot options
* I choose the macOS icon and it starts to boot and I get the stop sign.

if I boot my usb, I can get to the gui to re-install if I choose boot macOS install from install Catalina

but either I can't remember how, or doesn't work to use it to boot into my macOS drive.
* choose F12
* Choose USB (to answer your question, my m2 is listed as well)
* Clover menu appears with all the listings
* Boot macOS from macOS - Stop sign
* Boot recovery from recovery - Stop sign
* Boot FileVault rebooter from reboot - Stop sign
 
Top