Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Jul 29, 2012
Messages
88
Motherboard
Gigabyte Desingnare
CPU
i9-9900
Graphics
Sapphire Pulse RX 580 8GB
Mac
iMac
Mobile Phone
iOS
Hello again @qmediaservices,

Updating from 10.15.3 to either 10.15.4 or 10.15.5 is more complicated than most updates. We recommend (a) enabling native NVRAM and (b) using a new EFI folder, but copying-and-pasting existing Serial Number, Board Serial Number, and System UUID into the new config.plist.

Sound scary?

It's not so bad. Please see the post below and ask for help should you require it.
Thanks for the info, now the 10.15.6 is out, LOL, any ideas If is should update or wait till the fall for the new macOS 11.0 Big Sur? Thanks
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
10,104
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Thanks for the info, now the 10.15.6 is out, LOL, any ideas If is should update or wait till the fall for the new macOS 11.0 Big Sur? Thanks
If your system is running fine and you just applied the 10.15.5 update, then the choice to install 10.15.6 is really up to you. Always make a full bootable backup. The update from 10.15.5 to 10.15.6 is quite smooth in most cases, but each time the system reboots during the update process, check that the correct volume is selected in the Clover Boot Menu.
 
Joined
Oct 30, 2014
Messages
259
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
i9-9900k
Graphics
RX 580
Mac
iMac
I've always followed this guide for fresh installs since I've had this build. But a recent fresh install using the Catalina 10.15.5 mini guide went fairly well, but I cannot use my 2xBay Hotswappable USB 3.1 SATA Docking station properly. If there is one disc inserted and I try to insert another, it unmounts the currently inserted drive. And the same thing happens when I remove a drive. And when I unmount the drives in OSX, then pull them out, I get a message saying that the drive was not ejected properly. Even if I wait for it to disappear from the finder, stop spinning, and wait 2-3 min....
 
Joined
Jun 13, 2020
Messages
13
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 580
Quick question- I've kept my monitor via GPU's HDMI. I got a color-accurate monitor so I switched it to the GPU and, just for giggles and grins, I plugged in my main into the MB's HDMI.

Now, I got a black screen and its still black when I go back to the GPU's HDMI. I have no display! lol Haven't done a hard restart yet because I'm in the middle of transferring files but would that fix it? Does the native HDMI on the MB just not work?
 
Joined
Jun 4, 2020
Messages
17
Motherboard
Z390 Designare
CPU
i9 9900k
Graphics
VEGA 56
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
after updating the Mojave security update 2020-004 it boots after login (after putting pass and the desktop comes) really slow
what could cause the slow boot after login in ?
when i put my pass the mac takes much longer (compared to before update where it flawlesly boots up) to load everything
it looks like the screen freezes but i can move my mouse takes really long till i can interact.
i experience it since the security update 004.
did allready updated the kexts (weg lilu usbinjectall clover)
but still slooow.
anyone had the same problem with an solution and what could cause this ?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
10,104
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I've always followed this guide for fresh installs since I've had this build. But a recent fresh install using the Catalina 10.15.5 mini guide went fairly well, but I cannot use my 2xBay Hotswappable USB 3.1 SATA Docking station properly. If there is one disc inserted and I try to insert another, it unmounts the currently inserted drive. And the same thing happens when I remove a drive. And when I unmount the drives in OSX, then pull them out, I get a message saying that the drive was not ejected properly. Even if I wait for it to disappear from the finder, stop spinning, and wait 2-3 min....
Some questions:
  • What is the make/model of the docking station?
  • Was it working properly prior to 10.15.5?
  • Which USB port is the dock station plugged into? Or is it connected through a Hub?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
10,104
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
** Reminder: Profanity is a violation of the Rules **
(Even if it's part of a common phrase)

Excerpt from Rules:

Screen Shot 2020-07-28 at 9.34.45 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
10,104
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Quick question- I've kept my monitor via GPU's HDMI. I got a color-accurate monitor so I switched it to the GPU and, just for giggles and grins, I plugged in my main into the MB's HDMI.

Now, I got a black screen and its still black when I go back to the GPU's HDMI. I have no display! lol Haven't done a hard restart yet because I'm in the middle of transferring files but would that fix it? Does the native HDMI on the MB just not work?
On-board HDMI will not work until next versions of Lilu and WhateverGreen are released, and platform ID is changed to 0x3E9B0007 and a Framebuffer patch is applied. Details of platform ID and frame buffer patching are in Post #1.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
10,104
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
after updating the Mojave security update 2020-004 it boots after login (after putting pass and the desktop comes) really slow
what could cause the slow boot after login in ?
when i put my pass the mac takes much longer (compared to before update where it flawlesly boots up) to load everything
it looks like the screen freezes but i can move my mouse takes really long till i can interact.
i experience it since the security update 004.
did allready updated the kexts (weg lilu usbinjectall clover)
but still slooow.
anyone had the same problem with an solution and what could cause this ?
If you have a lot of login items (System Preferences --> Users & Groups --> Login Items), the system will take more time. Some login items such as iStat Menus can take more time than others. You can also run Activity Monitor and see which process(es) are consuming the most CPU. Feel free to post screenshot.
 
Top