Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,439
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Is there a reason why you set up your system with the home folder on a different drive? I did that on my previous Hackintosh but I didn't really see any benefits so I opted to keep my home folder on my main NVMe drive this time. My downloads folder lives on a separate drive and I don't store any music, photos, and videos on the main OS drive either so space isn't an issue. Seems like apps sometimes store preference files and such in the home folder so I liked the idea of keeping all of that on the same drive.
I did this mostly for future maintenance purposes. My home folder is 500GB and growing. I could have opted for a single 1TB or 2TB NVMe ($$$$$$), but decided to use a 240GB NVMe for the O/S and a SATA SSD for the home folder. Because the home folder will fill up more quickly (the O/S folder fills up considerably slower), I can always swap the SATA SSD for a larger size or combine multiple SATA SSDs in RAID-0 (JBOD).
 
Last edited:
Joined
Jan 16, 2017
Messages
50
Motherboard
Gigabyte H370N Wifi
CPU
i3-8100
Graphics
UHD 630
Mac
MacBook
Mobile Phone
iOS
Working on my first build; learning as I go. Have a simple question re: the UniBeast process. CaseySJ states "when the UniBeast process is done, you should see two USB disk icons on your Mac: Install MacOS Mojave and EFI. If you don't see both of these icons, stop and double-check your work. UniBeast creates these partitions on your USB drive; the EFI partition is especially important because the BIOS on your motherboard will only recognize and boot from this partition".

I finished the UniBeast process and did see the two USB disk icons. When I eject the USB, if I then re-insert, I only see the Install MacOS Mojave partition; the EFI partition is missing. Is this normal, or I am doing something wrong? Trying to figure out if this might be why I'm getting hung up during the Mojave Install process.

Thanks for any advice.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,439
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@MadDan This is normal and it's also a source of some confusion. We use EFI Mounter v3 or Clover Configurator --> Mount to mount this partition manually.
 
Last edited:
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Hello @CaseySJ Thanks for the great tutorial.

I'm thinking to build a new Hackintosh, but still didn't decided to go to Z390 Aorus Xtreme, or myabe this Z390 Designare. Do you you know if it will work too with Aorus Xtreme?

Thanks
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,439
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Hello @CaseySJ Thanks for the great tutorial.

I'm thinking to build a new Hackintosh, but still didn't decided to go to Z390 Aorus Xtreme, or myabe this Z390 Designare. Do you you know if it will work too with Aorus Xtreme?

Thanks
That's an amazing motherboard. My one complaint with the Designare is the lack of RGB Fusion, but the Aorus Extreme has everything, even RGB Fusion.

The following differences between the two boards can impact the post-installation procedure:
  • Aorus Extreme has 2 Ethernet ports; one is a standard GbE, but the other is an Aquantia 10GbE. This will require a different driver. The SmallTree driver in my post-installation guide is not compatible, but user KGP has a good discussion of Aquantia 10 GbE in Section E.8.2.1 of this comprehensive post.
  • Aorus Extreme does not have dedicated USB 2.0 ports (HS09 and HS10) so those entries can be deleted from the Custom SSDT. The remaining USB port may or may not be mapped to the same logical port numbers as the Designare, so it would be wise to check ports using IORegistryExplorer to see if they map to the same numbers as shown in the PDF file in Post #1 of this thread.
Most everything else looks the same and should work with the post-installation procedure for the Designare.
 
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
Thanks a lot for the reply....

About the 10Gbe, that I absolutely need, do you think that I still need to instal 10.13.3 at first time so that Ethernet card is flashed? That's what I did with my actual Asus 10Gbe card, but I was curious to know if I still need to do it with a clean install of Mac OS Mojave.

About your second point, that's the reason why I maybe will will choose Designaire. Since this Custom SSDT procedure is maybe too much for me (to be honest I didn't find the time to sit and go trough all the steps from @RehabMan), and since you did this perfect manual and attached all the files, life will be much easier for me. (I'm not too worried about usb ports, But I definitely want TB3 to work)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,439
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
For the Aquantia 10GbE, please do have a look at KGP’s description to see if he needed Windows to flash the BIOS.

For the USB SSDT, the changes needed for Aorus Extreme should be very simple. If you do choose this board, I can modify the SSDT for you.
 
Last edited:
Joined
Jan 21, 2018
Messages
186
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Vega 64
For the Aquantia 10GbE, please do have a look at KGP’s description to see if he needed Windows to flash the BIOS.

For the USB SSDT, the changes needed for Airbus Extreme should be very simple. If you do choose this board, I can modify the SSDT for you.
Oh Man. I don't even know how to thank you! :) I will try to do it myself, but If I need your help I will do it.

Thank you!
 
Joined
Feb 21, 2017
Messages
25
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-8700K
Graphics
RTX 2070
Mac
MacBook Air
Mobile Phone
Android, iOS
:headbang:Hai CaseySJ
I have Z390 Aorus Pro combined with i7-8700K.
16GB Corsair 3000Mhz RAM
I’ve followed every step you listed but the stage 2 installation reboots abruptly. But luckily I managed to take a photo and now I’ll attach it.
Please help me out. Am a noob:(.
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
5,439
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
:headbang:Hai CaseySJ
I have Z390 Aorus Pro combined with i7-8700K.
16GB Corsair 3000Mhz RAM
I’ve followed every step you listed but the stage 2 installation reboots abruptly. But luckily I managed to take a photo and now I’ll attach it.
Please help me out. Am a noob:(.
Happy to help. Let’s get some background info first:
  • Are you starting with 10.14 or 10.14.2?
  • Is your USB disk plugged into a USB 2.0 port with the black insert? USB 3.x ports have blue or red inserts.
  • Can you upload your config.plist? Don’t worry about serial numbers in the file because there aren’t any!
 
Top