Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Sep 25, 2012
Messages
78
Motherboard
Gigabyte Z390 Designare
CPU
i7 9700K
Graphics
RX 5700 XT
Hey there,
I have a problem wit my 4k display in combination with the Sapphire RT 5700xt. My mouse cursor freezes every 3 seconds. On DP it's not so bad but on HDMI it renders the system unusable. When I switch the monitor to DP1.1 instead of 1.2, the freeze is gone but I seem to get a general lag and only 30Hz instead of 60Hz (could be the reason for what feels like a general lag). When using my old 2K display, I don't have any problem at all.

I'm using the latest WEG and Lilu with agdpmod=pikera.
I am also wondering if the problem is monitor specific or if it would be the same with other 4k displays.
Unfortunately, I don't have another 4k display to test.

System specs
Monitor: PL2792UH (IIYAMA XUB2792UHSU)
Auflösung: 3840 x 2160 (2160p/4K UHD 1 - Ultra High Definition)
UI sieht aus wie: 1920 x 1080 @ 60 Hz

Does anybody know what to do?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,643
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey there,
I have a problem wit my 4k display in combination with the Sapphire RT 5700xt. My mouse cursor freezes every 3 seconds. On DP it's not so bad but on HDMI it renders the system unusable. When I switch the monitor to DP1.1 instead of 1.2, the freeze is gone but I seem to get a general lag and only 30Hz instead of 60Hz (could be the reason for what feels like a general lag). When using my old 2K display, I don't have any problem at all.

I'm using the latest WEG and Lilu with agdpmod=pikera.
I am also wondering if the problem is monitor specific or if it would be the same with other 4k displays.
Unfortunately, I don't have another 4k display to test.

System specs
Monitor: PL2792UH (IIYAMA XUB2792UHSU)
Auflösung: 3840 x 2160 (2160p/4K UHD 1 - Ultra High Definition)
UI sieht aus wie: 1920 x 1080 @ 60 Hz

Does anybody know what to do?
Some questions:
  • When you say the mouse cursor freezes, does the entire system freeze or only the mouse? In other words if you open a web page containing animations or a YouTube video, does the animation/video also freeze every 3 seconds?
  • What is the make/model of the mouse?
  • Are you using a good quality HDMI cable that is certified for 4K 60Hz (HDMI 2.0)? Have you tried a different HDMI cable?
 
Joined
Jul 20, 2013
Messages
81
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 590
Thank you! This is exactly the confirmation we were looking for. I've added Apple Thunderbolt Display to the very top of the section Thunderbolt Devices Made Compatible After Enabling Thunderbolt Bus. (This link is also present in Post #1 near the bottom of Spoiler #1.)
Great work! Glad I could help out with some testing.
Eagerly waiting to see how it goes. I trust you'll post a set of relevant photos/screenshots! :)
I've ordered a Raspberry Pi 4B and a SOIC8 clip with jumper wires/breadboard/capacitor/resisistor last night ... now waiting for shipment and delivery somewhere next week. Can't wait to get going!

I'll document the process and post results with relevant images. Let me know if there's anything in particular you want to see.
 
Joined
Jul 22, 2016
Messages
97
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 7 3700X
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Great work! Glad I could help out with some testing.

I've ordered a Raspberry Pi 4B and a SOIC8 clip with jumper wires/breadboard/capacitor/resisistor last night ... now waiting for shipment and delivery somewhere next week. Can't wait to get going!

I'll document the process and post results with relevant images. Let me know if there's anything in particular you want to see.

When I flashed the Designare TB chip with my RPI4 I could access the chip without removing the Designare board from my case. The board was unpowered when flashed. I followed CaseySJ's procedure "Mini-Guide for Flashing SPI ROM Chips using Raspberry PI 3B or 4" exactly as written. I did not use a breadboard or capacitors/resistors.

As I recall the only thing I did differently was disconnect the wire from the #1 Pin on the Raspberry PI that was connected to the #8 Pin on the SOIC8 clip. I don't recall where I found that recommendation, but it worked for me.

Aside from taking about three attempts to establish a good connection between the clip and chip, the procedure worked beautifully.

More unbelievably detailed work by @CaseySJ!!!!
 
Joined
Mar 29, 2017
Messages
68
Motherboard
Gigabyte Designare Z390
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. Mac mini
Hey CaseySJ, previously, I have Windows installed on a separate M.2 drive in my ASUS X99 Deluxe II and now I would like to remove it. Do I need to change anything in the BIOS or it is safe to just removed the drive.
The system is still working great with your EFI!
 

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,136
Issue solved, i had to overinstall 10.14.6 mojave full installer and right now the application works again...buhh, happy now...

I found the problem. Meanwhile, the issue was caused by an application called KCPM Utility...It had some permission resetting features in it. So, overall, I would avoid using any reset permission tools in Mojave or later. macOS doesn't like that anymore.
 
Joined
Oct 25, 2017
Messages
41
Motherboard
Gigabyte Z390 Designare-F9b
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Bluetooth works, after disabling the UIAC.aml but trying to import from iPhone functionality timeouts quickly and fails.

Screen Shot 2020-04-17 at 17.51.21.png
 
Joined
Sep 25, 2012
Messages
78
Motherboard
Gigabyte Z390 Designare
CPU
i7 9700K
Graphics
RX 5700 XT
Some questions:
  • When you say the mouse cursor freezes, does the entire system freeze or only the mouse? In other words if you open a web page containing animations or a YouTube video, does the animation/video also freeze every 3 seconds?
  • What is the make/model of the mouse?
  • Are you using a good quality HDMI cable that is certified for 4K 60Hz (HDMI 2.0)? Have you tried a different HDMI cable?

Thank you for your swift reply.
The mouse is a Logitech MX Master using a Logitech dongle.
Video and animations don't freeze, even the blinking cursor in a text box doesn't freeze.
The DP cable I'm using is definitely for 4k@60hz
I also checked a HDMI cable but like I said, the problem is much worse on HDMI.
 
Top