Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,678
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I would like to ask the folks on this board their advice.

I just purchased the Intel NIC NUC10I7FNH. This NUC has an internal Titan Ridge chip, and an Intel Core i7-10710U CPU (6 Core). This is a 10th generation Intel CPU (Ice Lake family). I need this unit for a work project, once done, I want to try and install MacOS on this unit.

I've never started from scratch with a new unit, however Apple is using this CPU family on the brand new MacBook Air 2020 unit so there is at least some minimal hope to get it working.

Question 1: Is there any advantage to this board for me to extract the Firmware from this brand new Intel unit (Thunderbolt)? I'd be very happy to do this if it would provide any benefits to this team.

Question 2: What is the best way to approach this from a "Brand New" CPU type? Any recommendations, suggestions, would really be appreciated.

Thank you guys and I fully realize this is somewhat off topic, and I'd be happy to take this conversation elsewhere if that is more appropriate.
Osy86 has a complete Hades Canyon NUC (NUC8xxx) setup on GitHub. That would be a good starting point. The NUC's ACPI (DSDT) is remarkably similar to Gigabyte's.

It would be interesting to examine the new NUC's Thunderbolt firmware.

As for how to begin macOS installation, perhaps by waiting for Clover Configurator to support new MacBook Air 9,1 or just trying iMac19,1 or Mac mini 8,1. Then solve each problem as it appears (easier said than done). Creating a new thread under Catalina Desktop Support would be the right approach, and we can assist in the effort.
 
Joined
Apr 1, 2011
Messages
355
Motherboard
Gigabyte z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. iOS
Osy86 has a complete Hades Canyon NUC (NUC8xxx) setup on GitHub. That would be a good starting point. The NUC's ACPI (DSDT) is remarkably similar to Gigabyte's.

It would be interesting to examine the new NUC's Thunderbolt firmware.

As for how to begin macOS installation, perhaps by waiting for Clover Configurator to support new MacBook Air 9,1 or just trying iMac19,1 or Mac mini 8,1. Then solve each problem as it appears (easier said than done). Creating a new thread under Catalina Desktop Support would be the right approach, and we can assist in the effort.
Thank you so much!! I'll get the extraction done and posted here...
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,678
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey guys, I need some help...
My hackintosh was stable but out of nowhere it started to reboot itself when it is in sleep mode...
Also started to have an issue with my thunderbolt ports, they were working fine, but now they only work if I connect the device before booting the system...
Can anyone tell me what to do?
I have the z390 designare with a I5 9600k, Sapphire Vega 64, 16gb Ram (Crucial Ballistix), System is installed in a NVME from XPG
Let's address Thunderbolt ports first. Please check the following:
  • Re-check all Thunderbolt BIOS settings as described in Post #1.
  • Check the CLOVER/ACPI/Patched folder for the presence of these two files:
    • SSDT-Z390-DESIGNARE-TB3HP-V4.aml
    • SSDT-DTPG.aml
 
Joined
May 31, 2013
Messages
381
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
@iDrakus I was having the same problem with an MSI 5700xt, swapped it for a Vega 64 and no freezing since.
Yes, seems to be getting worse since 10.15.1 for me. Noooooooo........
Support for Navi graphics cards (5700 and 5700 XT) appeared since macOS 10.15.2.

You can try installing the beta version of macOS 10.15.5, maybe there will no longer be such a problem.

You can also try removing WhateverGreen.kext. Perhaps this will work, but in this case, some ports on the video card may become unavailable for use. This may be a temporary fix for the problem.
 
Joined
Apr 28, 2018
Messages
205
Motherboard
Asus Dominus Extreme
CPU
3175X
Graphics
Radeon VII
Mac
  1. iMac
FWIW i also could not find any chips of the same size/type on the mac pro, certainly not on the io card itself. So either they are using different chips which are incompatible with our clips or they are hiding them well somewhere on the motherboard.

g\

Because the Chips are not on the IO Card itself, they are on the Logicboard.
If you take a good look on the pictures from the logic board, then only two chips could be related to it,
since the other stuff are mux chips which work together with PLX and don't contain any firmware.

DAmvK1JX1MLbCaDR.huge-2.jpeg
 
Joined
May 17, 2019
Messages
15
Motherboard
z390 Designare
CPU
i5 9600k
Graphics
AMD Radeon Vega 64
Let's address Thunderbolt ports first. Please check the following:
  • Re-check all Thunderbolt BIOS settings as described in Post #1.
  • Check the CLOVER/ACPI/Patchedfolder for the presence of these two files:
    • SSDT-Z390-DESIGNARE-TB3HP-V4.aml
    • SSDT-DTPG.aml
As I entered in the BIOS, I got a message saying that all my configuration had been restored to default. (I don't know what did cause this. Recently I installed more memory. Windows also might have updated.) Then I apply all the setting from the post and already tried ,and the Thunderbolt worked fine! Thank you!
Now I'll put to sleep to see if it still reboots by itself
 
Joined
Oct 25, 2017
Messages
41
Motherboard
Gigabyte Z390 Designare-F9b
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Hey, @CaseySJ
OpenCore 0.5.7 is released. I wonder if there should be any updates to the Micro-Guide.
 
Joined
Apr 28, 2018
Messages
205
Motherboard
Asus Dominus Extreme
CPU
3175X
Graphics
Radeon VII
Mac
  1. iMac
@CaseySJ Only added the first part to the one extracted via linux and like I already said in the past:

They are identical with the USBC Folder.

Bildschirmfoto 2020-04-06 um 15.47.36.png
 
Joined
Oct 9, 2013
Messages
69
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Mr Casey, in recognition of my gratitude for everything you bring us here, I want to share with you my satisfaction at being able to use my Sonnet eGpu with Vega 56 installed in addition to the discreet 5700.
Unfortunately, I cannot flash the thunderbolt chip due to the lack of appropriate equipment, but this result is already interesting.
Thanks again, I'm happy !!
A small screenshot to celebrate this !!
 

Attachments

  • Capture d’écran 2020-04-06 à 16.04.08.png
    Capture d’écran 2020-04-06 à 16.04.08.png
    171.7 KB · Views: 58
Joined
Mar 21, 2011
Messages
731
Motherboard
GA-Z390-AORUS Pro
CPU
i7-9700K
Graphics
RX 590
Does your Linux boot from Clover okay? I have Catalina, Windows 10 and Ubuntu 19.10 and all show up in Clover but only Windows and Catalina will boot. If I choose 'Linux' from the choices I just end up with the pinky purple screen and it just hangs there. It boots fine in I F12 and select the drive manually. A 1st world problem, as I only occasionally use Ubuntu, but it would be nice to fix it. I haven't looked into it too much.
I just tried booting Ubuntu from the Clover menu, and got the same result as you. I'm fairly sure that, when I installed it, several Clover versions ago, it booted properly. As yours does, it boots from F12. Sorry for the misleading post earlier.
 
Top