Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,830
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi CaseySJ thanks for the help once again!
Unfortunately I didn't run kext utility after deleting the kexts :(
and didn't also made a backup :(
I use these boot args
View attachment 456923

Im thinking to try and make a new unibeast drive with clover 5107 based on your guide Casey and try to boot from there. What do you think is it going to work?
  • Creating a new USB install disk may or may not help. It's worth a try.
    • However, start with WhateverGreen 1.3.6 (not 1.3.7). Perhaps the fix highlighted below might be causing some problems:
      Screen Shot 2020-03-25 at 7.11.05 AM.png
    • Does the system boot normally?
  • Are you able to boot into Recovery? This alone may not help us fix the black screen problem, but I'm curious is the screen operate normally in Recovery.
  • A worst-case scenario might be as follows:
    • Perform clean install of macOS Catalina 10.15.3 on a spare SSD. (Or even try a clean full install of 10.15.4.)
    • If the screen operates normally, we could either (a) use Migration Assistant to copy documents and apps from the bad 10.15.4 disk, or (b) reinstall apps and just drag-and-drop our Documents and Downloads and media folders to the new disk.
 
Joined
Mar 21, 2011
Messages
781
Motherboard
GA-Z390-Designare
CPU
i7-9700K
Graphics
RX 590
Updated Lilu, weg and appleALC by copying them to kexts/other.
Deleted these 3 from extensions folder.
Did the update.

So the system boots normally but after apple logo and horizontal purple lines the screen goes to sleep (LG 34WK95U / dp port). I think that I shouldn't delete applealc, weg and lilu from extensions folder. I followed Stork's guide (attached).
Any help would be much appreciated.

P.S. I cannot boot from Unibeast usb drive and I tried different boot args.
if you didn't remove FakeSMC or VirtualSMC from /L/E, and didn't change your config.plist for Kext injection from Detect to Inject, then clover wouldn't have loaded any of your kexts from clover/kexts. "detect" means that if fake or virtualsmc is in /L/E no kexts will be loaded from clover. in config.plist on your usb drive change Detect to Inject. when you can successfully boot from your Mac drive then you can remove fake or virtualsmc from /L/E and change Detect to Inject in your config.plist on your boot drive.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,830
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** EXTREMELY IMPORTANT **
Make a full bootable backup of Catalina 10.15.3 before attempting to install 10.15.4

There seems to be a high failure rate with the update to 10.15.4. It may or may not be due to WhateverGreen. Like COVID-19, we don't have a solution for it right now. Don't take chances. If you cannot make a full bootable back right away, do not update.
 
Last edited:
Joined
Oct 17, 2013
Messages
276
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
  • Creating a new USB install disk may or may not help. It's worth a try.
    • However, start with WhateverGreen 1.3.6 (not 1.3.7). Perhaps the fix highlighted below might be causing some problems:
      View attachment 456936
    • Does the system boot normally?
  • Are you able to boot into Recovery? This alone may not help us fix the black screen problem, but I'm curious is the screen operate normally in Recovery.
  • A worst-case scenario might be as follows:
    • Perform clean install of macOS Catalina 10.15.3 on a spare SSD. (Or even try a clean full install of 10.15.4.)
    • If the screen operates normally, we could either (a) use Migration Assistant to copy documents and apps from the bad 10.15.4 disk, or (b) reinstall apps and just drag-and-drop our Documents and Downloads and media folders to the new disk.
Screen works normal with recovery mode.
The issue I experienced before with clean install is that freezes are showing up again. I have to make a clean install of Mojave 10.13.6 and from there upgrade to Catalina (have you confirm this Casey from other users?). If I only could mount main system efi from my 2nd system and from there try weg 1.3.6...
 
Last edited:
Joined
Jan 6, 2020
Messages
149
Motherboard
Gigabyte Designare Z390 Thunderbolt 3
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
** EXTREMELY IMPORTANT **
Make a full bootable backup of Catalina 10.15.3 before attempting to install the 10.15.4 update

There seems to be a high failure rate with the update to 10.15.4. It may or may not be due to WhateverGreen. Like COVID-19, we don't have a solution for it right now. Don't take chances. If you cannot make a full bootable back right away, do not update.

Ok but if it is installed it is ok?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,830
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Screen works normal with recovery mode.
The issue I experienced before with clean install is that freezes are showing up again. I have to make a clean install of Mojave 10.13.6 and from there upgrade to Catalina (have you confirm this Casey from other users?). If I only could mount main system efi from my 2nd system and from there try weg 1.3.6...
Because you can boot into Recovery, we can actually make all the necessary fixes through Terminal.

Let’s start with this:
Code:
ls /Volumes
Please post the result.
 
Joined
Oct 17, 2013
Messages
276
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
if you didn't remove FakeSMC or VirtualSMC from /L/E, and didn't change your config.plist for Kext injection from Detect to Inject, then clover wouldn't have loaded any of your kexts from clover/kexts. "detect" means that if fake or virtualsmc is in /L/E no kexts will be loaded from clover. in config.plist on your usb drive change Detect to Inject. when you can successfully boot from your Mac drive then you can remove fake or virtualsmc from /L/E and change Detect to Inject in your config.plist on your boot drive.
No I didn't remove fakesmc from L/E and inject kexts setting is to detect mode. Fakesmc is on both locations (L/E and EFI). So this means as you said that kexts didn't injected from efi and they are no longer on L/E to be injected from there. That confirms my issue with booting. So I hope I can boot from usb drive and from there change the settings in config.plist. Thanks for clarifying all this info! :)
 
Joined
Oct 17, 2013
Messages
276
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Because you can boot into Recovery, we can actually make all the necessary fixes through Terminal.

Let’s start with this:
Code:
ls /Volumes
Please post the result.
1.jpg
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,830
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
The name of your macOS SSD is "iMac Pro". So let's check on FakeSMC and perhaps get rid of it. We can also rebuild the kernel cache.
Code:
cd /Volumes/"iMac Pro"/Library/Extensions
ls
Please post the output. Then if any other third-party kexts are still present, we can remove them. For example, if FakeSMC is present, we can do this:
Code:
rm -rf FakeSMC.kext
And we can repeat this for each FakeSMC sensor kext. When we're done we can rebuild the kernel cache:
Code:
cd /
kextcache -i /Volumes/"iMac Pro"
 
Top