Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Feb 19, 2018
Messages
301
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hello Ploddles,

Thank you for responding, see attachment with the content of the patched folder, yes I do have SSD-NVRAM.aml in it.

So you have VirtualSMC.kext + the two other files both in Kexts/Other and /L/E and VirtualSMC.efi in the UEFI folder and that is working for you? Do you mind posting a screenshot of the contents of your /L/E?

The boot stops with the message HID: Legacy shim 2. CSM support in BIOS is disabled, I enabled that for testing but at the time that didn't make a difference. Do you have CSM support enabled?

I don't know tinker, I just googled it and downloaded it. Where can I find more info on how to use it in the way you just wrote to me? So after I created a bootable usb drive I copy the EFI contents of my Mojave disc to the EFI of this bootable usb drive and then...copy the files of a previously working EFI content? Sorry, newbie in this area.

Best regards
Sorry for the misunderstanding. By 'tinker' I mean you can just change things on the USB, add or remove files etc.

I am away from home at the moment but tomorrow I will zip my EFI and post it for you to try, I will remove SMBIOS and Serial numbers from my config.plist so just replace them with yours. CSM support is disabled, as per the guide. My BIOS version is F8.
 
Joined
Feb 10, 2020
Messages
14
Motherboard
Z390 Designare
CPU
i9-9900
Graphics
RX 5700 XT
Update on my end - Just got the new Radeon VII card installed. Swapped back to original Clover Config file, dual monitor (dual DP) - and everything seems to be working incredibly smoothly so far. For kicks, I ran a Luxmark benchmark on it, and hit 50.1k, so it seems to be working.

Hopefully - this will be more stable than my old card. I'll report back in a few days and share the results *fingers crossed*
How can the Radeon VII benchmark 2.5 times faster than the rx5700xt? What SMBIOS was that? OS? Was that a dual test including CPU?
 
Joined
Dec 15, 2019
Messages
52
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K Coffee Lake
Graphics
MSI Radeon RX 580 Armor 8G
Mac
iMac
Mobile Phone
iOS
Sorry for the misunderstanding. By 'tinker' I mean you can just change things on the USB, add or remove files etc.

I am away from home at the moment but tomorrow I will zip my EFI and post it for you to try, I will remove SMBIOS and Serial numbers from my config.plist so just replace them with yours. CSM support is disabled, as per the guide. My BIOS version is F8.
Thanks again, ok I understand, actually tinkertool is freeware for the Mac, might be useful at some point ;), fantastic,
thank you for the effort, I'm also on F8.

Best regards
 
Joined
Aug 29, 2012
Messages
79
Motherboard
Gigabyte Designare Z390
CPU
i7-8700K @ 4.5Ghz
Graphics
Radeon VII
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
How can the Radeon VII benchmark 2.5 times faster than the rx5700xt? What SMBIOS was that? OS? Was that a dual test including CPU?
I don't know enough about them to offer an explanation. I'm currently running 19,1 SMBIOS, on Catalina 10.15.4 Beta 1, 2 monitors plugged in, both on DP, and it was the Single GPU only test. I didn't run the CPU or dual test.

I'm not sure I'd say it's 'faster' (and even if so, certainly it's not in every single instance), perhaps it just benchmarks on that particular test better?
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
7,530
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
There has been some discussion here in regard to SMBIOS macpro1,1 vs iMac19,1.

I benchmarked my GPU using Luxmark on a iMac19,1 build using the mini guide. It comes in around the 17000 mark.

I would be interested to see what others have out there.

Hope this is okay to post in this forum as it is particular to Casey's build.
Your score is 27,176 (not 17,000). This compares very favorably with mine (also from a 5700 XT):

Capto_Capture 2020-02-18_05-54-19_PM.png
 
Joined
Jul 3, 2019
Messages
6
Motherboard
Z390 Designare
CPU
I99000k
Graphics
2080ti-rx580
Hi @CaseySJ, thank you for such an amazing guide and specially for your time, Just after the step: Boot macOS Install from Install macOS Catalina in the mini guide I get the apple logo an a loading bar then suddenly I get no HDMI output to my monitor. I'm using the iGPU, and I made all the necessary changes in BIOS. Any way I can fix this?
 

VVK

Joined
Aug 29, 2015
Messages
17
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Sapphire RX 5700 XT Nitro+
Mobile Phone
iOS
I enabled native NVRAM earlier, then re-flashed BIOS, the same F8. Of course, Catalina won't boot. Just the Apple logo without a progress bar.
Now I'm trying to unlock CFG again following this guide https://www.tonymacx86.com/threads/...9700k-amd-rx-580.267551/page-432#post-1958808 and get this:

The first time everything was exactly like in a guide above, now I'm concerned about this warnings "does not match expected GUID". Don't remember this message before :/
Is it safe to just type "setup_var_3 0x5C1 0x0"?
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
7,530
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I enabled native NVRAM earlier, then re-flashed bios, the same F8. Of Course Catalina won't boot, just an Apple logo without a progress bar.
Now I'm trying to unlock CFG again following this guide https://www.tonymacx86.com/threads/...9700k-amd-rx-580.267551/page-432#post-1958808 and get this:

The first time everything was exactly like in a guide above, now I'm concerned about this warnings "does not match expected GUID". Don't remember this message before :/
Is it safe to just type "setup_var_3 0x5C1 0x0"?
No problem. It’s okay to proceed.
 
  • Like
Reactions: VVK
Top