Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
7,604
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
For futher information, on Asus Maximus desktop, I have the following set-up :

View attachment 446777

And Like I said on my first post Here, this board have only one Thunderbolt port that why there is only one thunderbolt ethernet appears on IOReg... But two connectors (one USB type A and one USB type C) are used with Thunderbolt device. That's an unknown set-up on Apple world but now it work !
Understood! Will do the Windows test with USB 3.1, USB 3.1 Gen 2, and USB 2.0.
 
Joined
Jan 25, 2020
Messages
9
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
I just did a little more experimenting with NVRAM in Clover..
I can confirm what you are saying. It just isn't working. I think the time I thought it was kinda working I may have had a errant copy of EmuVariable in there and didn't realize it.

But native NVRAM seems to be working just fine in OpenCore.
It would seem that native NVRAM doesn't work with Clover, then. I wouldn't know where to start in terms of which files to keep and which files to drop from my EFI folder, so I'm waiting to see if the Catalina Mini-guide gets updated. @CaseySJ, do you have any insights here? I'd love to use the OpenCore guide to get native NVRAM working, but I'm new to hackintoshing, so I guess it's better to use Clover for now.
 
Joined
Jan 25, 2020
Messages
9
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
See
I don't understand. You've linked me to Clover builds? I'm interested in knowing if anyone has a working EFI folder with native NVRAM for the Z390 Designare. Basically I'm new to Hackintoshing and just want a simple guide to follow, like the Catalina Mini-Guide, but if there's the possibility of the guide being updated with native NVRAM, I'd rather hold off until the guide is updated with that. :)
 
Joined
Feb 15, 2012
Messages
98
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
I don't understand. You've linked me to Clover builds? I'm interested in knowing if anyone has a working EFI folder with native NVRAM for the Z390 Designare. Basically I'm new to Hackintoshing and just want a simple guide to follow, like the Catalina Mini-Guide, but if there's the possibility of the guide being updated with native NVRAM, I'd rather hold off until the guide is updated with that. :)
I have hardware nvram fully working using clover. I just added SSDT-PMC.aml in patched ACPI folder, removed EmuVariableUefi-64 from drivers, removed nvram.plist from EFI partition, and removed clover rc scripts.

Variable persistence between reboots is working, clover remembers last boot drive, and changing startup volume from system preferences is working good.

I'm using latest F9b bios as well and didn't try this on earlier versions.
 
Joined
Jan 25, 2020
Messages
9
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
I have hardware nvram fully working using clover. I just added SSDT-PMC.aml in patched ACPI folder, removed EmuVariableUefi-64 from drivers, removed nvram.plist from EFI partition, and removed clover rc scripts.

Variable persistence between reboots is working, clover remembers last boot drive, and changing startup volume from system preferences is working good.

I'm using latest F9b bios as well and didn't try this on earlier versions.
That sounds fantastic! Would you be willing to share your EFI folder with serial numbers removed?
 
Joined
Sep 5, 2012
Messages
109
Motherboard
Gigabyte GA-Z390X Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I have hardware nvram fully working using clover. I just added SSDT-PMC.aml in patched ACPI folder, removed EmuVariableUefi-64 from drivers, removed nvram.plist from EFI partition, and removed clover rc scripts.

Variable persistence between reboots is working, clover remembers last boot drive, and changing startup volume from system preferences is working good.

I'm using latest F9b bios as well and didn't try this on earlier versions.
Could you post your efi please.
 
Joined
Jan 26, 2020
Messages
3
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Hi all,

i have a nooby question but after whole two days of unsucessful trials I will need your help. So, my friend wanted to build a hackintosh since he is a long time Apple user. We went thorugh the forum guides and selected the components which are the following:

- Intel i7 9700K
- Gigabyte Z390 Designare
- Sapphire RX 5700 XT Nitro+
- Corsair Vengeance Lpx 3200 MHz 32GB (2×16GB)
- Samsung 970 Evo 1TB
- Adata XPG 8200 Pro 1TB (For Windows)

i have put the components together yesterday and everything is working OK, BIOS version on the motherboard is F9. We have followed the guide in the opening post, set up the BIOS, prepared the USB drive. When we boot the Clover Install Catalina option some text lines appear for a minute or so, there are some errors such as location doesn't exist etc... I have searched the internet, tried different EFi configurations, different Clover Configurator settings, because each tutorial has very different settings for the same motherboard. When trying out outher EFI configurations, prepared by other users on the internet, I normally get the error "Error allocating 0x11c7f pages at......".

Can someone please point me to the right direction where to start from scratch since nothing seems to be working. I think that our Clover Configuration is not OK and want to set it up properly and try again. I can provide further details if someone is willing to help us at our first build.

Thanks in advance!
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,331
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I don't understand. You've linked me to Clover builds? I'm interested in knowing if anyone has a working EFI folder with native NVRAM for the Z390 Designare. Basically I'm new to Hackintoshing and just want a simple guide to follow, like the Catalina Mini-Guide, but if there's the possibility of the guide being updated with native NVRAM, I'd rather hold off until the guide is updated with that. :)
Clover can "make up" for those motherboards that don't save NVRAM information between boots. You don't need to do the EFI dance. So once you install macOS, run the reference Clover installer and your NVRAM will be preserved across boots.
 
Top