Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
Dec 14, 2017
Messages
9
Motherboard
Gigabyte GA-EX58-UD5
CPU
i7-920
Graphics
Asus GTX 760 2GB
I read somewhere that darkwake=0 might fix this. Unfortunately cannot remember where.

You are right, I just tried that and 1 key stroke is enough to bring the unit awake from sleep.
 
Joined
Nov 20, 2013
Messages
13
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX VEGA 64
Mac
  1. MacBook Air
  2. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Well, that solves which slot I am using. BTW are you running FCPX? I am building with an RX580 but plan on updating the graphics card at a later date. So far my order is spread out over tomorrow and friday for arrival. The CPU heatsink showed up today. Gotta Love Amazon... :-/

I don’t use FCPX as I predominantly do audio, but I do like to play CS:GO and can confirm that I get a stable ~160fps at 2560x1080 @ 144hz, silky smooth! So no need for that windows 10 drive anymore! Haha
I am sure that performance in FCPX will be stellar though!
 
Joined
Dec 6, 2018
Messages
11
Motherboard
Gigabyte Z390 Aorus Pro WiFi
CPU
i7-8700K
Graphics
RX 570
Mac
  1. iMac
CaseySJ's Coffee Lake in Phanteks Evolv X ATX Case:
Gigabyte Designare Z390 - i7-9700K - UHD 630 - AMD RX 580
...
Everything is working fine. Can I use migration tools to transfer my MacBook Pro TimeMachine backup to my custom Mac?
 
Joined
Jun 2, 2011
Messages
85
Motherboard
Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
As you can see, there's a Thunderbolt thingy in my IORegistryExplorer, but my USBC drive isn't recognised. Maybe that's because it's only USBC and not thunderbolt ?
 

Attachments

  • Capture d’écran 2018-12-27 à 11.25.21.png
    Capture d’écran 2018-12-27 à 11.25.21.png
    125.8 KB · Views: 125
  • petaire’s iMac.ioreg
    17.6 MB · Views: 43

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,820
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Everything is working fine. Can I use migration tools to transfer my MacBook Pro TimeMachine backup to my custom Mac?
Glad to hear!! How did you fix your 4K resolution problem? Was it an HDMI cable issue?

Your #1 priority now should be to create a full backup. If you have a 120GB SSD (they are only USD $25 on Amazon) mounted in an external USB 3.0 enclosure, you can have a very fast backup disk with boot capability.

Next you can use Migration Assistant from the Utilities folder to copy applications and home folder. You should NOT migrate computer and network settings or "other files and folders".

Sometimes "other files and folders" are beneficial because they can migrate certain license files and application-configuration files. In this case you can re-run Migration Assistant and only check the box for Other Files and Folders.

Because there's no undo with Migration Assistant, the full backup becomes your only safety net.

P.S. Can you please edit your post above and remove the full copy of the Build Guide. The build guide changes regularly so I want to ensure that everyone is looking at the one and only version of it.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,820
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
As you can see, there's a Thunderbolt thingy in my IORegistryExplorer, but my USBC drive isn't recognised. Maybe that's because it's only USBC and not thunderbolt ?
Have you copied the following two SSDTs to your EFI/CLOVER/ACPI/patched folder?
  • SSDT-DTPG.aml
  • SSDT-Z390-DESIGNARE-TB3HP-V3.aml
These two SSDTs and the Thunderbolt 3 BIOS settings on Page 1 build guide are required (particularly the TB3 security setting).
 
Last edited:
Joined
Nov 3, 2018
Messages
30
Motherboard
Gigabyte Designare Z390
CPU
i7-8700K
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
  2. iOS
Hi caseysj ... i still had problem with rx580 hdmi out at startup after the apple logo i lose hdmi out connection and i have to disconnect and reconnect the hdmi cable... you said me to try displayport to hdmi cable and i had the same problem but it doesnt show up anything after that i unplug & plug the displayport-hdmi cable... ny lg 4k screen doesnt have displayport so i can just test the adapter...maybe there is something wrong in my efi because my bios is same to your
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,820
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi caseysj ... i still had problem with rx580 hdmi out at startup after the apple logo i lose hdmi out connection and i have to disconnect and reconnect the hdmi cable... you said me to try displayport to hdmi cable and i had the same problem but it doesnt show up anything after that i unplug & plug the displayport-hdmi cable... ny lg 4k screen doesnt have displayport so i can just test the adapter...maybe there is something wrong in my efi because my bios is same to your
This looks like a tricky problem. Let's see if any of the following suggestions help:
  • Are you using HDMI 2.0 cable, preferably 6ft (~1.8m to 2.0m) or shorter?
  • Have you plugged in both 12V ATX power cables (2x2 and 2x4) as shown in attached diagram?
  • Do you have 500W or larger power supply?
  • Is RX 580 properly seated in the PCIe x16 slot? Try removing and reinserting the card. When removing the card, push the slot retention lever at the back of the PCI slot. The card will not come out otherwise.
  • Are you running Mojave 10.14.2?
Edit 28 Dec 2018: Which model of LG monitor are you using? Recent models that support DP 1.2 and HDMI 2.0 might be more reliable...
 

Attachments

  • ATX_12V.png
    ATX_12V.png
    139.1 KB · Views: 107
Last edited:
Joined
Jun 2, 2011
Messages
85
Motherboard
Aorus Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Have you copied the following two SSDTs to your EFI/CLOVER/ACPI/patched folder?
  • SSDT-DTPG.aml
  • SSDT-Z390-DESIGNARE-TB3HP-V3.aml
These two SSDTs and the Thunderbolt 3 BIOS settings on Page 1 build guide are required (particularly the TB3 security setting).
Yep, I've attached some screenshots. My IOReg is not what it's supposed to be ?
 

Attachments

  • image.jpg
    image.jpg
    2.6 MB · Views: 113
  • image-2.jpg
    image-2.jpg
    2.4 MB · Views: 113
  • image-1.jpg
    image-1.jpg
    2.4 MB · Views: 108
  • petairea_tm_s_iMac.ioreg
    17.6 MB · Views: 35
  • Capture d’écran 2018-12-27 à 16.35.51.png
    Capture d’écran 2018-12-27 à 16.35.51.png
    207.1 KB · Views: 151
Joined
Feb 11, 2014
Messages
229
Motherboard
Z390 Designare
CPU
i7-9700
Graphics
Radeon Pro WX 9100
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Everything just arrived. Including that 32gig Samsung USB3.1 thumbdrive. I will start on this later today and post results to this thread. THANK YOU Tonymacx86 and CaseySJ!
 

Attachments

  • IMG_4620.JPG
    IMG_4620.JPG
    2.2 MB · Views: 287
Top