Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,053
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@WhosMac @SpikedBR @heyelly

I've just installed Catalina successfully using only the iGPU, as follows:

Phase 1:
  • Start with the USB install disk you created by following the Catalina Mini-Guide.
  • Connect it to your Mac.
  • Now, in the ZIP attached below there are two config.plist files:
    • config-Internal-GPU.plist
    • config-AMD-GPU.plist
  • We will perform the installation with the Internal file and then switch to the AMD-GPU file later.
  • Copy config-Internal-GPU.plist to the CLOVER folder of the USB install disk.
  • Open the file with Clover Configurator, go to SMBIOS section, and select iMac19,1 from the pop-up menu.
  • Save the file and then rename it to simply config.plist.
Phase 2:
  • Power down, flip power switch on PSU to OFF, then completely remove the RX 5700 XT GPU from the system.
    • Don't skip any one of these steps.
  • Connect HDMI cable to rear IO panel and to your monitor.
    • Don't use a TV. Use a computer monitor.
  • Power up the system and press Del to enter BIOS Setup.
    • Change Initial Display Output to IGFX.
    • Save and quit.
  • Press F12 at BIOS Splash Screen to open BIOS Boot Menu.
    • Select the USB install disk.
  • At the Clover Boot Menu, select the leftmost icon (the external USB disk).
  • Follow the on-screen progress.
  • When the installer starts, run Disk Utility and format the target disk as APFS, select the Scheme as GUID Partition Map, and give it the name Catalina
    • You must select View --> Show All Devices... and click on the parent name of your target macOS SSD. Then click Erase and you will see three options: Name, Format, and Scheme.
  • Then quit Disk Utility and select the option to Install macOS.
  • When the system reboots, make sure to press F12 at BIOS Splash Screen.
    • Select the USB install disk.
  • At the Clover Boot Menu, select Boot macOS Install from macOS Catalina
    • NOTE: We will NOT select the USB install disk in Clover Boot Menu any longer. We will still use the USB disk to boot the system because only the USB disk contains the EFI partition that allows computer to boot.
  • The macOS installer should automatically resume and take 15-30 minutes.
  • When it reboots, press F12 again and select the USB install disk.
  • At the Clover Boot Menu, select Boot macOS from macOS Catalina
    • Now you will be greeted with the Welcome screen.
    • Follow the wizard. You can login to iCloud or do it later.
  • When you're at the desktop, run Clover Configurator to Mount EFI partitions of both the USB install disk and the new Catalina SSD.
    • Copy the entire EFI Folder from EFI partition of USB disk to EFI partition of Catalina SSD.
  • Eject the USB install disk.
  • Reboot and see if Catalina starts up.
Phase 3: Prepare to install RX 5700 XT.
  • (Steps to be provided later.)
  • Do not do this yet.
  • Please report your progress with Phases 1 and 2.


Voodoo Science: For some reason System Information --> Graphics/Displays is showing 4K at 60Hz when connecting my Asus Designo 4K monitor to the on-board HDMI port. This port should not support 60Hz. I'll post screenshot later this evening if I can prove to myself that I wasn't hallucinating. Maybe it's a bug in 10.15.1, but the screen did not flicker when moving windows around as it does at 30Hz. Anyway, this could just be a mistake on my part. But if the 3 of you have 4K monitors, see if you also get 60Hz.

Screen Shot 2019-12-06 at 7.30.55 AM.png
 

Attachments

Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,053
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Stuck on this
  • What is your firmware version? F8?
  • Are all firmware (BIOS) parameters set up correctly? Please see post #1:
    Screen Shot 2019-12-06 at 8.16.14 AM.png
  • You may also post your config.plist
 
Joined
Aug 6, 2019
Messages
66
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
  • What is your firmware version? F8?
  • Are all firmware (BIOS) parameters set up correctly? Please see post #1:
    View attachment 439048
  • You may also post your config.plist
Yes, F8. Everything is set up as you wrote in that post, I just double-checked it.
Here is my config.plist!
 

Attachments

Joined
Jan 5, 2014
Messages
60
Motherboard
GA-Z97X-UD3H
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro
Mobile Phone
iOS
*** OcQuirks / FwRuntimeServices Experiment: Conclusion ***

As a follow-up to the original post describing this experiment, I'm happy to say that TEST 4 works on my system even from the NVMe SSD. This is so far the only combination of parameters that works universally across USB, SATA, Thunderbolt, and NVMe PCIe (on my system).

We may finally have a viable alternative to OsxAptioFix2Drv-free2000. But let's wait for additional user feedback.
So when this is ready for prime time will this make it into a Post #1 update?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,053
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
So when this is ready for prime time will this make it into a Post #1 update?
It's ready to try now -- so far no reports of problems. It will certainly go into the updated guide.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,053
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Yes, F8. Everything is set up as you wrote in that post, I just double-checked it.
Here is my config.plist!
I've removed an entry related to WiFi/BT card in bottom short slot. Please rename and try the attached file. We must mount EFI partition of USB install disk and copy it to the EFI/CLOVER folder.
  • What is the make/model of your monitor?
  • Are you using a straight HDMI-to-HDMI cable (no DisplayPort or DVI adapters)?
  • You may also replace all files in the EFI/kexts/Other folder with those provided in the attached ZIP.
 

Attachments

Joined
Jul 25, 2012
Messages
44
Motherboard
Gigabyte Z390 M
CPU
i9-9900K
Graphics
RX 5700 XT
Mobile Phone
iOS
I know, easy come easy go!

Just to confirm: Did you click the pop-up menu in SMBIOS and select iMac19,1? The config.plist in the ZIP is unfinished or incomplete. We have to populate the SMBIOS section before using it.

Thanks for the link; going through this thread now...


UPDATE: There are a couple of differences in their config.plist that we might want to try, such as:
  • Enabling KernelXCPM in Kernel & Kext Patches
  • There's also an ACPI patch for an RTC bug, but I don't think that's needed
My gut feeling (and it's nothing more than that) is that 10.15.2 might be a better choice for doing fresh installations of Catalina because 10.15.2 will support SMBIOS MacBookPro16,1, which is the 2019 16-Inch MacBook Pro that comes standard with a Navi GPU (Radeon 5300M and 5500M). It should also support the new non-headless Platform ID 0x3E9B0008 for iGPU.

Anyway, I'll continue to tinker with the CLOVER configuration over the next couple of days.
No deal with the KernelXCPM, stuck on the same spot. I’ll wait for the second part of your iGPU fresh install above :)
 
Joined
Aug 6, 2019
Messages
66
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
I've removed an entry related to WiFi/BT card in bottom short slot. Please rename and try the attached file. We must mount EFI partition of USB install disk and copy it to the EFI/CLOVER folder.
  • What is the make/model of your monitor?
  • Are you using a straight HDMI-to-HDMI cable (no DisplayPort or DVI adapters)?
  • You may also replace all files in the EFI/kexts/Other folder with those provided in the attached ZIP.
I’m using a Benq PD2700 connected straight to HDMI. With the attached plist I got this
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,053
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I’m using a Benq PD2700 connected straight to HDMI. With the attached plist I got this
When I installed Catalina from scratch with only the iGPU, the installation was surprisingly smooth. There were no waiting periods like those mentioned in the Catalina Mini-Guide. The entire process went through quite quickly and I was able to create a user account and begin using Catalina. All in under 30 minutes.

Some of the differences between your system and mine:
  • Intel i7-9700K, but your CPU should be perfectly okay.
  • Fenvi FV-T919 in the bottom short slot.
  • Asus Designo 4K monitor connected via HDMI 2.0 cable.
    • Do you have the BenQ PD2700Q (1440p) or BenQ PD2700U (4K)?
  • 32GB memory using 4 x 8GB DIMMs.
Other:
  • RX 5700 XT fully removed from the system.
  • No other monitors or video cables connected.
  • BIOS F8 --> Initial Display Output set to IGFX.
  • CSM Support disabled.
  • USB install disk is 32GB Samsung Bar Plus connected to blue USB 3.0 port on front of the case.
You may also try:
  • Deleting all files from both CLOVER/kexts/Other and CLOVER/drives/UEFI and replacing them with the files in the ZIP above (Post # 10,821).
I'll work on Phase 3 later this evening and through the weekend.
 
Last edited:
Top