Contribute
Register

[SUCCESS] GB Z490M / 10.5.7 / i7 10700K / 5700XT / OpenCore

Joined
Oct 1, 2010
Messages
66
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi !!! Just discovered your topic about this config. I order exactly the same motherboard. Would use it with the whole new i9 10850k and a Sapphire Pulse RX580. Can I use your EFI / SSDT directly ? Or some changes to do ?
Thanks a lot :)

Afaik you can, yes :ugeek:
 
Joined
May 4, 2016
Messages
54
Motherboard
Gigabyte Z490m Gaming X
CPU
i9-10850K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Have a question : do you know if there any issues with Fenvi T919 with this MB or OC ? Use this great PCI card on my actual hackintosh config (with clover) and all is working perfectly : iMessage / Unlock with AppleWatch / Airdrop / etc.
Thanks :)
 
Joined
Oct 1, 2010
Messages
66
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Have a question : do you know if there any issues with Fenvi T919 with this MB or OC ? Use this great PCI card on my actual hackintosh config (with clover) and all is working perfectly : iMessage / Unlock with AppleWatch / Airdrop / etc.
Thanks :)

I don't have that card myself so I don't know - haven't ready about any problems though
 
Joined
Jan 8, 2011
Messages
4
Motherboard
CustoMac
CPU
Core I3 10100 Gigabyte Z490M
Graphics
RX 560 4GB DDR5
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have issue with corsair 3200 memory on this motherboard . As I am using a i3 processor the memory cannot be clocked to 3200 and the bios defaults to 2100 mhz. Gigabyte support says that only i7 and i9 processor will support ramoverclocking to 3200 and on i3 and i5 it will default to 2100
 
Joined
Sep 6, 2012
Messages
3
Motherboard
1
CPU
3
Graphics
2
Mac
Classic Mac
Mobile Phone
Does NVRAM work on this combo?
 
Joined
Nov 18, 2011
Messages
48
Motherboard
Gigabyte Z490M Gaming X / GA-H67N-USB3-B3
CPU
intel i7-10700 / intel i3-2105
Graphics
built in
NAZRM - Thank you. I used this on an Asus Z490m-plus and it worked. I am trying to figure out open core to tweak it, but am a dolt with open core.

Nothing else worked to get mine to boot. The first time it booted, I was stunned that it worked. Thanks

Is everything working for you? I went with the Gigabyte board because I've had more success with Gigabyte, but I think your Asus board is a little better. Thx.
 
Joined
Jan 23, 2016
Messages
65
Motherboard
EVGA X299 Micro
CPU
i9-10980XE
Graphics
RX 5500 XT
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Is everything working for you? I went with the Gigabyte board because I've had more success with Gigabyte, but I think your Asus board is a little better. Thx.
It is still working great. I have no complaints. I run my G Skill 3200 ram 16gbx4 at 2666. When I ran it at 3200, It froze twice in one month. My systems is on 24/7. At 2666, it didn't freeze at all.
 
Joined
May 4, 2016
Messages
54
Motherboard
Gigabyte Z490m Gaming X
CPU
i9-10850K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hier guys ! I finally took some time this Weekend to mount my new config. Thank U @nazrm for your advices and tips. I finally don't use your EFI & have prefered to used the Dortania Tuto, to understand what I'm doing (Old Clover config but 1st with OC)!

Before to start would just to say I'm totally fan of OpenCore! All is so much clean and understanding than Clover. The official Dortania's OpenCore Install Guide is so clear. All is explained and detailed perfectly.

After only few hours all is working like a charm :
  • Graphic Card : OK
  • Sound Chip (Rear & Front Panel Out/Mic) : OK
  • Ethernet (Intel i219) : OK
  • Fenvi T919 WiFi & BT : OK but... see below.
  • Sleep : OK
  • NVMe : OK
  • HandOff / Continuity / AirDrop : OK
  • NVRam : OK
One great thing with this MB is you have a max of 15 USB ports. So easy to make the USB Map.

Only have few issue I need to check and report later :
  • 1st : Some small scratches with sound chip (only the first hours I used the computer) no more issues since...
  • 2nd : Ok with WIFI Fenvi T919 but BT seems not working ! I use for moment a small BT 4.0 dongle. Don't know if it's a kext missing / or maybe a Front USB port issue on the MB (I've test both). A strange thing is the 2 Front USB ports aren't recognized with Hackintool !
  • 3rd : Unlock with Apple Watch doesn't work. Don't know if it's because the Fenvi BT issue or because I'm using the WatchOS 7 Beta ^^ - It's now working by using this cable : USB Cable / 4 pins
  • 4rd : Ethernet was slow with your IntelMausi kext in EFI (2.5.1d1) / No more issue with IntelMausi updated 1.0.3
  • 5nd : Would like to update the SMBIOS to 20,1 or 20,2 (20,2 is only for one precise processor model) but seems not working.
But as you can see... only some 2/3 issues !
I'm very happy with this Hackintosh. Was waiting the new iMac 2020... but soldered SSD and RAM ! NOOOO !

For those of U interesting, my config is :
  • BitFenix Phenom M (Mid Tower)
  • All new Gigabyte P750GM Modular 80 Gold Plus
  • Gigabyte Z490M Gaming X (mATX)
  • Intel i9 10th Gen 10850k
  • BeQuiet Dark Rock 4
  • 64 Go (16x4) DDR4 Crucial Ballistix 3200Mhz
  • Radeon RX 580 Sapphire Pulse XT 8Go
  • WIFI & BT with a FENVI T919 Card
  • SSD NVMe M.2 PNY CS3030 1To
  • 2 x SSD Samsung Evo 870
  • Samsung Monitor 4K 21/9 34"
Thank's a lot for your help and good luck for those of you starting mounting their Hackintosh ;)
(And please excuse me for my mistakes, I'm French and hate using Google Translator ahah)

Capture d’écran 2020-08-29 à 00.59.05.png
Capture d’écran 2020-08-30 à 00.09.01.png
 
Last edited:
Joined
Oct 1, 2010
Messages
66
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hier guys ! I finally took some time this Weekend to mount my new config. Thank U @nazrm for your advices and tips. I finally don't use your EFI & have prefered to used the Dortania Tuto, to understand what I'm doing (Old Clover config but 1st with OC)!

Before to start would just to say I'm totally fan of OpenCore! All is so much clean and understanding than Clover. The official Dortania's OpenCore Install Guide is so clear. All is explained and detailed perfectly.

After only few hours all is working like a charm :
  • Graphic Card : OK
  • Sound Chip (Rear & Front Panel Out/Mic) : OK
  • Ethernet (Intel i219) : OK
  • Fenvi T919 WiFi & BT : OK but... see below.
  • Sleep : OK
  • NVMe : OK
  • HandOff / Continuity / AirDrop : OK
  • NVRam : OK
One great thing with this MB is you have a max of 15 USB ports. So easy to make the USB Map.

Only have few issue I need to check and report later :
  • 1st : Some small scratches with sound chip (only the first hours I used the computer) no more issues since...
  • 2nd : Ok with WIFI Fenvi T919 but BT seems not working ! I use for moment a small BT 4.0 dongle. Don't know if it's a kext missing / or maybe a Front USB port issue on the MB (I've test both). A strange thing is the 2 Front USB ports aren't recognized with Hackintool !
  • 3rd : Unlock with Apple Watch doesn't work. Don't know if it's because the Fenvi BT issue or because I'm using the WatchOS 7 Beta ^^
  • 4rd : Ethernet was slow with your IntelMausi kext in EFI (2.5.1d1) / No more issue with IntelMausi updated 1.0.3
  • 5nd : Would like to update the SMBIOS to 20,1 or 20,2 (20,2 is only for one precise processor model) but seems not working.
But as you can see... only some 2/3 issues !
I'm very happy with this Hackintosh. Was waiting the new iMac 2020... but soldered SSD and RAM ! NOOOO !

For those of U interesting, my config is :
  • BitFenix Phenom M (Mid Tower)
  • All new Gigabyte P750GM Modular 80 Gold Plus
  • Gigabyte Z490M Gaming X (mATX)
  • Intel i9 10th Gen 10850k
  • BeQuiet Dark Rock 4
  • 64 Go (16x4) DDR4 Crucial Ballistix 3200Mhz
  • Radeon RX 580 Sapphire Pulse XT 8Go
  • WIFI & BT with a FENVI T919 Card
  • SSD NVMe M.2 PNY CS3030 1To
  • 2 x SSD Samsung Evo 870
  • Samsung Monitor 4K 21/9 34"
Thank's a lot for your help and good luck for those of you starting mounting their Hackintosh ;)
(And please excuse me for my mistakes, I'm French and hate using Google Translator ahah)

That's great! The dortania guide is really good as you say, and you learn a lot from reading/doing it. Regarding USBs: You can surpass the 15 port limit if you don't limit the amount of USB3 ports (because each physical port counts as two if you enable both USB2 and USB3 on it) Anyway, nice build, and bummer that the Fenvi didn't work!

I updated my main drive today to a Corsair Force MP600 1TB M.2 SSD - went smoothly. It's blazing fast with read/writes stable at 3GB/s (it would be close to 5GB/s if I had a PCIE 4.0 slot for it!)
 
Last edited:
Top