Contribute
Register

[Success] GA-Z77X-UD5H • i7-3770K • GTX560ti • 2 displays • Sierra 10.12.6 • Clover • FileVault

Joined
Jan 30, 2016
Messages
29
Motherboard
Gigabyte GA-Z77X-UDH5
CPU
Intel i7-3770k
Graphics
Nvidia GeForce GTX 560Ti
Mac
MacBook
Classic Mac
Classic, iMac, LC, Performa, Power Mac, Quadra
Mobile Phone
Other
Sierra has been almost effortless and a dream to set up to previous upgrades on my rig. The only problem was getting hold of a copy of Sierra as it seems Apple have completely removed it from the App Store.

In this guide, I first install El Capitan onto a new SSD. This is because I hadn't bothered to create a new Sierra Install USB drive, because i only have 1 USB drive and I didn't want to risk changing it. But don't worry, in the end I get Sierra running without compromising my USB ;)


THE USB

Using my trusty El Capitan USB (the same one I used for my El Capitan guide, still set up to install El Capitan and still itself using an older version of Clover), I added some important files mentioned in the Direct Upgrade guide:
- FakeSMC.kext (download here)
- Latest Clover pkg

With those files on my USB drive, I was ready. Switched off the machine and unplugged all my SSDs.


INSTALL EL CAPITAN AND NEW FILES TO THE NEW SSD

- With the machine switched off, I plugged in my new clean SSD, and plugged in my USB drive.
- Switch the machine on, select the USB from the Clover menu.
- Once booted, I run the El Capitan Installer having formatted my SSD appropriately using Disk Utility.
- Hit F12 on restart to select the USB boot loader, then choose the SSD from the Clover menu.
- Once the El Capitan install has finished, install the latest Clover to the SSD being careful to make sure the option is set to install to the SSD's EFI partition ("Install Clover in the ESP" under Installation Type)
- Mount the SSD EFI partition (i used Clover Configurator 4.52)
- Drag over the FakeSMC.kext and to the SSD's EFI partition, placing it in EFI/Clover/Kexts/Other.

Huzzah, clean El Capitan drive with latest Clover and FakeSMC ready to go!

This worked great and I was able to upgrade to El Capitan 10.11.6 from the App Store no problem. Something I'd been to afraid to do until now.


INSTALL SIERRA

I had hit a brick wall. Blogs wee reporting across the information superhighway that Apple had removed macOS Sierra from the app store. It wasn't showing in search or anywhere. Direct links to the app store resulted in "item not available in your country. Didn't matter which country I set the app store to, it was gone.

A few days later someone pointed me towards a site where it could be obtained (macOS 10.12 Sierra Installer has been removed from the App Store.), however it now seems there is a better way to get it: [How-to] Download Sierra 10.12.6 installer using Mac App Store command line interface.

Anyway, once I had it, I put it on my USB just in case (just the install file, i didn't make an install usb).

- Run the Sierra instal from the new El Capitan SSD.
- Restart booting from USB and then choosing "macOS Install" form the clover menu
- Installation finishes with language settings etc.
- Can now restart straight from the new Sierra SSD as it's EFI partition is already optimised.


FILEVAULT

Had trouble with this. I turned on File Vault, and having done a little research (FileVault and Sierra guide for noobs), I put UsbKbDxe.efi into my EFI partition to preempt the expected keyboard problems when rebooting the encrypted drive. Rebooted and got the no-entry sign as the Apple logo load screen was running. Tried verbose mode to see if i could see what was going on, it appeared when the no entry sign comes up, the screens graphics got a little distorted. No amount of rebooting would solve this.

But I'd been selecting my main drive from the Clover menu. So instead I tried the 2 (yes 2!) recovery drives that were also showing in the Clover menu. The first one got me to the login screen. Great I thought. Except the screen itself did look strange. The resolution was wrong and one of my screens wasn't working. But also... the keyboard did not work!

I tried booting the other recovery (one with a red cross in it's icon) from the clover menu. This just brought up standard Apple utilities, no Finder etc. Couldn't really do much with this. Supposedly unlock my encrypted disk, but it didn't recognise my password anyway. For whatever reason I got very bored of this route.

I switched off the machine. Plugged in my old El Capitan SSD and booted up using it as the startup drive, my new Sierra SSD also being plugged in.

As soon as the desktop appeared, a dialogue box asked fro my password to access the Sierra drive. Cool. That meant I could try the other Keyboard driver. And it turned out that was all i needed to do. I replaced with the other one from the FileVault and Sierra guide for noobs.

Switched off the machine, restarted with just the new Sierra Drive in. This time the Clover menu just showed 2 drives. Both labelled as Recovery drives (somehow that made sense). I selected the first one (the one without the red cross in the icon). Got the same strange resolution at the login screen, but the keyboard worked!

And when i entered my password, the desktop came up, and resolution was back to normal, both screens now working. And in the privacy pane of preferences i could see that encryption was almost done.

And as I speak, it is done.
 
Joined
Nov 21, 2018
Messages
4
Motherboard
Asus CG8500
CPU
i7
Graphics
GTX 560 Ti
Mobile Phone
Android
I have that exact GPU. Im wanting to setup a dual boot on my pc. Its a plex movie server as of now and I am extremely concerned about screwing something up. I got about 9TB's of movies half backed up. Ill literally cry if I lost all that. Should I go with el capitan?



CPU
Intel Core i7 2600 @ 3.40GHz 28 °C
Sandy Bridge 32nm Technology
RAM
8.00GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
Motherboard
ASUSTeK Computer INC. CG8350 (LGA1155) 26 °C
Graphics
NS-24E730A12 (1842x1036@60Hz)
1023MB NVIDIA GeForce GTX 560 Ti (NVIDIA) 31 °C
Storage
3726GB Western Digital WDC WD40EFRX-68N32N0 ATA Device (SATA ) 25 °C
111GB PNY CS900 120GB SSD ATA Device (SATA (SSD)) 33 °C
931GB Seagate ST31000528AS ATA Device (SATA ) 30 °C
3726GB Western Digital WDC WD40EFRX-68N32N0 ATA Device (SATA ) 27 °C
Optical Drives
HL-DT-ST BD-RE BH12LS35 ATA Device
Audio
NVIDIA High Definition Audio
 
Top