Contribute
Register

[Success] GA Z370 Aorus Gaming 7 + i7-8700k + RX5700XT + OC

Joined
Nov 6, 2012
Messages
27
Motherboard
GA--Z370
CPU
i7-8700K
Graphics
RX 5700 XT
Mac
Mac Pro
Svart's OpenCore Catalina 10.15.5 Refresh:
Core i7-8700k - Z370 Aorus Gaming 7 - 32GB RAM - RX 5700XT


Components

Gigabyte Z370 Aorus Gaming 7 Motherboard

https://www.amazon.de/GIGABYTE-Z370-AORUS-Gaming-7

Intel i7-8700K Coffee Lake 6 core 3.7 Processor
https://www.amazon.de/Intel-i7-8700K-Processor

G.Skill TridentZ DDR4 32GB PC 3200 CL14 Kit Tri/Z RGB (F4-3200C14D-32GTZR)
https://www.newegg.com/g-skill-32gb-288-pin-ddr4-sdram

Samsung 960 PRO SSD 512GB 2.1/3.5G PCIe M.2 NVMe
https://www.newegg.com/Product/Product.aspx?Item=N82E16820147596

Asus STRIX GTX1080-A8G-Gaming
https://www.newegg.com/Product/Product.aspx?Item=N82E16814126116

Fractal Design Define R6 Blackout Tempered Glass
https://www.newegg.com/Product/Product.aspx?Item=N82E16811352076

be quiet! Dark Power Pro 11 850W Power Supply
https://www.newegg.com/Product/Product.aspx?Item=1HU-004H-00042

Noctua NH-D15 CPU Cooler
https://www.newegg.com/p/1B4-0172-000B7?Description=Noctua

Noctua NF-A15 HS-PWM 140x150x25 fans
https://www.newegg.com/noctua-chromax-black-swap-case-fan


Added Components

Gigabyte Aorus RX 5700XT

https://www.newegg.com/gigabyte-radeon-rx-5700-xt

Samsung 970 PRO SSD 512GB 2.1/3.5G PCIe M.2 NVMe
https://www.newegg.com/samsung-970-pro-512gb


Comments

I wanted to upgrade my High Sierra build to Catalina and therefore needed to change my graphic card to AMD. I chose a 5700XT from Gigabyte. I also changed the boot loader from Clover to OpenCore. I'm surely no expert but after studying the opencore guide and some trial and error I got my working config.plist and SSDTs.

The build

I really liked the needed 2 slots of the gtx 1080, the 5700XT needs 3 slots and is very close to the next PCIE slot. Not a big problem because due to the massive heatsink - even a bit bigger than my 1080 - the fans aren't spinning for most of the time.

My working High Sierra install is on my M.2 SSD 970 and I used my M.2 SSD 960 to install Catalina. When I was sure everything was working and I got all my files copied to the Catalina install I cloned it to the 970 with CarbonCopyCloner. From now on CCC is cloning it to my 960 SSD to have a backup available whenever it is needed.

svarts hackpro.jpg
IMG_4688.jpg
IMG_4685.jpg


BIOS Settings

I upgraded the BIOS from F6 to the latest F15a.

1 Save & Exit → Load Optimized Defaults
2 M.I.T. → Advanced Memory Settings Extreme Memory Profile(X.M.P.) : Profile1
3 System → CSM Support : Disabled
3 BIOS → Fast Boot : Disabled
4 BIOS → LAN PXE Boot Option ROM : Disabled
5 BIOS → Storage Boot Option Control : UEFI
6 Peripherals → Initial Display Output : PCIe 1 Slot
7 Peripherals → Above 4G Decoding : Enabled
8 Peripherals → Intel Platform Trust Technology : Disabled
9 Peripherals → Network Stack Configuration → Network Stack : Disabled
10 Peripherals → USB Configuration → Legacy USB Support : Auto
11 Peripherals → USB Configuration → XHCI Hand-off : Enabled
12 Chipset → Vt-d : Enabled (disabled in the config.plist but if you use Windows you can enable it)
13 Chipset → Wake on LAN Enable : Enabled
14 Chipset → IOAPIC 24-119 Entries : Enabled
15 Chipset → Integrated Graphics : Enabled

Smart Fan Settings set to silent mode so all 6 fans are below 1000 rpm and nearly inaudible.

OpenCore

I followed the OpenCore Desktop Guide for my Coffee Lake CPU and also used the Hackintool and the New Beginner's Guide to USB port Configuration for mapping out my USB ports.

Choosing iMac19,2 iMacPro1,1 because it is very close to my build. Mandatory needed boot-args: agdpmod=pikera and igfxonln=1 without this I got stuck at booting "Nvidia IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0 error".
For audio I chose first the boot-arg "alcid=11" instead of the default "alcid=1" and later added it to Device Properties in the config.plist instead.

Mapping out the USB ports with USBMap tool like the guide mentioned wasn't as clear as with Hackintool form me. But both work.

Conclusion

So far so good. I got working iMessage, all USB ports, both UAD cards, sleep/wake, Bluetooth via USB, since I don't have WIFI installed Airdrop isn't available. This would be handy but not really needed right now. Unfortunately my SATA1 port is broken so I decided to ditch my DVD drive, not needed in a very long time :). All other SATA ports are used.

The downside of using 2 M.2 SSDs (pluged in M2A & P) with this motherboard is that I have to choose between having SATA ports 4 + 5 or losing the M.2 SSD populated in the M2P slot and gaining my Thunderbolt Alpine Ridge add-on card. For now I decided to have a backup M.2 and to use my SATAs till they die or I'm running out of space and switch to an external disk via thunderbolt.

To do

When I wake the system with a USB stick plugged into one of the frontside USB slots I get the message "USB not ejected properly". Not very high priority since I usually power down my pc.

Thanks to this awesome community and happy hackintoshing!

Edit 30.6.2020:
I got couple of black screens with the watchdog timeout window server error message like in this post. I changed from DP to HDMI and it seams to be solved.
Now I can use the NativeDisplayBrightness app from KAMIKAZEUA which didn't work with DP. Would be cool if you could choose not just only the "F" keys but also the "fn" key to adjust the brightness.

Edit 3.7.2020: I changed NativeDisplayBrightness to the app MonitorControl. Adjustment of brightness and audio works via the dedicated keys on my apple keyboard without pressing the "fn" key.

Edit 7.7.2020: Thanks to Slider29arg I changed today to iMacPro1,1 too and followed mattystonnies guide and increased the Metal-score in GB5 by almost 20k points.

Edit 21.7.2020: Updated to 10.15.6 via Softwareupdate with no issues.
 

Attachments

Last edited:
Joined
Jun 2, 2016
Messages
11
Motherboard
Aorus GA-Z370
CPU
i7-8700K
Graphics
RX 5700 XT
Mac
iMac
I have the same, GA Z370 Aorus Gaming 7 + i7-8700k + RX5700XT + OC and I try to come from Clover whith your OC EFI.zip

Everithing works, USB3... wifi, bluetooth etc, but, i cant enable hardware acceleration... you know why?
 
Joined
Nov 6, 2012
Messages
27
Motherboard
GA--Z370
CPU
i7-8700K
Graphics
RX 5700 XT
Mac
Mac Pro
great that you got it up and running!

via videoproc I'm able to activate the hardware acceleration, although I haven't tested it sofar:
videoproc hw acc.png


maybe you get better results with macpro7,1 as mentioned here by this guy.
Let me know your progress if you try it out!
 
Joined
Jun 2, 2016
Messages
11
Motherboard
Aorus GA-Z370
CPU
i7-8700K
Graphics
RX 5700 XT
Mac
iMac
great that you got it up and running!

via videoproc I'm able to activate the hardware acceleration, although I haven't tested it sofar:
View attachment 479329

maybe you get better results with macpro7,1 as mentioned here by this guy.
Let me know your progress if you try it out!

Thanks!
I have solved changing to ImacPro1,1 (with macpro7,1 and 64gb in 4 blocks i have problems)
 
Joined
Jul 13, 2011
Messages
190
Motherboard
Z370 Aorus Gaming 7-OpenCore
CPU
i9-9900K
Graphics
RX 580
if you guys want a DSDT for this board.
Gimmie a shout.
I've got the same board running an i9 9900k on F14 with everything working spot on in OpenCore.

Just upload a vanilla of whatever bios version you're on.
 
Joined
Mar 9, 2013
Messages
5
Motherboard
Z370 Aorus Gaming 5
CPU
i7 8700k
Graphics
GTX 970
Mac
MacBook Pro
Mobile Phone
iOS
Would it be possible to get this running without whatevergreen kext? I had it running without it on clover but using your open core efi I wasn’t able to get it to boot removing the kext and the boot arguments related to whatevergreen. What else would be necessary to remove to get it running as the 5700 should usually work natively
 
Joined
Feb 15, 2018
Messages
276
Motherboard
Aorus x299 Gaming 7 Pro
CPU
i9-9980XE
Graphics
RTX 2080 TI
Mac
iMac
Mobile Phone
iOS
i recently bought that same card because i have a complete aorus system
i like nvidia cards more but since i needed an amd card to run mac os
i choose that card because is aorus and it also has a nice design
of course the nvidia cards had better design and also better rgb effects

did i forgot to mentioned better performance?
:lol:

anyway when i received that 5700xt, the first thing that i noticed was, how dimmed the rgb lights look
compared to the front of the card that it look much brighter or how it should look under normal circumstances

can you please confirm if the aorus logo and the fan stop also look very dimmed in your card?
compared to the front of the card right where the fans at

if you use aorus engine on windows and set the brightness all the way up and that area still looks dimm
then it wasn't a faulty card, that means that card comes like that with horrible RBG

not even aorus can save that card
not even mac os can save amd

this is why i have always stick to nvidia even if that means no more mac os for me

yes i do once in a while turn off the rgb lights but what about when i want to use them
my system looks nice , except for that card that was ruining my build, that's why i sent it back for a refund

for those who doesn't care about RGB then the card is good for mac os
 
Last edited:
Joined
Mar 7, 2014
Messages
3
Motherboard
Gigabyte Z370M DS3H
CPU
Core i5 8600k
Graphics
Sapphire RX 580 Pulse 8gb
I just did an open core Catalina install on a similar setup: Gigabyte Z370M DS3H, i5 8600, RX 580. This is my third hack, first time getting it going without any tonymacx tools at all. Your writeup was helpful to me making it all work, thank you.
 
Top