Contribute
Register

[Success]GA-Z270X-UD3 i7-7700 GTX 960 16GB Samsung Evo 1TB

Joined
Apr 13, 2012
Messages
39
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
QuickTime's Kaby Lake i7-7700 Build:
GA-Z270X-UD3 - i7-7700 - GTX 960


Components

Gigabyte GA-Z270X-UD3 Motherboard
https://www.amazon.com/dp/B01N5G35XK/?tag=tonymacx86com-20

Intel Core i7-7700 Kaby Lake Processor

https://www.amazon.com/dp/B01N0L41N7/?tag=tonymacx86com-20

CoolerMaster LiquidMaster LITE 120
https://www.amazon.com/dp/B06XZ99XZY/?tag=tonymacx86com-20

Patriots 16GB DDR4 Signature Line 2400Mhz
https://www.amazon.com/dp/B016A3AU3W/?tag=tonymacx86com-20

EVGA SuperNOVA 650 G3
https://www.amazon.com/dp/B01LYGFRL6/?tag=tonymacx86com-20

Archer T9E 802.11AC AC1900
https://www.amazon.com/dp/B00TQEX7AQ/?tag=tonymacx86com-20

Already Owned

Samsung 850 EVO 1TB

https://www.amazon.com/dp/B00OBRFFAS/?tag=tonymacx86com-20

Fusion Drive:
3TB HGST HDN724030ALE640
480GB PNY CS2211

https://www.newegg.com/Product/Product.aspx?Item=9SIA0AJ3W49061&cm_re=PNY_CS2211-_-9SIA0AJ3W49061-_-Product

IOGEAR Bluetooth 4.0 dongle
https://www.amazon.com/dp/B007GFX0PY/?tag=tonymacx86com-20

EVGA GTX 960 2GB
https://www.amazon.com/dp/B00SL2TQ2C/?tag=tonymacx86com-20

Acer CB240HYK 24" 4K x 2 via DisplayPort
Magic Keyboard 2
Magic Trackpad 2

Comments

While trying to figure out why my Clover would not recognize my Fusion Drive any more, could have caused something to burn my previous Z77X motherboard. Replaced the PSU first but still can't light up so decided to rebuild.

Issues with rebuild:
  1. Latest Unibeast made USB drive couldn't boot. Will show cross circle icon.
  2. Some of the clover configs out there related to this motherboard did not work for me. Often get stuck at "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0", or just blank screen
  3. Because I don't want to lose my old system and files, I was trying to reinstall High Sierra onto my SSD, and there might be some old Nvidia web drivers causing problem.
  4. SIP was a major issue
Config that works for my final build:

Note:
  • You may need a different config that focus on using the Intel Graphics first. Otherwise I think this config will just software renderer
  • Follow other common recommendation for BIOS settings for GA-Z270 or Z170 boards should be fine
  • darkwake = 8 works well for me. Can sleep overnight and wake again the next morning properly with USB still working
  • IntelGFX Fake ID is 0x59128086 for the Intel HD 630 in i7-7700
  • FakeCPUID is 0x0506E3 for i7-7700
  • I needed to turn off SIP for this to work, otherwise having issues with some kext and Nvidia graphics. CsrActiveConfig is set to 0x67
  • I am using iMac18,3 system definition
Kext used in Clover:
  • FakePCIID_Intel_HD_Graphics.kext (may be needed for installation before Nvidia web drivers)
  • FakeSMC.kext
  • IntelGraphicsFixup.kext (may be needed for installation before Nvidia web drivers)
  • IntelMausiEthernet.kext
  • Lilu.kext
  • NullCPUPowerManagement.kext
  • NvidiaGraphicsFixup.kext
0.png

1.png

3.png

4.png

5.png

6.png

7.png


What Works
  • Wireless and bluetooth works out of box, supports 802.11ac
  • Sleep, with darkwake=8
  • Metal acceleration and CUDA
  • ALC1220 audio, with AppleALC 1.2.0, and see the ACPI config above. Front headphone jacket seems unstable, but back headphone jack works well (shown as "Built-in output: Internal Speakers)
  • USB 3.0
What Does Not Work
  • Thunderbolt (have to add a card so haven't tested)
  • USB 3.1 (USB-C) (haven't tested)
  • Wake up from Apple Watch, can't seem to activate this
  • Powernap, do not see this option
Benchmarks

Screen Shot 2017-10-29 at 4.49.09 PM.png

Screen Shot 2017-10-29 at 4.51.39 PM.png

Screen Shot 2017-10-29 at 8.41.51 PM.png
 
Last edited:
Top