Contribute
Register

[Success] GA-Z170X-Gaming 7 (Rev 1.0) + i7-6700K + GTX 560 Ti + Sierra

Joined
Dec 16, 2016
Messages
20
That's great. Sometimes it shut downs, sometimes it restarts and sometimes it shuts down but the power button won't work to turn back on until I turn off and on the power supply.

I really appreciate this thread. Thank you for sharing your build.
 
Joined
Dec 16, 2016
Messages
20
Also testing, but Patches under DSDT - Rename HDAS to HDEF, SAT0 to SATA, HECI to IMEI, _OSI to XOSI, _DSM to XDSM, GPRW,2,N to XPRW and GFX0 to IPGU
Is the above patches just a case of renames in the config? Also, What is the benefit of renaming SAT0 to SATA? My drives seem to be working.
 
Joined
Dec 4, 2016
Messages
57
Motherboard
Gigabyte GA-Z170X-Gaming 7 ATX LGA1151
CPU
Intel Core i7-6700K
Graphics
EVGA GeForce GTX 970 4GB SSC ACX 2.0+
Is the above patches just a case of renames in the config? Also, What is the benefit of renaming SAT0 to SATA? My drives seem to be working.
Yes, depending on your needs, you can add those renames in the config.plist file. Some are needed for say patching other things. E.g. _DSM to XDSM is needed for SSDT-LPC.aml patching.

You need to rename SAT0 to SATA if your IOReg shows SAT0 in lieu of SATA. And then you use SSDT-SATA.aml to patch it.

See @VoiletDragon SSDT patch repository here for some examples of patches and what is needed to be added when using such patches. https://github.com/VoiletDragon/Series-9-Patches
 
Joined
Dec 16, 2016
Messages
20
What do these patches achieve? My machine seems to be running well without them. I have no idea what an .aml is.

Is this all to fix sleep?

Yes, depending on your needs, you can add those renames in the config.plist file. Some are needed for say patching other things. E.g. _DSM to XDSM is needed for SSDT-LPC.aml patching.

You need to rename SAT0 to SATA if your IOReg shows SAT0 in lieu of SATA. And then you use SSDT-SATA.aml to patch it.

See @VoiletDragon SSDT patch repository here for some examples of patches and what is needed to be added when using such patches. https://github.com/VoiletDragon/Series-9-Patches
 
Joined
Dec 4, 2016
Messages
57
Motherboard
Gigabyte GA-Z170X-Gaming 7 ATX LGA1151
CPU
Intel Core i7-6700K
Graphics
EVGA GeForce GTX 970 4GB SSC ACX 2.0+
What do these patches achieve? My machine seems to be running well without them. I have no idea what an .aml is.

Is this all to fix sleep?
If your machine is running well, then don't use these patches. They are used to fix different things, not just sleep.
 
Joined
Dec 16, 2016
Messages
20
If your machine is running well, then don't use these patches. They are used to fix different things, not just sleep.
Ok but returning to the original question, is it just a case of renaming within the config file or is there aml files to be installed? I have the same motherboard so I'll probably have to do some of this at some stage.
 
Joined
Oct 20, 2010
Messages
8
Motherboard
Z77X-UD5H, Z170X Gaming 7
CPU
3770K, 6700K
Graphics
GTX 760, GTX 960
Did you manage to make your Renesas USB hub work?
FYI. My front panel is connected to F_USB30_2 (connected to a Renesas uPD720210 hub chip) and they are working fine using the instruction here.
 
Joined
Sep 10, 2012
Messages
3
Motherboard
10.7
CPU
i7
Graphics
9600
Mac
Classic Mac
Mobile Phone
Hi everyone
Firstly thanks so much for all the info JmacIV and others, it's been a massive help to find this thread.
I've just changed out the MB, CPU, GPU and RAM on my hack to this MB (Gaming 7)
In just a day I've pretty much got everything going by following the install on page 1.
I'm still stuck with the audio, reinstalled the kext, checked the config, nothing, until I gave up and plugged in my Creative soundblaster USB to 3.5mm. then after a reboot the rear panel Line-out and SPDIF-out appeared.
I was hoping the people that are smarter than me (Just about everyone here) can figure this. I know the chip is the same, but what injects the drivers at boot? Can I fake that somehow so I don't need the SB USB Card (I use it for my macbook pro)
Cheers
 

pkv

Joined
Apr 2, 2011
Messages
10
Motherboard
Z77X-UD5H / Z170x-gaming 7
CPU
core i7 3770 / core i7 7700K
Graphics
gtx 1060 6GB / gtx 960
Mobile Phone
Android
@JMacIV
Much thanks for your excellent guide !

followed your instructions for audio, worked great; is it compulsory to put the two kexts in SLE or LE ?
tried first in CLOVER>kexts>other but it did not work.

Regarding having IGPU + nvidia card (gtx 960), I have both running at the same time on two screens.
I did not have anything to do, worked OOB after clean install with iGPU (HD 630 because I switched a 6700K for a 7700K)

I did not implement any of the patches or fixes; rig is working so did not feel the need to tinker.
 
Top