Contribute
Register

[SUCCESS] Fanless Build: Coffee Lake + Iris Plus 655 + Catalina, Quiet and Fast

Joined
Jan 19, 2020
Messages
9
Motherboard
Partaker B16
CPU
i7 8595U
Graphics
Intel Iris Plus 655
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
DC's Fanless Catalina:
Core i7-8559U - Partaker B16 - 16GB RAM - Intel Iris Plus 655


1597625120387.jpg


Components
Partaker B16 Fanless Mini PC
https://www.newegg.com/p/1VK-01S3-009A8

Samsung 970 EVO Plus SSD 250GB
https://www.amazon.com/dp/B07MG119KG/?tag=tonymacx86com-20

PNY 8GB DDR4 2400MHz Notebook Memory (a pair)
https://www.amazon.com/dp/B07PYYBXD6/?tag=tonymacx86com-20

Already Owned

Dell DW 1510 PW934 Half-Size Mini Wireless PCi-E WiFi
https://www.amazon.com/dp/B00B5A0NGU/?tag=tonymacx86com-20

HP 27 inch 27es IPS LED Full HD ( 1080P ) Ultrafast (a pair)
https://www.amazon.com/dp/B01MRKO20L/?tag=tonymacx86com-20

Comments

I started Hackintosh build over ten years ago but until about a year ago with good success with ThinkPad X220, X230. Those two are solid and served me well that I was able to use them on a daily basis. On another hand, as a minimalist, I have been longing for a mini PC for years and got hands on a NUC DC3217IYE earlier in the year. The build with the NUC was a success. However with all the builds, the fan noise came up sooner or later bothering me. Thus I ended up the purchase of the fanless mini PC. With much research I only saw suppliers from oversees, especially China. The Partaker B16 off AliExpress was an eventless transaction and delivered from Hong Kong within a week.

I used the EFI files from my NUC build and the installation of the latest Catalina 10.5.6 was ok for the B16. It was though quite an effort to get full video acceleration/Metal and dual external monitor working off the built-in Intel Iris Plus Graphics 655. Details are shared in below section.

Installation Notes
- [open] unable to identify the Partaker B16 motherboard model
- [open] DP -> HDMI does not work

I was unable to find a guide specific for the Partaker B16, and, thus, I adjusted the BIOS based on general guidance such as no secure boot. You need hold down the Delete key to enter the BIOS and F11 to enter the Boot priority list. The manufacturer masked the base board id to Default String and I was unable to identify the motherboard ID. Appreciate if you can shed some light on the specific motherboard information.

1597625120439.jpg

Wifi extension
With DW 1510, only thing needed to make the Wifi work is the extension: IO80211Family.kext (no need of IO80211FamilyV2.kext)

Graphics Settings
It was quite an effort to make the Intel Iris Plus Graphics 655 fully work under Catalina 10.5.6. I started with the Clover configuration only as it worked for me for X230 well. With endless research and no success, the Graphics of the About This Mac page always showed 7 MB memory.
- Updated to the latest Lilu (1.4.6) and Whatevergreen (1.4.1)
- Tried with no success, Inject Intel with Fake IntelGFX 0x12345678, 0x3EA50000, and ig-platform-id 0x3EA50000, 0x3EA50004, 0x3EA50009
- Tried with no success, DSDT edits on the Method(_DSM, 4, NotSerialized) with Iris device id and ig-platform-id
- Tried NUC8i7BEH EFIs with no success. I was hoping the NUC configuration work without adjustment for the B16. However it did not.

Until I stumbled upon the Hackintool (version 3.4.4) and CaseySJ's post, I was able to gradually make the graphics work.

With the general guidance of the Hackintool, I delightfully found the graphics card was fully recognized and finally the memory showed 1536 MB instead of the dreadful 7 MB. However, only one of the two HP 27es that connected to the DP -> VGA works, the other monitor that connected to the HDMI did not work. I searched and found CaseySJ's post about search for the right combination of Connectors parameters: Index/Bus ID/Pipe/Type and con number.


Screen Shot 2020-08-16 at 8.23.14 PM.png


I started with only the DP/VGA port working and thus only the Index=1 (port-number=5) line was red. Not sure if the B16 has two or three port-number's, I tried with both Index=2 and Index = 3. With rounds of failure based on random mapping of Index to Bus ID, I finally experimented with setting the same Bus ID (1, 2, 4, 5, 6 but different from the Index 1 Bus ID) for both Index 2 and 3. It happened that the HDMI screen flickered when I used Bus ID = 0x02 for both ports. The HDMI screen flickered for about 20 seconds and turned stable. However when I restarted B16, the HDMI screen stayed dark for about 30 seconds and flickered again and turned stable after a while.

This is when I turned again to Whatevergreen with the release note promised a fix for the black screen.
- Fixes black screen on Intel HD since 10.15.5.

I was able to spot the suspect boot flag: igfxonln=1. With the boot flag finally I was able to boot the machine with both external display on and stable. At this time I was able to verify with the Hackintool that I have two ports, port-number = 5 for the DP/VGA and 6 for the HDMI.

Screen Shot 2020-08-16 at 9.07.01 PM.png

With a working setup I have been further trying to figure out if I can make the DP -> HDMI work using an adapter but found no success. I suspect is is a problem of the motherboard or BIOS setting as the DP -> HDMI does not work even for BIOS screen. Appreciate if anybody can share a tip to make it work.
 

Attachments

  • EFI.zip
    5.4 MB · Views: 17
Last edited:
Joined
May 5, 2017
Messages
378
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
  1. MacBook Pro
This is great to see - thanks for sharing. I will do some more research into those machines, as it looks like it might be easier than trying to make an existing machine passive.

How is the performance and the temperatures?
 
Joined
Jan 19, 2020
Messages
9
Motherboard
Partaker B16
CPU
i7 8595U
Graphics
Intel Iris Plus 655
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I have been using the machine mostly for daily office work, e.g. Microsoft Suite and Python programming. Have not tried gaming much. So far so good with the CPU temperature. I can put my hand on the top, definitely feel the heat but it's not unbearable.

I'm extremely happy with the quietness and the Coffee Lake runs smoothly.

One thing I am working on these couple of days is trying to get a more reliable Bluetooth solution. I use the Igogear GBU521 but it is unstable working with my AirPods Pro. I got a Broadcom BCM94331CD off eBay as I thought it would work OOB. The WiFi works but the Bluetooth does not. Not sure if the card is a defect.
 
Joined
May 5, 2017
Messages
378
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
  1. MacBook Pro
I'm not sure your hackintosh experience, but one "often" made mistake with the Apple cards is that you also need to connect to USB - have you done that? Wifi works over the PCI interface, but a separate USB connection is needed for bluetooth.
 
Joined
Jan 19, 2020
Messages
9
Motherboard
Partaker B16
CPU
i7 8595U
Graphics
Intel Iris Plus 655
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Thanks @phrozenpenguin for the suggestion. I read it somewhere it but did not put too much thought on the USB connection. Will look further into it. On the other hand, the card has four connectors (one for Bluetooth and three for WiFI) and the fanless has only two pigtails. The WiFi works regardless of how I connect the two pigtails to two of the four connectors. However I had no luck with the BT.
 
Joined
May 5, 2017
Messages
378
Motherboard
HP 8300 CMT
CPU
i7-3770
Graphics
RX 560
Mac
  1. MacBook Pro
There are potentially two issues to troubleshoot.

1 - is the bluetooth interface physically connected (USB) - i.e. can you see bluetooth in MacOS
2 - assuming 1 is connected and detected, does it work. If you have no bluetooth antenna connected I wouldn't expect it to work well but I would expect it to show up.
 
Joined
Jan 19, 2020
Messages
9
Motherboard
Partaker B16
CPU
i7 8595U
Graphics
Intel Iris Plus 655
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Thanks buddy. I just ordered a different PCI-E adapter with the USB connection today. Tried to connect to the USB header but the WiFi even stopped being recognized. I need to research further.
 
Joined
Jan 19, 2020
Messages
9
Motherboard
Partaker B16
CPU
i7 8595U
Graphics
Intel Iris Plus 655
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Got a pair of 4k monitors (Lenovo L28U-30), spent the last several days and finally got the full 4k resolution! Tried and failed numerous attempts by using framebuffer patches before I finally made up mind to increase the DVMT pre-allocated to 64MB/96MB and it worked.

I searched the BIOS and there was barely any option for graphics (of course no luck with a DVMT pre-allocated setting). Thus I would need to use the EFI Shell to edit the BIOS setting (following Jake Lo's post). After the DVMT edit, I deleted below framebuffer patches and they are not necessary:
  • framebuffer-fbmem
  • framebuffer-stolenmem
  • framebuffer-unifiedmem
  • enable-hdmi20
  • KextsToPatch on AppleIntelFramebufferAzul
Steps for the BIOS DVMT editing (credit to Jake Lo):
  1. Universal BIOS Backup ToolKit 2.0.exe - to backup the BIOS. The read/backup went through ok though the tool says the BIOS was not recognized.
  2. UEFITool.exe to find the module labeled SetupPrep and extract the PE32 image section (setup.bin)
  3. Search with this GUID (899407d7-99fe-43d8-9a21-79ec328cac21), right click the GUID found and select extract body. Save it as setup.bin (though Jake says Dell only, the same GUID works for my fanless)
  4. Universal IFR Extractor.exe to extract setup.bin to a readable text file
  5. Use notepad to search for “DVMT” in the text file. 2 were found at 0xa14 and 0xa15 but only 0xa14 needs to be changed to 0x3
  6. Format an USB drive to fat32 and create a folder name EFI
  7. Download the EFI Shell and extract the Boot folder to EFI folder (EFI/Boot/bootx64.efi)
  8. Boot system with the USB and select UEFI Boot
  9. At the grub prompt, enter these commands, hit enter after command, then exit and reboot.
    Code:
    setup_var 0xa14 0x3
 

Attachments

  • DVMT_Edit.zip
    8.6 MB · Views: 18
Last edited:
Joined
Jan 19, 2020
Messages
9
Motherboard
Partaker B16
CPU
i7 8595U
Graphics
Intel Iris Plus 655
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
@phrozenpenguin: after several days trying to make the Bluetooth work but failed. I'm giving up now. I got two cards (BCM94331CD and BCM94360CS2) and two mini PCI-e adapters (one with USB signal port and one without). No luck so far. Will use GBU521.
 
Joined
Sep 22, 2011
Messages
729
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700T
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@distantcube - Nice job. Have you gotten DP->HDMI to work yet? If not, try the concepts below that I am still trying to confirm after building my HP EliteDesk 800 G4 Mini with DP->DVI adapters:

From what I have observed, the keys to success with UHD 630 when using adapters (e.g. DP->HDMI or DP->DVI) are as follows:
  • Choose connector BusIDs based on the converted type and not on the connector type on your motherboard (e.g. if you are using a DP->HDMI adapter, select a valid BusID for HDMI)
  • Choose the connector type based on the converted type and not on the connector type on your motherboard (e.g. if you are using a DP->HDMI adapter, select connector type HDMI and not DP)
  • When using adapters, in order to avoid an AppleALC kernel panic on wake from sleep, you may need to add HDA property no-hda-gfx as I have described in my thread's Methodology
  • Try boot-arg igfxagdc=0. I needed this in order to enable multiple displays on my HackMini8,1.
  • Look at the results of my framebuffer patching experiments to get ideas - discovering that I needed to use connector type DigitalDVI with DP->DVI adapters and discovering that I needed to use the BusIDs associated with DigitalDVI (not DP) was the result of tedious trial and error
 
Top