Contribute
Register

[SUCCESS] El Capitan - GA-EP45-DS3R (BIOS F11e) + Q9400 + Radeon HD 4850

Status
Not open for further replies.
Joined
Aug 28, 2013
Messages
6
Motherboard
GA-EP45-DSR3 r1.0
CPU
Q9400
Graphics
HD4850 512MB
Mobile Phone
  1. Android
Just wanted to share my success story with building and installing a CustoMac made from old parts, using UniBeast and MultiBeast.

Admittedly, it is not the first time I've installed OS X on this particular rig, but with the magic of Clover, it has definitely been the smoothest install by far.

The settings in this post have resulted in a CustoMac that has no sound, sleep, USB or graphics issues that I know of.

EDIT: (v0.2) It turns out that the system won't power off by itself -- after OS X has halted, I need to manually hold the power button to turn the system off. This is the only issue I've encountered.

In other words, it (mostly) Just Works™

Version: 0.2


OS: Mac OS X El Capitan 10.11.3 (15D21)


Hardware:

Motherboard: Gigabyte GA-EP45-DS3R rev. 1.0 (BIOS F11e)
CPU: Intel Core 2 Quad 9400 (2.67 GHz, 1333MHz FSB)
RAM: 4x2 GiB Kingston DDR2-800 (running at 667 MHz)
HDD: Seagate 500 GiB 7200 RPM 16 MB cache (ST500DM002-1BD142)
GPU: Club 3D Radeon HD 4850 512 MB (OpenGL 3.3)
Sound: Realtek ALC 889a
Network Card: Realtek 8111C GigE


MultiBeast Options:

Code:
MultiBeast Configuration - 2016-02-29 09:23:10
-----------------------------------------------------------------
Quick Start > Legacy Boot Mode
Drivers > Audio > Realtek ALCxxx > ALC885/889a
Drivers > Disk > 3rd Party SATA
Drivers > Disk > Intel Generic AHCI SATA
Drivers > Misc > FakeSMC v6.18.1394
Drivers > Misc > FakeSMC Plugins v6.18.1394
Drivers > Misc > FakeSMC HWMonitor Application v6.18.1394
Drivers > Network > Realtek > RealtekRTL8111 v2.0.0
Bootloaders > Clover v2.3k r3320 Legacy Boot Mode
Customize > System Definitions > Mac Pro > Mac Pro 3,1
Drivers > Graphics > Inject ATI


Custom Clover settings:

Code:
# mount the EFI partition
mkdir /Volumes/EFI
# this assumes that only one harddrive disk is present
# and that the EFI partition lives on /dev/disk0s1
sudo mount_msdos /dev/disk0s1 /Volumes/EFI
cd /Volumes/EFI/EFI/CLOVER/
# use whichever editor you prefer -- I used nano
nano -w config.plist


1./ Ensure that OS X can throttle the CPU power states and go into low-power idle CPU states:

Code:
                <key>SSDT</key>
                <dict>
                        <key>DropOem</key>
                        <false/>
                        <key>Generate</key>
                        <dict>
                                <key>CStates</key>
                                <true/>
                                <key>PStates</key>
                                <true/>
                        </dict>
                        <key>EnableC2</key>
                        <true/>
                        <key>EnableC4</key>
                        <true/>
                        <key>EnableC6</key>
                        <false/>
                </dict>

NOTE: Make sure you enable C2/C2E and C4/C4E in the BIOS menu (where?)


2./ Ensure that the Radeon HD 4850 graphics cards works by having Clover spoof a known Apple-branded HD 4850 PCI device id (some people have had more luck spoofing a known HD 4870 PCI device id instead -- see below):

Section "ACPI / DSDT / FIXES":

Code:
                       <key>FixDisplay_0100</key>
                       <true/>


Section "Devices / FakeID / ATI":

Code:
                        <key>ATI</key>
                        <string>0x944a1002</string>

NOTE: The original PCI device id for my card was 0x94421002; Apple-branded Radeon HD 4850 cards use the PCI device id 0x944a1002 I believe. See Fl0r!an's Radeon Compatibility Guide for the gory details.

UPDATE: Fl0r!an has dropped the 4xxx gen cards from his guide, but in one of his posts he notes that some people have had luck using the HD 4870 PCI device id 0x94401002 for their HD 4850 cards on Sierra.


Section "Graphics / Inject":

Code:
                        <key>ATI</key>
                        <true/>

NOTE: This option was already set by MultiBeast.

_____
Enjoy!
 
Last edited:
Joined
Nov 24, 2015
Messages
1
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello,

has been passed a month since your thread. Do you confirm that it just works? or have you matched some issue?
I've a Q9400 + 8Gib + HD4850 and I've only to buy MoBo.
Thanks in advance.

:beachball:
:)
 
Joined
Aug 28, 2013
Messages
6
Motherboard
GA-EP45-DSR3 r1.0
CPU
Q9400
Graphics
HD4850 512MB
Mobile Phone
  1. Android
It turns out that the system will halt but not power off by itself, which means that I need to manually hold the power button for 4 seconds after OS X has shut down to make the machine power off.

When using the exact same installation with an NVidia GTS 450, the system powers off by itself.

This is the only issue I've encountered.
 
Joined
Dec 8, 2010
Messages
51
Motherboard
Aspire 5750
CPU
i3-2330m
Graphics
Intel 3000
Mac
Classic Mac
Mobile Phone
  1. Android
Didn't know if you guys were aware that most of these old BIOS on these GA boards can be modded and the internal SATA / Jmicron / Realtek drivers can be updated on them? Many people report way quicker boot times, etc from this. There is a modded version here! http://forums.tweaktown.com/gigabyte/28441-gigabyte-latest-beta-bios-2.html

Many of them even add trim to RAID, etc...

I have the EP45-DQ6 and have sleep issues also, trying to sort it out now but my F12 BIOS fixes them in Windows, going to test other versions soon and hopefully get this sorted once and for all as I have had sleep issues for years on this DSDT / BIOS

--- While I am at it, you know you can EASILY mod your board with a cheapo 771 XEON processor and get it running cooler and so on for very cheap? I updated mine to a E5450 (My Ep45-DQ6 and my G31M ) and they now run at 80W all for $20 This would double the cache on your chips, up them to 3GHz and give you 15W less!!!
 
Joined
Aug 28, 2013
Messages
6
Motherboard
GA-EP45-DSR3 r1.0
CPU
Q9400
Graphics
HD4850 512MB
Mobile Phone
  1. Android
Didn't know if you guys were aware that most of these old BIOS on these GA boards can be modded and the internal SATA / Jmicron / Realtek drivers can be updated on them? Many people report way quicker boot times, etc from this. There is a modded version here! http://forums.tweaktown.com/gigabyte/28441-gigabyte-latest-beta-bios-2.html

I updated my BIOS to the GA-EP45-DS3R - F11i version and it worked like a charm as long as I set it up to use AHCI and disabled the "Native IDE" option for SATA ports 0-3.

Thanks for the tip!

Not sure I want to bother with the Xeon LGA771 - LGA775 mod, but it's certainly a nice option to have. :)
 
Joined
Jul 19, 2016
Messages
1
Motherboard
intel h61
CPU
i3
HI

@ermo
I have also an ATI 4850 and the El Capitan installed on my machine . I can not make it work full . Did you put the values in framebuffer or other ktext in the system?
 
Joined
Aug 3, 2012
Messages
1
Motherboard
Mac OS X El Capitan and Mountain Lion
CPU
Quadcore Intel
Graphics
GT 7500
Mac
  1. Mac Pro
Thank you all for your hints!

With this background I managed either to have a working shut down or a working sleep.
I still use the F10 bios not the F11 beta.

I used all the entries The Voiceover gave concerning multibeast for El Capitan. I did not use the changes in clover settings he suggested. I did simply not know if I have these xstates in my bios..... :)
When I looked I found at least the the entry C1E and I disabled it. Now first time I had a clean shut down.
Fiddling around I changed in system preferences ---energy saver----display and computer sleep from "never" to "1hour".

Result the working shut down was gone......!

So it seems the savers option must be "never".

This working shut down was with "S3 mode" in the "power management options" of the F10 bios. When I changed to "S1" the "sleep" was working, but no more the "shut down".

Funny!

I decided myself to use the S3 option with the working "shut down" option.

Hope this works for you all too.
 
Joined
Apr 24, 2017
Messages
10
Motherboard
MSI P45 Neo3-FR P45 S775
CPU
E7200
Graphics
GTX 280
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
hi ermo,

thanks a lot for you instruction! Are you still on El Capitan or already on Sierra? I tried with Sierra but my 4850 is not working.

Thanks!
 
Joined
Aug 28, 2013
Messages
6
Motherboard
GA-EP45-DSR3 r1.0
CPU
Q9400
Graphics
HD4850 512MB
Mobile Phone
  1. Android
HI

@ermo
I have also an ATI 4850 and the El Capitan installed on my machine . I can not make it work full . Did you put the values in framebuffer or other ktext in the system?

Sorry for the late reply (my account got deactivated for some reason).

No, I only configured Clover to spoof the PCI device id.
 
Joined
Aug 28, 2013
Messages
6
Motherboard
GA-EP45-DSR3 r1.0
CPU
Q9400
Graphics
HD4850 512MB
Mobile Phone
  1. Android
hi ermo,

thanks a lot for you instruction! Are you still on El Capitan or already on Sierra? I tried with Sierra but my 4850 is not working.

Thanks!

Still on El Capitan.

I updated the guide per Fl0r!an's advice to use a HD 4870 PCI device id instead of a HD 4850 PCI device id on Sierra.

Maybe try that? :)
 
Status
Not open for further replies.
Top