Contribute
Register

[SUCCESS] El Capitan 10.11.5 x Win 10 Dual Boot - GA-H81M-D2V - i7-4770 - R9 280X 3GB

Status
Not open for further replies.
Joined
Oct 27, 2015
Messages
8
Motherboard
Asus Prime Z270-A
CPU
i7-7700K
Graphics
GTX 1080
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
systemvsud2.png


INTRODUCTION


Back in 2010, I already built two Hackintosh machines and after working on a MacBook Pro and an iMac for almost 5 years, I decided to turn my existing gaming platform into a Hackintosh instead of buying a new Mac.

I tried installing Yosemite or Mavericks (can't really remember) a while ago, but not everything was working as expected so i ditched the project.

After stumbling across a post on the tonymacx86's Facebook page, I felt like I should try it again with El Capitan. Now that MultiBeast contains Clover, I was eager to try out this method as I've never used Clover before.

My goal was to be able to use both El Capitan and Windows 10 (for gaming only) side by side.

So, let's take a look at the components I used first.


COMPONENTS

Mainboard: Gigabyte H81M-D2V rev. 1.0 (Bios F6)
Processor: Intel i7-4770
Graphics Card: Sapphire R9 280X 3GB
RAM: Corsair Vengance DDR3 1600 16GB
HDD1: WD Blue 1TB HDD
HDD2: Apple 500GB Macbook HDD
SSD1: Samsung EVO 580 500GB
SSD2: OCZ Vertex 2 128GB
PSU: Thermaltake Berlin 630W
Case: Cooler Master K260
Optical Drive: TSScorp DVD-ROM
USB Stick: SanDisk Ultra Flair 16GB USB 3


INSTALLATION

As usual, I followed tonymacx86's invaluable guide to create the USB stick with Unibeast and downloaded MultiBeast 8.2.2 (for El Capitan) and copied it to the USB stick once Unibeast was finished.

Link to guide: http://www.tonymacx86.com/threads/u...pitan-on-any-supported-intel-based-pc.172672/

Be sure to use 'UEFI Boot Mode' when Unibeast asks for the Boot method. Graphics Configuration is not needed.

The first thing I did before beginning to install the OS was disconnecting all the unnecessary hardware. The only thing connected to the mainboard was the Samsung SSD (and vital parts such as RAM, processor, fans etc). I installed the graphics card once the OS was up and running. I connected my monitor via the DVI port.

I'm running BIOS version F6, which seems to be the latest one for this mainboard.

In the BIOS, I made the following settings:

1. Load Optimized Default
2. Disabled 'VT-d'
3. Set 'OS Type' to 'other'
4. Set 'Extreme Memory Profile' to 'Profile 1'
5. Set 'XHCI Handoff' to 'Enabled' (should be on by default)
6. Set 'Initial Display Output' to 'IGFX'
7. Set 'Intel Processor Graphics' to 'Enabled' (We'll switch to the 280x later
8. Disable the IO Serial Ports (I didn't do it on the first try but it didn't make any difference)

Be Sure to check out the screenshots as I might forgot to mention one or two settings I made. If you're not sure about different settings, please ask. I'm no expert on BIOS settings but I'll try my best to help.



After saving the settings and exiting, my mainboard booted into the USB stick automatically, if your's is not, select the USB stick as your boot device in the BIOS.

At the Clover boot screen I chose "Boot Mac OS X from USB" and followed the steps described in the tonymacx86 guide posted earlier to install El Capitan.

When the installer asks for an internet connection, select "the computer is not connected to the internet" and when it asks you to login into your iCloud, just skip it. You can do that later.

After finishing the installation, the system will reboot. Be sure not to remove the USB drive as you'll need it once again to boot into your newly installed OS X.

When the Clover boot screen pops up, I selected "Boot Mac OS X from HD" as described in section 5 of the install guide.

After the system had successfully booted, I copied MultiBeast from the USB stick onto my desktop and opened it.

I chose the following settings:

1. Quick Start: Choose 'UEFI Boot Mode'
2. Drivers:
- Audio: Realtec: Realtec ACL887/888b
- Network: Realtek: RealtekRTL8111 v.2.2.1
- USB: 3rd party USB 3.0
- USB: Support for 7/8/9 Series USB Support
3. Customize:
- System Definitions : iMac 14,2



The rest got automatically selected by MultiBeast.

I clicked on the build tab and then on 'Install'.

After the installation was finished, I ejected the USB drive and rebooted the system.

After the system had rebooted, I went to 'System Preferences' and then to the 'Audio' tab. Opened up the 'Output' tab and selected 'Internal Speakers', my audio was now working with the audio ports on the back.

I also plugged on my Ethernet cable to see that the network card was working.

The only thing left to do was to get the graphics card up and running.

I shut down the machine, installed the graphics card into the mainboard and went into the BIOS. I set the 'Initial Display Output' from 'IGFX' to 'PCI 1' and the 'Intel Processor Graphics' to 'Disabled'. After that I unplugged the DVI connector from the mainboard and connected it to the graphics card. I saved the BIOS setting and rebooted, the graphics card was now working.

Now that El Capitan was up and running, I shut down the machine once again and plugged the Windows 10 SSD and the Apple HDD back in and rebooted.

At the Clover boot screen, the Windows 10 SSD showed up and I was able to boot into it without any problems.

The Clover boot screen also showed all the Legacy booting options for Windows 10 which I removed in the Clover Configurator later by un-clicking the 'Legacy' button at the 'Gui' section.

To change the settings of our config.plist you have to mount the EFI partition in Clover Configurator by pressing 'Mount EFI' and selecting the disk your OS is installed. In my case it shows two disks as Clover Configurator seems to detect the Windows 10 EFI as well.

Now open up the config.plist in Clover Configurator. Clover's config.plist is stored in EFI -> CLOVER.

Navigate to the 'Gui' section and click on th 'Legacy' radio button on the top in the 'Scan' section. Press CMD + S to save your settings.



Another setting I had to make was to activate the 'XMPDetection' (klick on 'XMPDetection=Yes') in the 'Boot' section in Clover Configurator because I enabled the XMP setting in the BIOS when the OS was already installed and so Clover didn't set this automatically.



To get the R9 280x fully recognized, we need to set "Inject ATI" in the Clover settings.



That's it. This was the easiest Hackintosh installation I've ever done. Not a single kernel panic, nothing. Everything was working as expected.

To get HDMI audio working, you need to follow this guide:
http://www.tonymacx86.com/threads/new-automatic-hdmi-audio-script-released.184867/

After installing it and rebooting, be sure to head over to the system preferences and then audio and select the HDMI output / target device.


BENCHMARKS

Geekbench 32bit:


Cinebench:


Black Magic Speed Test:


Not exactly a benchmark but you can see the the Intel Turbo Boost is working and speeds up the CPU voltage to 3.82Ghz



KNOWN ISSUES

Waking up from sleep doesn't work with the 280x, the screen stays black after waking up. This seems to be a known issue with the Radeon cards in El Capitan (as far as I know).

The HDMI port of the graphics card doesn't seem to detect my monitor correctly and therefore sets the color profile to a default one which results in a bright, high-contrast image.

Audio over HDMI doesn't seem to work but I only tested it once with a different monitor that I connected my speakers to. This is not a huge problem as I'm using a headset only with this machine and the colors via the HDMI port are useless for my tasks (Photography / Video Editing / Graphics).

UPDATE 20.05.2016: HDMI audio now working thanks to this fix:
http://www.tonymacx86.com/threads/new-automatic-hdmi-audio-script-released.184867/

iMessage, Continuity & Handoff doesn't work, but I've never used these features in all the years working on a Mac.


FINAL WORDS

I'm very happy with the result and it couldn't have been easier to get it up and running. Everything is working fine, haven't encountered any problems so far besides the ones mentioned above.

If you have any questions or comments regarding this build, feel free to post them ;)


Update 20.05.2016: HDMI Audio working
 
Last edited:
Joined
Feb 6, 2016
Messages
5
Mac
Classic Mac
Mobile Phone
I tried this with my motherboard and it still won't boot. It just gives me this - boot0af: error - Any tips?
 
Joined
Oct 27, 2015
Messages
8
Motherboard
Asus Prime Z270-A
CPU
i7-7700K
Graphics
GTX 1080
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Could you share your system specs and BIOS settings?

Did you format your harddrive with MBR or GPT partition scheme?

MBR can cause the boot0af afaik.
 
Last edited:
Status
Not open for further replies.
Top